Java Runtime max memory configuration is too large

vseaslcm's Avatar

vseaslcm

19 Nov, 2020 02:14 AM

I have Moneydance 2021.2008 which fixed crashes experienced with 2021.2006. That's good. However, I've noticed that Moneydance is consuming large amounts of memory and has been for the last few releases. While looking at one of the JVM crash files, I noticed that the -Xmx JVM arguments for Moneydance is set to -Xmx80%. On my 32GB iMac, it is allocated -Xmx27488, which means that the Moneydance JVM runtime will increase its memory allocation until it hits 27GB of RAM. I normally keep Moneydance running all the time, but with this setting, I have to stop/start Moneydance on a daily basis to avoid its consumption of memory. It starts out relatively small, around 600MB and then goes up from there. After a day or two, it is in the 5GB range. On one occasion I had not cycled it for a while and it had gobbled up 12GB.

The -Xmx setting should not be set to 80%. Please consider changing this setting to a much smaller percentage of the total memory or making it user-modifiable. A reasonable setting could be as low as 2GB: "-Xmx2g".

  1. 1 Posted by tgilbert666 on 19 Nov, 2020 03:17 AM

    tgilbert666's Avatar

    I'm a fellow user with little to offer in the way of insight, but you might care to examine the moneydance.vmoptions file which - on Windows - is in my \Program Files\Moneydance folder. I imagine it's in the equivalent location on other platforms. The total of my knowledge comes from the contents of that file which will read something similar to the following:

    # Enter one VM parameter per line
    # For example, the following line sets the maximum memory usage to 1GB 
    
        -Xmx1024m`
    
    to set the maximum memory limit to 2GB, remove the # from the following line`
    #    -Xmx2048m`
    ..
    

    In the absence of more authoritive or complete advice, you may choose to experiment AFTER taking a backup of course! OTOH, I may be totally on the wrong track!!

  2. 2 Posted by jeff_l on 19 Nov, 2020 06:39 AM

    jeff_l's Avatar

    I think the first thing to do is to take a look at what MD Extensions you have installed. Out of date extensions are known to cause crazy memory issues. If you go to Help → Console Window in MD you should see a list of any out of date extensions. Either update them are remove them. Restart MD & go to the Mac OS Activity Monitor.

    Whilst writing this I have Activity Monitor running & MD is still only showing 472.2 MB memory usage on my Macbook Pro.

    I don’t think it is wise to keep MD running for days & days, mainly because it messes with the programs ability to create regular life saving backups.

    fellow user

  3. 3 Posted by Stuart Beesley ... on 19 Nov, 2020 07:59 AM

    Stuart Beesley - JUST A FELLOW USER's Avatar

    Yes. If I leave my MD running it grows in memory size to GBs too

  4. Support Staff 4 Posted by Maddy on 19 Nov, 2020 12:14 PM

    Maddy's Avatar

    Hi,
    Thank you for contacting Moneydance support.

    You can allow for more memory by editing the Moneydance.vmoptions file and set it to increase the amount of memory that Moneydance is allowed to use.
    To achieve this you can try the following.

    • Navigate to the Moneydance.vmoptions file, located in the folder where Moneydance is installed, so most likely c:\Program Files\Moneydance\Moneydance.vmoptions

    If you open that file with Notepad or any other text editor, you'll see some instructions for how to change it.
    The basic recommendation is to changing the -Xmx1024m setting to -Xmx2048m which doubles the amount of memory that Moneydance is allowed to use. You can give it more if you wish, E.g.: you make it -Xmx3000m, for optimal results.
    The limit is set deliberately low to enable it to work with computers having very small amounts of RAM.

    I hope this information is helpful. Please let me know if you have further questions or need any assistance.

    --
    Maddy, Infinite Kind Support

  5. 5 Posted by Stuart Beesley ... on 19 Nov, 2020 12:30 PM

    Stuart Beesley - JUST A FELLOW USER's Avatar

    Hi Maddy, out of interest does this file also exist on a Mac - where would I find it..? (or do you have to create it?)

  6. Support Staff 6 Posted by Maddy on 19 Nov, 2020 02:05 PM

    Maddy's Avatar

    Hi Stuart,

    Unfortunately there isn't a comparable vmoptions file for mac. We should consider making one, but it's not currently possible.

    Sorry I don't have better news in this sense.

    --
    Maddy, Infinite Kind Support

  7. 7 Posted by vseaslcm on 19 Nov, 2020 09:22 PM

    vseaslcm's Avatar

    Hi Maddy,

    Thanks for the quick reply. Since this issue is on a Mac, and there is no Moneydance.vmoptions file, it seems that the only workaround is to stop/start Moneydance regularly to avoid overallocation of memory. Would it be possible to initiate a change request for a future release that provides user-accessible configuration for the JVM options for Mac users?

    Thanks also to the users who chimed in with suggestions! Much appreciated. I do keep extensions updated. I can also confirm that the Backups preference to "Save backup daily" actually does not do an automated daily backup. It only performs the backup when Moneydance quits. Thus, this is another reason to stop/start more frequently.

  8. 8 Posted by Stuart Beesley ... on 19 Nov, 2020 09:39 PM

    Stuart Beesley - JUST A FELLOW USER's Avatar

    That is a very good point.....! Exit frequently to ensure backups...!!!

  9. 9 Posted by sprimost on 20 Nov, 2020 12:49 AM

    sprimost's Avatar

    From: sprimost ....just another user

    Backups are good. You can also achieve the same thing by File->Export
    Backup and save to the same archive directory. I do this every night
    after updating information like credit cards and mutual bond prices. I
    also have a daily job that sync's the archive directory to a disk on
    another system as well as backup manually on a weekly basis to a USB
    that hangs from a clip when not in use!

    There use to be a combination-key to perform the backup (like ctrl-S)
    but that has been subverted to initiating the sync process.

    Every couple of weeks I restart MD,,,not a big deal to keep it going.

  10. Support Staff 10 Posted by Maddy on 20 Nov, 2020 09:31 AM

    Maddy's Avatar

    Thanks for the suggestion for improving Moneydance! I've filed a ticket in our ticketing system with your suggestion, so the developers will be looking into it.

    Please let us know if we can be of further assistance!

    --
    Maddy, Infinite Kind Support

  11. Maddy closed this discussion on 20 Nov, 2020 09:33 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac