Accounts not auto-downloading at startup

Ted's Avatar

Ted

04 May, 2019 09:51 PM

I've switched laptops and installed 2019.3 (1870) on my new Win 10 computer. After downloading each account manually to save the passwords, I went to Preferences > Network > Automatically Download in Background.

I suspected auto downloads weren't working, so I left MD open for 10 minutes without doing anything. None of the accounts showed new transactions. Then I manually chose to Download All Accounts, and immediately the accounts started downloading and displaying updates. Is there something else I can do to determine why my accounts aren't being downloaded in the background at startup?

  1. 1 Posted by -Kevin N. on 04 May, 2019 11:25 PM

    -Kevin N.'s Avatar

    Hi Ted,

    I went to Preferences > Network > Automatically Download in Background.

    Did you then close Moneydance and restart it?

    It has been my experience that the option to d/l in the background initiates when opening Moneydance.

    -Kevin N. (not a member of MD support)

  2. 2 Posted by Ted on 04 May, 2019 11:35 PM

    Ted's Avatar

    Kevin, I did, and it's happened twice since I made the change, both after closing and re-opening MD.

    Thank you for the reply,

    Ted

  3. 3 Posted by Ted on 22 May, 2019 02:25 AM

    Ted's Avatar

    Transactions are still not auto downloading after numerous program and computer restarts. MD Staff, any ideas what else I can try?

  4. 4 Posted by Henry on 28 May, 2019 01:40 PM

    Henry's Avatar

    Hi Ted,

    Please accept my sincere apologies for the delay getting back to you. I’m afraid that your request for assistance was missed by the support team, and it’s only now we’ve been able to work through the backlog of older discussions.

    Would it be possible for you to attempt to connect again by first creating a new empty file and then adding the account again?
    To do this, you will need to open Moneydance and click on File > New > Create New File, then select the empty checking account from the sidebar and click on Online > Setup Online Banking, enable automatic downloads in preferences, restart Moneydance and let me know if you are successful with the empty file.

    --
    Henry, Infinite Kind Support

  5. System closed this discussion on 27 Aug, 2019 01:50 PM.

  6. Ted re-opened this discussion on 14 Jun, 2020 06:12 AM

  7. 5 Posted by Ted on 14 Jun, 2020 06:19 AM

    Ted's Avatar

    It took me almost a year to make any progress with this, but another issue forced me to restore from backup. As soon as I did that, sync was broken (different issue that I'm not trying to support here). To fix syncing, I used Derek Kent's excellent instructions and script to make my laptop with the backup file the master. As soon as I finished restarting MD, the transactions auto downloaded. When I re-set the additional slave systems to sync with my new master laptop, they do not auto download at startup even though the preference is set..

    In short, it seems that when using Shared Folder sync, only the master can auto-download transactions at startup. The slave computers can manually download transactions, but their auto-download doesn't work no matter how the settings are configured. It's probably an unintended consequence, but I wanted to share it with the public in case it helps anyone.

    Currently on Windows 10 2019.4 (1888) on the master laptop.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac