Problem Downloading Fidelity Investment Transactions using Pocketsense with Moneydance 2012

bosie88's Avatar

bosie88

23 Sep, 2016 10:55 PM

I've been using Pocketsense to download my Fidelity transactions with Moneydance 2012 for a number of months, ever since Moneydance's OFX downloader stopped working with Fidelity accounts. It had been working flawlessly until a couple of weeks ago, when it stopped downloading investment transactions from my Fidelity Brokeragelink account. The transactions from my Fidelity NetBenefits Account (401k) continue to download. I use the Fidelity Investments ofx server for the Brokeragelink account. I've checked to see if the addresses for these servers have changed recently, but they appear to be correct in my Pocketsense configuration files. I called Fidelity today and they were not able to give me any useful information about changes in their ofx servers.

Is anyone else experiencing the same problem? Using a csv to qif converter is a complete pain and I don't want to upgrade to Moneydance 2015 because of the horrible color scheme. I'll probably upgrade to 2017 if the color issue is fixed. But in the meantime, I would be interested in knowing if anyone else has experienced this problem or has found a solution. Thanks.

  1. 1 Posted by -Kevin N. on 24 Sep, 2016 01:17 AM

    -Kevin N.'s Avatar

    Hi bosie88,

    I'm using the following setting in sites.dat for Fidelity. I'm connecting to Fidelity Brokerage though. I'm not familiar with Fidelity Brokeragelink.

    <site>
        SiteName : Fidelity
        AcctType : INVSTMT
        fiorg : fidelity.com
        fid : 7776
        url : https://ofx.fidelity.com/ftgw/OFX/clients/download
        bankid :
        brokerid : fidelity.com
        appid :
        appver :
        mininterval:
        timeOffset :
    </site>

    HTH -Kevin N.

  2. 2 Posted by -Kevin N. on 24 Sep, 2016 01:56 PM

    -Kevin N.'s Avatar

    Hi bosie88,

    I was able to download a txn from Fidelity this morning with Pocketsense.

    Are you making any progress?

    -Kevin N.

  3. 3 Posted by bosie88 on 24 Sep, 2016 03:30 PM

    bosie88's Avatar

    Hi Kevin N. -

    Thanks for your help. Unforutnately no progress. I'm using the same settings for Fidelity as you are. There are no errors when I download from Fidelity. There are just never any new transactions.

    Brokeragelink is a regular Fidelity brokerage account that is linked and funded by your Fidelity 401(k) account in order to improve the available investment options. In the past, I've just treated it as a separate account from my 401(k) and have had no problem downloading my transactions into Moneydance. But since September 1, no new transactions have been downloaded even though I can see the transctions when I log into the Fidelity website.

    My hunch is that Fidelity has changed the way they view this linked account internally. Perhaps they now view it as part of the 401(k) account (Fidelity NetBenefits) and not a separate entity. But then the missing transactions should be viewable in the ofx file for NetBenefits and they are not.

    Fidelity has not been able to clarify what the issue is, although they did say that some Quicken users were having a similar problem and they are looking into it. In the meantime I suppose I'll just have to use the XL2qif addin to get these transactions into Moneydance.

    Hoping that Moneydance 2017 is a good build so I can stop jumping over hoops just to get my account information downloaded. I'm getting too old for this crap....

  4. 4 Posted by -Kevin N. on 24 Sep, 2016 04:10 PM

    -Kevin N.'s Avatar

    Hi bosie88,

    Back on 6/22/16, I received an email from Fidelity announcing that they will be rolling out a two-factor log on process within the next few months.

    I'm wondering if this is somehow effecting your access to their ofx server.

    Something else comes to mind. A while back Chase changed something with their access wherein I had to add ofxVer: 103 as a line item into the < site > information for Chase in sites.dat. The default is ofxVer: 102

    It might be worth a try to add ofxVer: 103 to your Fidelity < site > settings and see if it restores your access.

    HTH -Kevin N.

  5. 5 Posted by bosie88 on 25 Sep, 2016 03:32 PM

    bosie88's Avatar

    Hi Kevin N.,

    Tried changing the ofxVer value to 103, but am getting no new transactions from Fidelity. I will try to speak to someone from Fidelity again later on in the week to see if they have any new information. Very perplexing...

  6. 6 Posted by -Kevin N. on 25 Sep, 2016 04:07 PM

    -Kevin N.'s Avatar

    Hi Bosie88,

    Perplexing indeed. Post back after speaking with Fidelity or if you otherwise get it working. OK?

    I'm curious to hear of the solution.

    -Kevin N.

  7. 7 Posted by -Kevin N. on 25 Sep, 2016 04:54 PM

    -Kevin N.'s Avatar

    Hi Bosie88,

    I meant to post this earlier for you.

    There's a Pocketsense discussion board that you might want to post to with what you're experiencing.

    Maybe someone there has already been through it or maybe the developer can offer a tip or two.
    http://pocketsense.blogspot.com/2015/07/upgrade-to-windows-10.html

    -Kevin N.

  8. 8 Posted by Sam on 02 Oct, 2016 05:20 PM

    Sam's Avatar

    @boise88 -

    I was having the same issue you described above. I have a pcra tied to netbenefits account. I had been logging in to each individually to download transactions but the brokerage stopped working. I also spoke with Fidelity and they also suggested I create a new account and register it and it seemed odd to me... Until... I noticed that now the account number has changed .... Add a BLNK####### to your old account number. Also use the https://nbofx.fidelity.com/netbenefits/ofx/download instead of the old url settings.... <ORG>nbofx.fidelity.com<FID>8288</FI>

  9. 9 Posted by bosie88 on 02 Oct, 2016 05:59 PM

    bosie88's Avatar

    Thanks so much, Sam!

    That was it! I can't believe I spent over an hour on the phone with the tech people at Fidelity and they weren't able to communicate that to me. They kept saying that I needed to use the Netbenefits ofx server rather than Fidelity's but didn't tell me that I had to prepend "BLNK" to my account number. So I kept getting an unknown account error message when I tried to connect.

    How did you know to add the BLNK? I just went online to look at my account, and I cannot find a "BLNK" before the brokerage link account number.

    Thanks again. Problem solved....

  10. 10 Posted by Sam on 03 Oct, 2016 02:48 AM

    Sam's Avatar

    @boise88

    That is great news! I was receiving the same unknown account error message. I finally tried the following instead of requesting my account info and it returns back the account numbers for the login id/password combination... It looks like the transactions remain the same but acctid has changed. Hopefully anyone else that stumbles upon this will resolve it much faster.

    -Sam

    <SIGNUPMSGSRQV1>
    <ACCTINFOTRNRQ>
    <TRNUID>B2F07960-7B34-5678-8FF5-861BBD50026
    <ACCTINFORQ>
    <DTACCTUP>1990- not sure if this is needed
    </ACCTINFORQ>
    </ACCTINFOTRNRQ>
    </SIGNUPMSGSRQV1>

  11. 11 Posted by Jim Y on 20 Oct, 2016 03:25 PM

    Jim Y's Avatar

    I also want to thank you, Sam. That worked for me too. This voodoo is killing me...
    I was getting so depressed thinking about manually making the entries or the amount of work it would take to switch to Quicken or something else.

    Just to be clear to anyone else having this problem, you need to add BLNK to the front of the account number when setting up the account in pocketsense. I wasn't sure if you ment a "space" or if you meant BLNK#######. Sorry. Just me.

    Also, Sam, can you tell me exact steps you took to get Fidelity to list the accounts? Did you edit sites.dat?

    Thank you!!!!
    Jim

  12. 12 Posted by Sam on 20 Oct, 2016 04:43 PM

    Sam's Avatar

    @Jim Y-

    Unfortunately, I don't use Pocketsense but from looking at the site. It looks like I am doing something similar. I connect directly using OFX and have created my own scripts. I am not sure if Pocketsense has something similar that can be edited to display the account numbers but it sounds like it is possible.

    Sam

  13. System closed this discussion on 19 Jan, 2017 04:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac