MD keeps changing stock price I manually input

's Avatar

jannh5568

15 Aug, 2015 12:43 PM

I input a stock price of 654.8545 and MD keeps changing it to: 654.85466667. When I looked at the history, the price shows 654.8545. I tried deleting the transaction and re-entering it - same 8 decimals instead of 4. I tried deleting the stock and re-entering it - same thing happens. I have it set for 4 decimals, but cannot get it to hold the price I put in.

I don't download my investment information. I input all of it manually.

Help?

Thanks.

  1. 1 Posted by Ben Spencer on 15 Aug, 2015 01:01 PM

    Ben Spencer's Avatar

    Hi

    Please can you verify the version of Moneydance you are running. To do this run Moneydance and from the menu bar select Help->Console Window... Then copy and paste the output of the console window to this discussion.

    Ben Spencer
    Infinite Kind Support

  2. 2 Posted by JudyH on 15 Aug, 2015 06:09 PM

    JudyH's Avatar

    Hi Ben-
    Thanks for the response. File is attached. GOOG is the only stock that had that problem.

  3. 3 Posted by drangnon on 16 Aug, 2015 11:18 PM

    drangnon's Avatar

    I get this too, and with everything, not just GOOG. I'm on the latest preview downloaded from http://infinitekind.com/preview (becuase I will need the lot matching to work). when I imported my transactions from Quicken 2007 it overrode the share prices with its own idea of what would multiply into the cost of the shares and it also does this when I enter things manually.

    For example last night I caught up some mutual fund reinvestments. two screenshots attached. one the schwab web UI where it lists the transactions and the other what MD did when I entered them.

  4. 4 Posted by Ben Spencer on 16 Aug, 2015 11:36 PM

    Ben Spencer's Avatar

    JudyH

    Can you try updating to the latest preview version from the link below:

    http://infinitekind.com/preview

    drangnon, I am not certain the original poster an yourself have the same issue. Could you please post your issue in its own thread.

    Ben Spencer
    Infinite Kind Support

  5. 5 Posted by JudyH on 17 Aug, 2015 01:11 AM

    JudyH's Avatar

    Hi Ben - thanks for getting back to me.

    I did install the latest preview version from the link. The same thing happens with the Google short sale price: it goes out to 8 decimals. I noticed that if I take it out to just 2 or 3 decimals, it holds the correct price, but when I take it out to 4 decimals is when the problem starts. It will not let me put in only 4 decimals. It takes it out to the 8 decimals which rounds off the price to a different amount than it should be: instead of 654.8545, it shows as 654.85466667.

    I also just noticed that it had done that on another transaction when I had imported my earlier files from MS Money. That one was also for four decimals that MD changed to 6 decimals (but that price wouldn't have rounded up, so I didn't notice it before).

    Apparently MD doesn't like 4 decimals! Good thing I don't use them very often. Any ideas? It just won't let me put in the correct price!

  6. System closed this discussion on 19 Mar, 2016 05:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac