After the entry "mark as cleared", the entry data disappeared and the amount = 0

chan.pat93's Avatar

chan.pat93

02 Mar, 2018 02:53 PM

I upgraded from 2011r2(803) to MD 2017.6(1656). I use windows 10 64 bit.

As titled, when I finish inputting an entry (and before mark that entry as cleared), that entry is correct --> see attached file "Before Mark as cleared"

However, immediately after I marked the entry as cleared (i.e. with a green dot), the ticker (of the same entry) disappears and all the data (i.e. share no, price, commission) disappear and amount become 0 ---> see attached file "After Mark as cleared"

I have tried many times, but still get this problem. I have been using MD (803) many years to record my investment and 803 does not have this problem.

Hope MD support and experienced user can help me. Many thanks!

  1. 1 Posted by derekkent23 on 02 Mar, 2018 03:06 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    I don’t use Cleared in my investment accounts, but it looks like it has a similar bug as other registers. Once I have entered a transaction I have to click on another transaction then back before clearing.
    SUPPORT PLEASE NOTE.

  2. 2 Posted by sth on 05 Mar, 2018 02:30 AM

    sth's Avatar

    If you were editing the transaction you need to click on another transaction or use enter to actually make the changes.

  3. 3 Posted by flying.boy on 05 Apr, 2018 02:08 PM

    flying.boy's Avatar

    I am plagued by a similar problem, which manifests itself in various circumstances. In particular, I recently added a transaction to a group of 3 similar ones. I closed the amended transaction properly, then highlighted all four and right-clicked to mark all of them as cleared. Immediately the first 3 were marked Cleared and the 4th (new) one VANISHED. It could be found nowhere within the dataset. I retry the process and it behaves correctly(!)

    I frequently get recent transactions disappearing, or an amendment to a Duplicate Transaction not 'taking' when closed. I wonder if it is connected with the jittery mouse problem, which is a real nuisance for me. I use the Mac Magic Mouse (bluetooth)

    I'm using MD for Mac 2017.7.1 on 2 machines using MacOs 10.13.4 (High Sierra) and I synch using Dropbox folder. The dataset is in the default location (not on cloud) and I don't have both machines active together.

    I am beginning to lose confidence in the integrity of my data entry.

    I hope this helps

  4. 4 Posted by derekkent23 on 05 Apr, 2018 04:51 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    I know it’s a bug, losing a transaction if you try to immediately clear it, but until it gets fixed did you try the work around?

    I am using windows so don't have any mouse issues, but still get this particular problem if I forget to use the work around.

    Before right clicking on a transaction or a group of transaction you have just entered click on an old transaction then back to the new transactions and then right click to select cleared.

    Hope this helps

  5. 5 Posted by flying.boy on 05 Apr, 2018 05:03 PM

    flying.boy's Avatar

    Yes, derekkent, I picked up the workaround, and mostly use it. But there are unusual situations ( eg editing a category to point eg to a Suspense Account) where the record vanishes as soon as I hit Enter. Again, not reproducible!

    I'm going to start using a usb mouse to see what happens. A number of times a right click will have a cascade of unwanted actions. Usually moving to a different part of the screen is the only way to get a clean right click outcome.

    At present I'm growing anxious about disappearing records, because I can't know if this bug is affecting more than just the most recent edit. But I was hoping that offering the details of my experience of the problem might help the software development team.

    Thanks for helping.

    David

  6. 6 Posted by derekkent23 on 05 Apr, 2018 05:19 PM

    derekkent23's Avatar

    I am not support staff, just a user.

    At least for the bug, right clicking to clear a transaction as you enter it, is repeatable on both Windows and Mac computers, it should be looked at.

    SUPPORT PLEASE forward this issue to Sean, as it should be relatively simple to fix.

  7. 7 Posted by Henry on 06 Apr, 2018 08:09 PM

    Henry's Avatar

    Hi all,

    Thank you for reporting the issue.
    I attempted to reproduce it in both registers and I did not see the same.
    Would it be possible to get a description of steps needed to reproduce the issue?

    Henry
    Infinite Kind Support

  8. 8 Posted by derekkent23 on 06 Apr, 2018 10:08 PM

    derekkent23's Avatar

    Hi Henry thanks for following this up.

    2017.7.1(1671) windows 10.

    My example.

    In credit card register add a new transaction and complete the entry by pressing Enter key.

    See screen shot “Enter New Transaction – Sainsburys”

    Transaction is highlighted. Right click and select Mark as Cleared.

    See screen shot “After Right Click on Mark as Cleared”. Description, Category disappear. Charge changes to “0.00”

    If before right clicking you highlight another transaction then move back to highlight the new transaction and right click and select Mark as Cleared all works as it should.

    Derek

  9. 9 Posted by derekkent23 on 06 Apr, 2018 10:08 PM

    derekkent23's Avatar

    Screen shots, next post

  10. 10 Posted by derekkent23 on 06 Apr, 2018 10:10 PM

    derekkent23's Avatar
  11. 11 Posted by Henry on 07 Apr, 2018 04:19 PM

    Henry's Avatar

    @derekkent23

    Thank you for the description of steps, I had a few difficulties reproducing the issue at the start, if the preference setting 'Auto-create new transactions' is ticked the issue isn't present.

    I've informed Sean about the issue and will notify you here as soon as I get an update.

    Henry
    Infinite Kind Support

  12. 12 Posted by derekkent23 on 07 Apr, 2018 05:26 PM

    derekkent23's Avatar

    Hi Henry, good call.

    My 'Auto-create new transactions' is NOT ticked.

  13. 13 Posted by flying.boy on 07 Apr, 2018 06:01 PM

    flying.boy's Avatar

    Very interesting. And an amazing spot!

    I, too, had been operating with 'create new transaction' flag cleared.

    I've just set the flag. While I haven't got real transactions to enter (and I am supposed to be on a break from the accounts this weekend!) I tried a few basic manipulations and everything 'feels' better.

    I'm impressed with the support effort evident here.

    David

  14. 14 Posted by Henry on 09 Apr, 2018 10:24 AM

    Henry's Avatar

    @ All,

    I checked with our lead developer and he confirmed that he will fix the issue, I unfortunately don't have a timeline for that, he also said that as a temporary workaround clicking on the little square in the C column to select the reconciliation status is also an option.

    Thank you all for bringing this forward and I apologize for the inconveniences caused.

    Henry
    Infinite Kind Support

  15. 15 Posted by derekkent23 on 30 May, 2018 07:56 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    I looks like this issue has been fixed in preview build 2017.8(1677) from https://infinitekind.com/preview

    Thanks Sean

  16. System closed this discussion on 29 Aug, 2018 08:00 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

17 Jun, 2024 11:18 PM
17 Jun, 2024 10:10 PM
17 Jun, 2024 09:48 PM
17 Jun, 2024 07:29 PM
17 Jun, 2024 07:00 PM