stocks not updating correctly

Sang Mun's Avatar

Sang Mun

20 Dec, 2019 12:46 PM

I recently added a new stock to my investments and noticed it was not getting updated so I double checked to make sure I was using the correct stock symbol for Home Depot (HD). I checked the Quotes and Exchange Rates Settings and I do have the box "Only show securities that I own". I checked the console log and saw that only 3 of 5 that I own had updated. I unchecked the box "Only show securities that I own" and tried to update again and HD updated. I had a similar problem with AAPL previously. My thinking is that option is preventing the latest stock from being added to the securities sent to Alpha Advantage. I selected the option again so I will see if HD updates like it should.

  1. Support Staff 1 Posted by Maddy on 20 Dec, 2019 06:02 PM

    Maddy's Avatar

    Hi Sang,

    We are sorry to hear about the problem you have encountered.

    Can you check you're running the latest version of the Quotes and Exchange Rates extension? To do this, choose Extensions --> Manage Extensions. The latest version of the extension is v.1024. You should see an 'Update' button if you're using an older version, or remove the extension and re-install.

    Can you also check which version and build of Moneydance you are running?
    To do this, open Moneydance and select Help --> About Moneydance (or Moneydance --> About Moneydance on a Mac) where the version and build number will be displayed.

    Moneydance previously obtained rates using Yahoo, but unfortunately they stopped supporting downloads to third party applications in the last year or so. Since then we've been trying to locate other services we can include, but few are free and reliable. We currently use Alphavantage and IEX Trading.

    Alphavantage worked well for some time, but recently changed their services and introduced a premium membership. This has limited the number of downloads per minute for free accounts, so you may find the updates are slower.
    We've included IEX trading as another source for updating rates. This website includes a list of eligible symbols IEX trading uses - https://iextrading.com/trading/eligible-symbols/

    Recently, a knowledgeable Moneydance customer and developer (Mike Bray) has created a third party extension called 'Quotes Loader'. This extension doesn't adhere to the same limitations as the program and is able to connect with Yahoo. You can find more information about the extension in this thread(the latest free third-party Quote Loader is post 205) from the public discussion board.
    Download the PDF attached to post 205 and have a read.

    To get an overview take a look at the YouTube video by using the link on page one of the PDF.

    I hope this information is helpful. Please let me know if you have further questions or need any assistance.

    --
    Maddy, Infinite Kind Support

  2. 2 Posted by Sang Mun on 20 Dec, 2019 09:58 PM

    Sang Mun's Avatar

    I am on the current build for Moneydance itself but the extension is
    back at 1020 which I will update. I don't think there is a problem with
    Alphavantage providing quotes as much as a bug in the way the securities
    list is handled. You can check with the programming team but I think
    when a new security is added, the view is being updated on the "Quotes
    and Exchange Rates Settings" with the new security but with "Only show
    securities that I own" checked, the securities list that will be sent is
    not refreshed. When I unchecked the box and then checked it back, I
    think it updated the securities list. I tried today after market close
    to do the update and all 5 securities updated. I will leave myself a
    note to check if I add a new stock to see if the quotes update correctly
    or not.

  3. System closed this discussion on 20 Mar, 2020 10:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac