Security prices update

norfolkjp's Avatar

norfolkjp

11 Nov, 2015 12:30 PM

I can't get security prices to update. When I update, I get the message 'no data found'. Does this service work in the UK and if so what settings should be used? On the update page, I have set the Stock Exchange as 'London Exchange (GBP)' and I have entered the six digit LSE ticker in the Ticker Symbol field of each security (the security price update in the UK seems to be provided by Yahoo! Finance (UK & Ireland)).

  1. 1 Posted by Tom Freeman on 11 Nov, 2015 06:30 PM

    Tom Freeman's Avatar

    The extension works by going to the Yahoo finance page, retrieving an download file made available there, then importing that into MD.

    Unfortunately Yahoo support for Non-US funds can be spotty. One way to test is to go to the yahoo finance page for that security, scroll down to the bottom right for the toolbox, click on the link downloadable file. Open that in a spreadsheet app to confirm that it ti populated.

    One helpful hint it to have the extension set to Yahoo USA, even if you have the exchanges set to London exchanges.

    If you can send a screen shot of your extension page, I can confirm if the set up is correct.

    Tom Freeman
    Infinite Kind Support

  2. 2 Posted by kai_hooch on 06 Dec, 2015 02:16 PM

    kai_hooch's Avatar

    I have the same problem but this only started after I updated to the latest version of moneydance. I have updates set to Yahoo Finance Uk and London Exchange (pence) and this worked fine before. I've tried Yahoo USA and switching to £ instead of pence but nothing works. The error message I get is input data was not text.

  3. 3 Posted by Ben Spencer on 06 Dec, 2015 02:32 PM

    Ben Spencer's Avatar

    Can you give me an example ticker symbol that is not working for you.

    Ben Spencer
    Infinite Kind Support

  4. 4 Posted by kai_hooch on 11 Dec, 2015 07:57 AM

    kai_hooch's Avatar

    Thanks Ben, I could give an example (Centrica ticker symbol = CNA) - but the problem seems to be fixed! All are updating OK again now. Many thanks

  5. 5 Posted by Tom Freeman on 12 Dec, 2015 12:15 AM

    Tom Freeman's Avatar

    Sometimes Yahoo support for UK funds is spotty. hey usually correct it eventually. Please let us know if there are further issues.

    Tom Freeman
    Infinite Kind Support

  6. Tom Freeman closed this discussion on 12 Dec, 2015 12:15 AM.

  7. norfolkjp re-opened this discussion on 12 Dec, 2015 11:26 AM

  8. 6 Posted by norfolkjp on 12 Dec, 2015 11:26 AM

    norfolkjp's Avatar

    Following the guidance in kai_hooch's message yesterday, I also am now
    successfully getting security prices through - I wonder how many other
    users in the UK have had the same problems and simply given up, like me
    'til now! The breakthrough was kai's revelation that the ticker code he
    used for Centrica was CNA, which is the EPIC code. I tried this,
    experimenting with various settings until something finally came
    through. The settings for someone in the UK would seem to be as follows:

    /Source: Yahoo Finance USA/ - nothing at all comes through if source set
    to Yahoo Finance UK
    /Stock Exchange: London Exchange (Pence)/ - this works for most
    securities, but not if a fund has a non-GB ticker code (see below)
    /Ticker code: EPIC (for individual equities, e.g. Centrica); ISIN (for
    funds)//- /N.B. the EPIC code will not work for funds; the ISIN code
    will not work for individual equities.

    Some funds are not quoted on the London Exchange. The ISIN code for
    funds quoted on the London Exchange begins with the letters GB (e.g.
    Invesco Perpetual Income Class Y Income - GB00BJ04HX60). For funds
    quoted on other exchanges the ISIN code begins with two different
    letters, e.g. IE = Irish Stock Exchange; LU = Luxemburg (EBS). For
    these funds, the 'Stock Exchange' should presumably be set to the
    relevant exchange. I have tried setting the IE stocks to 'Irish Stock
    Exchange' (e.g. Lindsell Train Global Equity Class D Income -
    IE00BJSPMJ28). I get a price through, but the price is in GB Pounds
    whereas Moneydance automatically treats it as in Euro. The only
    solution that I can see to this would be to create an additional field
    in 'Quotes and Exchange Rate Settings' for the currency of the quote.

    Finally, for some reason no quotes are available for any of the Jupiter
    funds, a major UK fund manager (e.g. Jupiter Financial Opportunities -
    GB00B8JYV946). This seems strange - would it be possible to raise this
    with Yahoo?

    Kind regards
    Jeremy

  9. 7 Posted by norfolkjp on 12 Dec, 2015 11:26 AM

    norfolkjp's Avatar

    Following the guidance in kai_hooch's message yesterday, I also am now
    successfully getting security prices through - I wonder how many other
    users in the UK have had the same problems and simply given up, like me
    'til now! The breakthrough was kai's revelation that the ticker code he
    used for Centrica was CNA, which is the EPIC code. I tried this,
    experimenting with various settings until something finally came
    through. The settings for someone in the UK would seem to be as follows:

    /Source: Yahoo Finance USA/ - nothing at all comes through if source set
    to Yahoo Finance UK
    /Stock Exchange: London Exchange (Pence)/ - this works for most
    securities, but not if a fund has a non-GB ticker code (see below)
    /Ticker code: EPIC (for individual equities, e.g. Centrica); ISIN (for
    funds)//- /N.B. the EPIC code will not work for funds; the ISIN code
    will not work for individual equities.

    Some funds are not quoted on the London Exchange. The ISIN code for
    funds quoted on the London Exchange begins with the letters GB (e.g.
    Invesco Perpetual Income Class Y Income - GB00BJ04HX60). For funds
    quoted on other exchanges the ISIN code begins with two different
    letters, e.g. IE = Irish Stock Exchange; LU = Luxemburg (EBS). For
    these funds, the 'Stock Exchange' should presumably be set to the
    relevant exchange. I have tried setting the IE stocks to 'Irish Stock
    Exchange' (e.g. Lindsell Train Global Equity Class D Income -
    IE00BJSPMJ28). I get a price through, but the price is in GB Pounds
    whereas Moneydance automatically treats it as in Euro. The only
    solution that I can see to this would be to create an additional field
    in 'Quotes and Exchange Rate Settings' for the currency of the quote.

    Finally, for some reason no quotes are available for any of the Jupiter
    funds, a major UK fund manager (e.g. Jupiter Financial Opportunities -
    GB00B8JYV946). This seems strange - would it be possible to raise this
    with Yahoo?

    Kind regards
    Jeremy

  10. 8 Posted by derekkent23 on 13 Dec, 2015 12:59 PM

    derekkent23's Avatar

    I have had similar problems with downloading security prices. I made some suggestion to improve the situation and the reply was “Thanks for the suggestion for improving Moneydance! I've passed your feedback onto the developers, so they'll be taking it into consideration”, but no update has yet been forthcoming. Take a look, http://help.infinitekind.com/discussions/suggestions/9255-quotes-an... The more people that request an improvement to the Quotes and Exchange Rates Extension the more likely it is to happen. At the moment I am updating prices manually using the “Security Price Entry” extension.

  11. 9 Posted by norfolkjp on 14 Dec, 2015 08:48 AM

    norfolkjp's Avatar

    What would help as an interim measure would be a report at the end of a
    securities price update listing those securities for which the update
    failed, so that these can be updated manually. If there is some way of
    getting this information already, other than checking each individual
    security, it would be very helpful to know.

  12. 10 Posted by Ben Spencer on 14 Dec, 2015 03:10 PM

    Ben Spencer's Avatar

    You can have the system run a test to tell you which securities updated correctly. To do this:

    From the menu bar select Extensions->Quotes and Exchange Rates...
    Click the "Advances >>" link on the right hand side.
    Click the "Test" button on the bottom left.

    Ben Spencer
    Infinite Kind Support

  13. 11 Posted by phil on 09 Mar, 2016 12:26 PM

    phil's Avatar

    I've found the same problem as norfolkjp regarding GBP funds on the Irish Stock Exchange. For example, IE00B1S75374, the Vanguard UK Government Bond Index, is listed on the Irish Exchange, but its price is in GBP.

    So the Quotes and Exchange Rates Updater fetches the price (say, 150.00) and says it's in Euros, when it's actually in GBP. Even only doing the Updater's 'Test' fetching, it changes the Currency of the security - if I subsequently open the security's History window, its Currency gets set to Euro, even when I've manually changed it to British Pound. This also screws up the graph of previously-manually-entered prices until I change the Currency back again.

  14. 12 Posted by Tom Freeman on 09 Mar, 2016 09:55 PM

    Tom Freeman's Avatar

    In the extension set the exchange to the Irish stock exchange. Then right click the exchange field and set the currency to GBP.

    Tom Freeman
    Infinite Kind Support

  15. 13 Posted by phil on 10 Mar, 2016 10:37 AM

    phil's Avatar

    Thanks Tom, but I'm a bit stumped. If I right click (Control click, as I'm on a Mac) on the exchange field I just get the same drop-down menu to select the exchange that I do if I normal-click on it. The London exchange has options for GBP or pence, but there's only one Irish exchange. Am I missing something?

  16. 14 Posted by phil on 15 Mar, 2016 07:03 PM

    phil's Avatar

    I wondered if this wasn't working for me because I was still on Moneydance 2014, but I've just updated to 2015.7 and still no joy. If I Control-click on anything it's just the same as if I do a standard click. How do I get it to work as it did for you? Thanks.

  17. 15 Posted by Tom Freeman on 18 Mar, 2016 06:55 PM

    Tom Freeman's Avatar

    I asked a mac person and they said if you have a two button mouse you can right click to bring it up or if using a touch pad, a two finger tap. I have attached an image as to what you are looking for.

    Tom Freeman
    Infinite Kind Support

  18. 16 Posted by phil on 21 Mar, 2016 09:19 AM

    phil's Avatar

    That's strange... In general, on a Mac, doing a Control-click behaves exactly the same as right-click with a two-button mouse, or a two-finger-tap on the trackpad (if that option is enabled in System Preferences). But it seems that in Moneydance that's not the case.

    In the Quotes and Exchange Rates Updater, if I Control-click on something it behaves exactly the same as a standard (left) click. So Control-clicking the exchange drop-down menu opens the drop-down menu. But a two-finger-trackpad tap or a right-click on a two-button mouse on the menu does the trick. Which is peculiar and impossible to predict.

    Even aside from that, having a drop-down menu act as a button, not a drop-down menu, when it's right-clicked doesn't seem very intuitive.

    But thanks for your help in figuring out the UI.

  19. Ben Spencer closed this discussion on 21 Mar, 2016 04:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

27 Sep, 2022 12:49 PM
27 Sep, 2022 12:37 PM
27 Sep, 2022 12:23 PM
27 Sep, 2022 10:40 AM
27 Sep, 2022 07:22 AM