can't enter quantity in investement purchase

Nick Pell's Avatar

Nick Pell

27 Aug, 2021 09:25 AM

Using MD 2021.1 (3069) on Imac Catalina 10,15,7
I created a new account in euro for my investments in cryptocurrencies and then I set up cryptocurrencies as securities, with their RIC from yahoo finance (for example BTC-EUR for bitcoin)
I started with a purchase of bitcoins and all went well. Then I added a second security (Cardano cryptocurrency) but for mysterious reasons when I tried to enter the transaction, it would not maintain the qty purchased! I enter the number and when I move to the total amount of the transaction (so the price is calculated automatically), the qty is deleted and the field returns empty!
I also tried to enter first the price then the total, or the quantity and the total but nothing! all I get is blank fields!
I also cancelled all transactions, securities and account and start all over from scratch! Nothing!!!!! same problem
I even replaced the whole data file with a backup copy from Apple's Time Machine and start from scratch. NOTHING
Any NEW security (besides the first one) that I try to add to this account have this problem. All OLD, already existing securities added to this new account works fine
PLEASE HELP

  1. Support Staff 1 Posted by Maddy on 27 Aug, 2021 09:33 AM

    Maddy's Avatar

    Hi Nick,
    Thank you for contacting Moneydance support.

    Adding a security to an investment account simply makes that security available for use within that investment account. Technically adding a security to an investment account creates a sub account in the investment account priced in that security as a place to hold the number of shares in that security you own.

    After you add a security to an investment account you need to enter a buy transaction to increase the number of shares you own. Go into the investment register and click the new transaction button. Set the type of the transaction to Buy.

    This will reduce the amount of cash in the investment account to pay for the buy. If you are simply wanting to reflect preexisting holdings you can set the initial cash balance of the investment account to cover these buys. To do this go into the investment account and select Edit Account from the Account menu.

    I hope this information is helpful. Please let us know if you have further questions or need more assistance.

    --
    Maddy, Infinite Kind Support

  2. 2 Posted by Nick Pell on 27 Aug, 2021 09:40 AM

    Nick Pell's Avatar

    Maddy, what you say is very obvious! That is exactly what I'm doing and where encounter the problem! Please read carefully my initial message.
    FYI I updated MD to 2021,2 (3095)
    And finally I attach here the details of the transaction I entered and gave the wrong results. The system simply does not calculate the price/qty/total!

  3. 3 Posted by Stuart Beesley ... on 27 Aug, 2021 11:48 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    What is the decimal place setting for the security? How many decimal places are u trying to enter?

    If not sure, install toolbox extension. Current tools menu. Show hidden decimal place settings.

    If it’s wrong and this is a new security then try creating a new security with the right dpc and try again.

    (Not support, just a fellow user)

  4. 4 Posted by Nick Pell on 27 Aug, 2021 12:04 PM

    Nick Pell's Avatar

    Spot on Stuart!!!!!
    dpc was set at 20!!!!
    I created a new security with 8 decimal points and everything worked perfectly!
    Thank you again for your help
    PS: You should be in the real support group! And toolbox extension is very cool!

  5. 5 Posted by Stuart Beesley ... on 27 Aug, 2021 12:16 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Toolbox 🧰 +1 😃 👍

  6. Maddy closed this discussion on 27 Aug, 2021 12:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac