New iPad not sync with computer.

sprimost's Avatar


13 May, 2019 10:16 PM

Linux system (Ubuntu 18.04) with Moneydance 2019.1
iPad (sixth Generation) with latest iOS, (fresh from the box). (Multiple processes trying Dropbox folder and Connection)
[Note, since everything did not work properly, when I initially tried to sync the iPad with the computer, I decided to start all over!)
The very first time I installed the app on the iPad, I had to sign-in to Dropbox from the iPad, which I did through Google.
I thought I understood sync process. With a new iPad, I reasoned that I would have to reset everything, and followed the following:

On computer set Don’t Sync as the syncing method.
On the iPad app Disconnect. (It had not worked when I just added the iPad initially.
Since I have the Dropbox Client installed on my computer, I deleted the “.moneydancesync” folder in Dropbox.
I exited MD on computer, and restarted MD. (Strangely, it recreated the ".moneydancesync" folder.)
I initialed sync from the computer, for instance Dropbox folder. notification on the bottom of the screen indicated sync completed. Did a ctl-S to save the data and it indicated data saved and sync completed.
On the iPad: Case 1 -- I started sync where I did not re-install the app. It immediately came back as sync'ed but the wrong data (from a previous sync). Obviously, nothing ever sync'ed either adding transactions to either end.
On the iPad: Case 2: uninstall the app on the iPad, and re-install. Starting the app shows and empty transaction log (expected), and when initiating the sync, it keeps cycling for over 2 hours.

Then, I looked at my Dropbox account, and saw that I had more than 3 devices linked to it; one of them was an iPad (the old one). I pruned down to two (realy should not have a couple of them for security reasons, and when I do need files, there is always the browser interface).. I uninstalled and re-installed the MD app, disconnected from Dropbox, and resigned in. Security shows the Safari browser, which is correct. The sync was initiated, and still hung waiting, waiting..... (about an hour so far)

What am I doing wrong?

This iPad replaced an iPad 2 that had given gallant service for over 14 years! {a full dressed military funeral will be given).

  1. 1 Posted by sprimost on 15 May, 2019 07:27 PM

    sprimost's Avatar

    I have solve this problem; iportant to note what was wrong and how it can be fixed.

    The first indication that the iPad is not sync'ing with the (Linux/Ubuntu 18.04) computer system is when you attempt to sync on the iPad. The correct display after clicking on Dropbox logo, is for a list of databases to use for sync'ing; (The Dropbox for under .moneydancesyc has two files, one of which contains the name of the Moneydance set of files currently used on the computer.. If that is not displayed, and you click on sync after entering the Moneydance dropbox password, it will (forever) wait for the initialize file. (could not find the file. ++definite sign that the computer is going to one version of Dropbox folder, and the iPad is going to another version, one of which is an outdated cache.

    The tricky part is to get them both to point to the same directory. The issue is probably with the iPad! You will need to _completely_ sign out of Dropbox, and go through the process of signing in to Dropbox on the iPad, and then signing into Dropbox for Moneydance, and finally allowing Moneydance to use Dropbox files. If you don't perform all three, then you have not signed out! Another thing I did was to sign-in using the Dropbox credentails rather than allow a signin through my Google credentials. (complicated by the fact that the Ipad is running under my wife's google credentials and not mine (do not share username/password for security).

    Insome cases, exiting the application and starting it might help but not having the opportunity to select the database is a big warning that it is not going to work!

  2. sprimost closed this discussion on 15 May, 2019 07:53 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac