TD Credt Card Data Imports Incorrectly

lroche's Avatar

lroche

15 Dec, 2019 05:23 PM

When importing transactions from TD Credit Card Services website, all of the charges end up in the payments column and all of the payments import into the charges column. All of the payments also import as the 1/1000 times the actual amount. 1,247.24 imports as 1.24. Also four transactions from past periods keep importing over and over. Two of these are charges, and two are payments. All four are divided by 1000. Lastly, each time the prior month's transactions are imported, the number of transactions multiplies by the number of imports. There are 117 transactions in the month so the first time they imported, 117 transactions appeared in Moneydance. After deleting and trying to reimport the same data, 234 transactions appear in Moneydance. On the seventh import, 819 transactions appear. I downloaded the trial version that is available on the Infinitekind website and have unchecked the "Ignore transaction types..." box as instructed, but did not notice any improvement.

I do not know where to go from here, any assistance would be appreciated.

  1. 1 Posted by wadivkarts on 15 Dec, 2019 07:27 PM

    wadivkarts's Avatar

    I have the same issues with the debits and credits being interchanged. So am awaiting an answer on that.
    But regarding the 1/1000 amounts, that is due to the delimiter. While importing, select the decimal rather than the comma as a separator.

  2. 2 Posted by lroche on 15 Dec, 2019 08:09 PM

    lroche's Avatar

    Wadivkarts:

    I am importing QXF data and do not recall having any option to modify how the records are delimited. Am I missing something?

    Thanks for any direction you can offer on this in advance.

    Sent from my Verizon, Samsung Galaxy smartphone

  3. 3 Posted by lroche on 21 Jan, 2020 11:35 AM

    lroche's Avatar

    I found a work around. Moneydance now has a problem importing QFX data from TD Credit Card. It worked fine for years prior to November or December of 2019, but something has changed. Until they figure this out, I have been able to export data from TD Credit Card to a csv file. I then open it in excel, add a column to the right of the amount column, move the credit amounts into this new column and import. This gets the charges and credits into the correct columns.

  4. Support Staff 4 Posted by Maddy on 21 Jan, 2020 12:17 PM

    Maddy's Avatar

    Hi,

    Within the latest version, Moneydance 2019.3 (1880) you can find a feature called

    "Ignore Transaction Types in Favor of Amount Signs", in the Network tab of the settings, which should fix the problem for you.

    Please let me know if you have further questions or need any assistance.

    --
    Maddy, Infinite Kind Support

  5. 5 Posted by lroche on 25 Jan, 2020 02:54 PM

    lroche's Avatar

    Maddy:

    I followed your instructions below and downloaded my December transactions from TD Credit Card Services but it did not fix the problem. The charges are all in the payment column and the payments, or credits are all in the charge column. Also the payments are off by a factor of 1000. A 1,000.00 payment imports as 1.00. There are other problems as well, the download included payments, divided by 1,000, from three or four prior months. It also imports duplicate transactions. Importing via QFX is not working for me at all. I am going to stick to importing by .csv file and modify it as I described below.

    Thanks,

    Chip Roche
    Newfab Inc.
    928 Minot Avenue
    Auburn, ME 04210-3719
    Phone: 207.786.2446. Ext. 201
    Website: www.newfabinc.com<http://www.newfabinc.com/>

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac