TIAA online connection broken

feffer777's Avatar

feffer777

20 Jan, 2020 05:41 AM

I was able to set up and use MD online banking with my TIAA-CREF account. Previously, it worked normally. However, now an error appears while trying to download from that account.

"Error Description: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found"

I tried creating a new connection in MD, and chose TIAA-CREF in the drop-down menu, then NEXT; now a screen appears with a blank box for "Broker ID" and another under it with my account number. I have no idea what to put in the blank "Broker ID" box. If I leave it blank or put "none" and hit next, MD says it has "most of the info needed for a connection" and offers a "Finish" button. However if I hit "Finish" no connection seems to be created and MD does not offer the choice of Ctl-D (Download data) for that account.

When trying to make a new connection, I tried going to the "Advanced" screen where I could fill out various TIAA OFX items, but I don't know the proper fill-ins.

I looked thru the MD forum knowledge-base and discussions, found some related things but don't know how to get my connection back.
Is the "Broker ID" box info something I can get from TIAA? How can I fix the "No Trusted Certificate" issue.

All my other FI do the web-connect downloads properly. I'm using MD 2017.7.1 (1671)

  1. 1 Posted by feffer777 on 21 Jan, 2020 01:01 AM

    feffer777's Avatar

    Seems to be a version issue. Upgraded to the latest MD version and redid the connection to my TIAA-CREF accounts. Works fine now.

  2. System closed this discussion on 21 Apr, 2020 01:10 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac