Problem with Python Remove All Services script

wa1oui's Avatar

wa1oui

21 Jul, 2020 06:55 PM

In an attempt to solve a Direct Connect problem in a previous discussion here, I thought maybe the database, file/db, or however the connections are stored had gotten corrupted so I reluctantly tried to run a four line remove_all_services.py script. That failed with a macOS permissions error (attached). I then searched the public discussions and found a newer much longer version which I tried and received the same error. Usually I can open apps from unknown developers using the CTRL-Open trick, but I have no way of doing that with this system (that I know of). I'm running the latest macOS Catalina 10.15.6 on MD 2019.3.

Sooo. can anyone tell me which script to run and how to get it to run?

  1. Support Staff 1 Posted by Ethan on 21 Jul, 2020 08:42 PM

    Ethan's Avatar

    Hello,

    I believe I just responded to your other current thread on your Bank of America connection. We can try to run this script if you want, but it likely won't have any effect on a username/password error. If the issue were the connection information itself, you'd be getting different kinds of errors, likely before you were even able to enter in your login information.

    I'm not quite sure what exactly you're clicking on with CTRL-open to run the script. You shouldn't have to click on the script itself to run it. Here are more complete instructions:

    Before proceeding, take a manual backup via File --> Export Backup.

    To use the .py file, first save it to your computer and then follow these steps:

    1. In Moneydance, select Window --> Python Scripting (Choose 'MoneyBot' if you're using the 2019 version).
    2. In the window that opens, select 'Open Script' then navigate to the .py file wherever you saved it on your system.
    3. Select 'Run' to execute the file.
    4. You will be asked to select which connection you want to clear. Choose your bank, and click OK. You'll get a confirmation message when the connection has been removed. Close the window when done.
    5. Set up the connection to your bank like normal choosing the "New Connection" button. Since all of your settings have been cleared, you should get the most recent connection information for your bank.

    Again though, I haven't heard any reports that Bank of America's connection has changed, and a login error would not be the kind of error you should get if they have.

    Ethan
    Infinite Kind Support

  2. 2 Posted by wa1oui on 21 Jul, 2020 10:23 PM

    wa1oui's Avatar

    Hi again,

    I guess I wasn’t clear with my CTRL-open comment. Other apps that Apple doesn’t like can be run if you once open them with CTRL-open. Since this is not an app but apparently a library of sorts there is no open button to use the CTRL-open trick.

    I had been hoping to clear the entire database at one time, but can try the single shot approach, although I had already tried disabling Direct Connect and then re-establishing it. Don’t forget that BoA apparently does recognize a correct name/PW as it tells MD the list of my accounts with that web account and I choose the proper one. Then it all goes bad and I can’t get in. Sort of points to BoA on one hand, yet on the other I can’t know what MD sends through to them the second time. I’ll try a single delete via python (if it runs) and report back, but I still would like to be able to do a complete wipe.

    1) Which complete wipe should I use, a 4 line one or a more complex one I found… I can post them if you’re not familiar with them.

    2) How do I tell macOS to accept the dylib that’s referenced in the attachment?

    Thanks,

    David

  3. 3 Posted by wa1oui on 21 Jul, 2020 10:27 PM

    wa1oui's Avatar

    OK, the single account direct connect delete bombs as will on a different dylib... now what?

  4. Support Staff 4 Posted by Maddy on 22 Jul, 2020 11:07 AM

    Maddy's Avatar

    Hi,

    The python script will not run under Catalina unless you change your Security & Privacy setting in the OS, as shown in the screenshot attached.

    --
    Maddy, Infinite Kind Support

  5. Maddy closed this discussion on 22 Jul, 2020 11:07 AM.

  6. Maddy re-opened this discussion on 22 Jul, 2020 11:09 AM

  7. 5 Posted by wa1oui on 22 Jul, 2020 01:23 PM

    wa1oui's Avatar

    Thanks. That didi it! I'm familiar with that error, but normally either System Prefs pops up or I'm told to go there... this time I needed your help. NOW you can close the discussion. : )

  8. Support Staff 6 Posted by Ethan on 22 Jul, 2020 03:47 PM

    Ethan's Avatar

    I'm glad to hear that's been sorted out! Please let us know if we can be of further assistance,

    Ethan
    Infinite Kind Support

  9. Ethan closed this discussion on 22 Jul, 2020 03:47 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac