Not able to save file after Mac OS X Snow Leopard upgrade

Marc Miller's Avatar

Marc Miller

11 Sep, 2009 10:40 AM

Since installing OS X Snow Leopard upgrade, every time I try to save changes to Moneydance, I get an error saving file message saying that permission is denied. Any help on this is appreciated, Marc

  1. 1 Posted by Ben Spencer on 11 Sep, 2009 01:02 PM

    Ben Spencer's Avatar

    Hi Marc

    Please check the location that you are trying to save your moneydance data file. It is possible that your operating system upgrade has changed the permissions on that folder. Navigate to the folder in question with finder and press command-I to bring up the permissions window. Make usre that you have write permission for the folder.

    Sincerely

    Ben Spencer

  2. 2 Posted by Marc on 12 Sep, 2009 04:29 AM

    Marc's Avatar

    Ben, hi. Following your suggestion, read and write was already set for me. I changed admin and everyone to read and write from read only just to see if that would help. The problem of not being able to save still occurs. I noticed that looking with Control I at the file, even if I open and close MoneyDance, it is still showing the file created 8/31/09 6:35am (before I did the SL upgrade), modified today, and last opened 8/31/09. I don't know if that helps with the next step of problem diagnosis / solving. Thanks again, Marc

  3. 3 Posted by Ben Spencer on 12 Sep, 2009 01:18 PM

    Ben Spencer's Avatar

    Hi Marc

    Is the location you are trying to save too on the local machine ot is it on a remote server or external drive? If it is not on a local drive it might be that SL is not mounting the path at startup.

    Would you please try saving the file to a location I am certain you should be able to write to, such as the desktop. Select File->"Save As" and put the new save file on the desktop.

    Thank you for your patience.

    Sincerely

    Ben Spencer

  4. 4 Posted by Marc on 12 Sep, 2009 02:45 PM

    Marc's Avatar

    Ben, I should thank you for your patience and suggestions. I was trying to save to the local machine. Your suggestion about saving to my desktop worked. After that, when I tried saving as back in the usual Moneydance folder I have in my library, I got the same error message. What do you think? Thanks, Marc

  5. 5 Posted by Ben Spencer on 12 Sep, 2009 03:02 PM

    Ben Spencer's Avatar

    Hi Marc

    Do you mean something specific when you use the word "Library"? What is the path that you are trying to save the file to.

    Can you save other documents produced by other applications to the same location?

    Sincerely

    Ben Spencer

  6. 6 Posted by Marc Miller, M.... on 12 Sep, 2009 03:16 PM

    Marc Miller, M.D.'s Avatar

    Ben, your questions just now helped me realize something that I'll get to in a moment.  The path I'm trying to save to is Mac Hard Drive/Library/Moneydance Accounts/Moneydance Accounts.MD.  What I realized is that when I previously told you about checking the permission level, it was for the actual file endng in .MD.  But when I opened Get Info on the folder Moneydance Accounts, the permissions part is grayed out and I can't change the settings.  Currently, the setting under permission for "Marc" is read/write, while for "admin" and "everyone" it is at read only.  Again all three of them are grayed out.  Marc

    Marc Miller, M.D. 
    (949) 331-9893 Direct
    (360) 343-8244 Fax

    --- On Sat, 9/12/09, Ben Spencer <[email blocked]> wrote:

    From: Ben Spencer <[email blocked]>
    Subject: Re: Not able to save file after Mac OS X Snow Leopard upgrade [Problems]
    To: [email blocked]
    Date: Saturday, September 12, 2009, 8:02 AM

  7. 7 Posted by Marc on 13 Sep, 2009 02:20 PM

    Marc's Avatar

    Ben, my problem is solved. Thanks to your suggestions, you helped guide me, as a new Mac user, to the solution. I created a new folder, did a saved as to the same Library and deleted the old folder. Pretty basic I know. Thanks for your help and have a good day, Marc

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac