unwanted auto-completion during credit card imports

flying.boy's Avatar

flying.boy

05 Jul, 2019 01:03 PM

Moneydance 2017.8 (1678) Mac OS 10.13.6 High Sierra.

I've been using the File / Import feature to download credit card transactions (using the .csv format). A lot of them have Description fields like Sainsbury Store but when imported there is an autocompletion so it reads Sainsbury store bread. This is not what I want, Some examples are far less trivial.

I have the box for case-sensitive autocomplete un-flagged.

How can I import so that the description field show only the text that was imported?

Thank you

David

  1. Support Staff 1 Posted by Maddy on 05 Jul, 2019 03:22 PM

    Maddy's Avatar

    Hi David,
    Thank you for contacting Moneydance support.

    We've released a new stable version of Moneydance (build 1880) that should resolve the problems you've encountered.

    Moneydance (build 1880) can be downloaded from this page

    Since your license key: B22901472-5BF359E5 works with both Moneydance 2017 and 2019, the software will register automatically.

    You should take a manual backup of your data file via File --> Export Backup before you download the preview version.

    Finally keeping the box for case-sensitive autocomplete un-flagged should not cause any problems, after updating.

    I hope this information is helpful. Please let me know if you have further questions or need any assistance.

    --
    Maddy, Infinite Kind Support

  2. 2 Posted by flying.boy on 05 Jul, 2019 03:28 PM

    flying.boy's Avatar

    Thank you, Maddy.

    Just let me be sure I understand you before I subject myself to the potential hazards of upgrading what is (apart from the problem under discussion) a comfortably working system:

    In the new version, will I be able to suppress auto-completion during the Import process? Will I be able to suppress auto-completion globally?

    Kind regards

    David


    You should never judge a fish by its inability to climb a tree.

  3. Support Staff 3 Posted by Maddy on 05 Jul, 2019 05:25 PM

    Maddy's Avatar

    I understand your concerns David, so if you wish to keep running Moneydance 2017, since the version you have installed is an out-dated one, you could consider downloading a newer version of 2017 such as Moneydance 2017.10 (1706) available here. Also, you are still entitled for a free upgrade to 2019.

    Are you able to confirm that you see ‘Current Transaction’ listed, when confirming the imported transactions? If yes, then choosing this will result in the avoidance of the change of category.

    Also, Auto-complete cannot be switched off and it operates based on the description field of a similar transaction that was already entered.
    However, the newer versions will not remove the auto-completion or auto-fill.

    Finally could you check if you have accidentally enabled the ‘Automatically Merge’ option in the preferences?

    --
    Maddy, Infinite Kind Support

  4. 4 Posted by flying.boy on 05 Jul, 2019 06:46 PM

    flying.boy's Avatar

    Hi Maddy

    I think we may have been at cross-purposes.

    I am very happy with my current version of MD and would only change it in the short term if upgrading would fix my current issue.

    The issue is that during Imports, the Description field is spuriously altered, based on some historical transaction history, and is therefore NOT a true and accurate representation of what was in the Import file. This is for me a major issue.

    With normal transaction entry (manually) it is possible to override the autocomplete very easily, especially with the ‘original documents’ at hand. But during imports the import file is not immediately visible, so correction is not possible. I end up with a lot of imported transactions which look more or less plausible but are in fact incorrect.

    You have just told me that the new versions of MoneyDance do not offer an option to disable autocomplete on imports.

    Please treat this as an Improvement Request to your development team.

    Thank you

    David


    Success consists of going from failure to failure without loss of enthusiasm.

  5. Support Staff 5 Posted by Maddy on 23 Sep, 2019 08:34 AM

    Maddy's Avatar

    Hi David,

    Generally, we'd recommend you use the OFX or QFX file format if available.
    If not, use the QIF file format.

    Although CSV files can be imported, unfortunately the import process is a little more involved. CSV files were not designed to transfer data to personal finance programs, so there is no standard format or layout for these files.

    If CSV is the only format available, you'll be able to import the file to Moneydance using File --> Import. During the import process, you'll assign the columns in your CSV file to fields within the Moneydance account register.

    If you want to send a copy or a sample of the CSV file, I can let you know the exact settings you need to import the file to Moneydance. Once we've determined the import settings you need, they should not change.

    This discussion is private so your replies can only be viewed by the support team.

    Thank you

    --
    Maddy, Infinite Kind Support

  6. 6 Posted by flying.boy on 23 Sep, 2019 08:45 AM

    flying.boy's Avatar

    Hi Maddy

    I’m afraid you are missing the point.

    I have no problems with importing files into Moneydance.

    The issue is that MoneyDance sees the Description field and attempts to auto-complete it, based on its memory of previous entries with that Description. For example if the Description field says “Tesco” the program adds from its memory and I get “Tesco bread”. The transaction is almost certainly not for bread.

    Unless I can suppress Autocompletion during transaction import, I cannot rely on the imported transactions being an accurate copy of what was in the original download.

    I cannot understand how your support team / development team don’t see this as an issue. Essentially the import process is corrupting the data.

    NB I tried to set this as a Public issue. Maybe other users will recognise this and agree it is an issue.

    Kind regards

    David

  7. 7 Posted by flying.boy on 04 Nov, 2019 06:55 PM

    flying.boy's Avatar

    Can I formally request an improvement which would allow a user to suppress the 'random' autocompletion of the Description field when doing an Import.

    Thanks

    David

  8. 8 Posted by dwg on 04 Nov, 2019 08:05 PM

    dwg's Avatar

    I'm a fellow user.

    Have you tried using the Find and Replace extension to replace all occurences of Tesco bread to read just Tesco, so that Tesco Bread is not present ?

  9. 9 Posted by flying.boy on 05 Nov, 2019 12:40 AM

    flying.boy's Avatar

    The trouble is, it won’t always be “Tesco bread” but an unlimited variety of references which get corrupted during import.

    Nice try! Thanks


    Tiny Toes Hertford Ltd, 41 Chambers Street, Hertford, SG14 1PL
    T: 01992 589020 www.tinytoeshertford.co.uk [email blocked]
    Registered in England & Wales No: 10876848. Registered office: Wilson Devenish (Accountants), The Maltings, Railway Place, Hertford, SG13 7JT.

  10. System closed this discussion on 04 Feb, 2020 12:40 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac