Bank of America - charges importing as payments

stonemss's Avatar

stonemss

21 Nov, 2019 04:24 PM

I've seen a bit of this in the forums, but all say bad file format. I'm downloading as Quicken/WEB Connect 2017+, and I get a QFX file that looks good. Charges have a "-" in front of them and payments do not. In the example below, the 9.95 charge showed up in the payment column for the imported transaction. As did the 1973.13 payment. I tried downloading and importing as well as directly opening in MoneyDance.

QUESTIONS
1. Is Bank of America sending bad files?
2. Is there a quick way to swap payment and charge in a batch update to fix the mess that's been created?

Excerpt from file:
                    <STMTTRN>
                        <TRNTYPE>PAYMENT
                        <DTPOSTED>20190516160000[0:UTC]
                        <TRNAMT>-9.95
                        <FITID>201905166
                        <CORRECTFITID>201905166
                        <CORRECTACTION>REPLACE
                        <NAME>COSTCO WHSE #0745 KALISPELL MT
                    </STMTTRN>
                    <STMTTRN>
                        <TRNTYPE>CREDIT
                        <DTPOSTED>20190520160000[0:UTC]
                        <TRNAMT>1973.13
                        <FITID>201905207
                        <CORRECTFITID>201905207
                        <CORRECTACTION>REPLACE
                        <NAME>BA ELECTRONIC PAYMENT
                    </STMTTRN>

  1. 1 Posted by hleofxquotes on 21 Nov, 2019 05:59 PM

    hleofxquotes's Avatar

    There was some discussion in this area on this thread: https://infinitekind.tenderapp.com/discussions/problems/53744-capit...

    I did not following very closely on all the points raised there but my personal opinion is that the default behaviour should have been

    • to ignore the value of TRNTYPE in consideration to balance

    The spec is quite clear on that under

    • 11.4.4.1
    <TRNTYPE> Transaction type, see section 11.4.4.3 for possible values. This element does not  
    change the effect of the transaction upon the balance (increases and decreases  
    are indicated by the sign of the <TRNAMT>).
    
  2. Support Staff 2 Posted by Maddy on 21 Nov, 2019 06:16 PM

    Maddy's Avatar

    Hi,

    We are sorry to hear about the problem you have encountered.

    We would recommend downloading the latest version, Moneydance 2019.3 (1880) from here.

    In order to fix the issue described, you need to make sure you select the Ignore Transaction Types in Favor of Amount Signs checkbox, in the Network tab of the settings.

    Please let me know if you have further questions or need any assistance.

    --
    Maddy, Infinite Kind Support

  3. 3 Posted by stonemss on 21 Nov, 2019 08:35 PM

    stonemss's Avatar

    I am on the latest version - thank you. Now, I have a cleanup problem. I have transactions that were downloaded and confirmed that matched manually entered transactions. But in the process of changing the amount from a payment to a charge it goofed something up.

    I have two transactions that I need to change back to downloaded, but unconfirmed in order to fix the merge options being offered. I can't figure out how to mark something that has been confirmed as unconfirmed.

    I tried deleting the transaction entirely and importing again, but it gets imported as already confirmed !?

    It gets worse - I tried deleting all the transactions and importing again, now the downloaded ones all merge to first one. There must be a list of downloaded transactions somewhere separately that has become corrupted. How to clean that up?

  4. Support Staff 4 Posted by Maddy on 22 Nov, 2019 09:17 AM

    Maddy's Avatar

    Hi,
    To highlight the relevant transactions in the register, click on the first transaction, hold down SHIFT, then click on the last transaction, this will select multiple transactions, at once.
    To highlight non-contiguous transactions, hold down CTRL.
    Once the desired transactions are highlighted, right-click (CTRL-click for Mac) on any of them and from the resulting context menu, select Mark as Uncleared.

    I hope this information is helpful. Please let me know if you have further questions or need any assistance.

    --
    Maddy, Infinite Kind Support

  5. 5 Posted by stonemss on 22 Nov, 2019 05:14 PM

    stonemss's Avatar

    Maddy - no that doesn't help. Maybe try reading what I'm saying a little
    more closely. The problem is with merging downloaded transactions. And I
    believe I have corrupt data that I somehow cannot see in the register.
    This all started after changing the flag to ignore transaction type and use
    the +/- value.

    I am on the current version 19.03 - 1880

    *Scenario*
    1. I had manually entered transactions (monthly transaction with same
    amount each month), auto entered by reminders
    2. I downloaded from my bank
    3. The matching manually entered transactions disappeared (which I've never
    seen before)!? Usually both show up and I can merge the downloaded one
    into the existing manual one. HOWEVER, now *the manually entered ones
    inexplicably disappear when I download or import the bank data*, so only
    the newly (unconfirmed) ones are visible.
    4. There was no option to merge the transactions, so I confirmed the first
    one
    5. After I confirmed the first downloaded transaction as a new one,
    subsequent month's downloaded transactions offered to merge to the first
    downloaded one, which should never happen - right?
        a) If I merge with the previously downloaded one, the new downloaded
    one(s) disappears, which is basically how it should work except that it
    shouldn't offer to merge with a previously downloaded and merged
    transaction.
        b) If I confirm it as a new transaction, the next downloaded one offers
    to merge to either of the previous two

    So, I deleted all matching transactions that I could see in the register
    (manual or downloaded) and manually re-entered the ones I deleted. Then I
    repeated the download and got the same results. I tried merging everything
    it gave me the option to merge and ended up with a single transaction,
    which I deleted and the repeated the process with the same behavior.
    Finally, I just downloaded the transactions and confirmed them all as new.
    I downloaded the next month's data and the process started over. I've
    tried this several times now and can't get the downloaded transactions to
    match/merge with manually entered ones, so I conclude that I must have
    corrupted data somewhere relating to downloaded transactions that is not
    visible from the register view *and I need help sorting it out*.

    Thank you :)

  6. Support Staff 6 Posted by Maddy on 29 Nov, 2019 04:49 PM

    Maddy's Avatar

    Please accept my sincere apologies for the delay in responding to your query.

    Please can you try the following:

    The filter at the top of the register should be set to "All".

    Are you in split register or combined mode?

    To check this, click on the button that toggles between split and combined mode, at the top-right corner of the register.
    Please note: If it is in split mode, then all unconfirmed transactions will be shown in a second register which appears below the regular register.
    This can sometimes be collapsed, so that all it shows is a bar with a label that says "N unconfirmed transactions". If you see that bar, drag it up vertically and you'll see the unconfirmed transactions in that list.

    I hope this information is helpful. Please let us know how you get on and do not hesitate to contact us back if you need further assistance.

    --
    Maddy, Infinite Kind Support

  7. 7 Posted by stonemss on 06 Dec, 2019 07:28 PM

    stonemss's Avatar

    When I get a chance to look at this again, I'll give it a try - thank you!

  8. System closed this discussion on 06 Mar, 2020 07:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac