Copy & Paste report format

s©tt's Avatar

s©tt

06 Feb, 2020 08:43 AM

Up until recently, I would copy and paste a report into an email, and the format it appeared in the email (or notepad) was tab-separated.

Now when I copy and paste a report, it pastes in CSV (comma-separated) format, and I have to edit it out all the commas by hand.

Has the behaviour changed, or is there a setting that changes this behaviour (which I perhaps inadvertently changed)? I want to be able to copy and paste reports in tab-separated format.

  1. 1 Posted by derekkent23 on 06 Feb, 2020 08:57 AM

    derekkent23's Avatar

    I am not support staff, just a user,
    Hi s©tt

    I presume you are using the Copy to Clipboard.
    Have you tried Save and select Tab delimited to create a file?

    Hope this helps.

  2. 2 Posted by s©tt on 06 Feb, 2020 09:01 AM

    s©tt's Avatar

    @derekkent23 - Yes, I am using the copy to clipboard button which, as I wrote, used to produce tab-separated when I pasted. Something seems to have changed.

    Save as a file works, but that's a few extra steps. I'm just trying to the the 'copy to clipboard' to work the way it used to, and was wondering if the functionality had changed in the past month or so, and/or if there is a setting somewhere.

  3. 3 Posted by dwg on 06 Feb, 2020 09:08 AM

    dwg's Avatar

    The only change I have seen recently is in Build 1898:

    Build 1898 Sat Dec 28 23:26:48 2019
        
        • Improved encoding of commas and large numeric values in comma-delimited report exports (and copying to clipboard)

  4. 4 Posted by s©tt on 06 Feb, 2020 09:23 AM

    s©tt's Avatar

    @dwg - well, that would appear to be it, thanks. Funny how the definition of "improved" seems always to be different for developers than it is for users ;-)

    A(nother) problem it creates is that Moneydance ignores the system settings, where in my country the decimal separator is a ',' and the list separator is a ';', so when I copy and past to say, Excel, it doesn't work properly.

    Moneydance should take these values from the system settings, or at least allow them to be set in preferences.

  5. 5 Posted by s©tt on 14 Feb, 2020 09:18 AM

    s©tt's Avatar

    Fixed in build 1903.
    Thanks to the developer!

  6. s©tt closed this discussion on 14 Feb, 2020 09:18 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac