Copying data to spreadsheet

Joy's Avatar

Joy

10 Jul, 2020 09:56 AM

When I copy a report from transaction filter to excel I find I am unable to total a selected list of amounts as they are entered as text with the currency in front. I have to individually edit the cells to remove the currency so that i can total a column.
Is there a way round this?

Thank you

  1. 1 Posted by mhoggie on 10 Jul, 2020 10:27 AM

    mhoggie's Avatar

    just a user,

    Have you had any success by selecting the column involved and changing the format to numbers, or currency?

  2. 2 Posted by christine joy on 10 Jul, 2020 11:38 AM

    christine joy's Avatar

    Yep. tried that.
    Thanks anyway

  3. 3 Posted by jeff_l on 10 Jul, 2020 04:57 PM

    jeff_l's Avatar

    You don’t say what version of MD you are using.

    This issue was corrected in a preview version sometime ago

    Moneydance build 1903 (Tue, 11 Feb 2020 22:58:00 +0000) * changed report copy-to-clipboard contents back to tab-delimited

    Download the current preview version here:-
    https://infinitekind.com/preview

    just a user

  4. 4 Posted by christine joy on 11 Jul, 2020 10:48 AM

    christine joy's Avatar

    Thanks Jeff. Am on 2019.3 1880. Will try the preview.

  5. 5 Posted by dwg on 11 Jul, 2020 11:13 AM

    dwg's Avatar

    I'm a fellow user.

    It is not unusual for spreadsheets to choke on the currency indicators.

    I can think of two approaches to this.

    1. Edit the currency in Moneydance and remove the prefix.

    2. In many spreadsheets you are given options as to what characters are to be considered as delimiters. If you current prefix says includes something like a $ sign you can set this as one of the field separators and this should remove the currency indicator from the amount field.

  6. 6 Posted by Ben on 12 Jul, 2020 09:50 AM

    Ben's Avatar

    I'm a fellow user who also finds this happening sometimes, but not just with Moneydance. Excel sometimes thinks pasted-in values with currency symbols are text and sometimes recognises that they're numbers displayed as currency, and I don't know what the rule is - so I've learnt workarounds. Here are two.

    1. For occasional use
    If all the currency characters are the same (e.g. all £), remove them all in one go. Highlight the column, press Ctrl-H for find-and-replace, put £ (or whatever) in the Find box and leave the Replace box empty, then Replace All.

    2. For often pasting into a larger analysis spreadsheet.
    Set up another column in which each cell is the pasted-in currency value plus zero e.g. =b8+0. This will be happy with numbers, currency-text values. blanks, etc. You can then do analysis on that column.

    Hope this helps!

  7. 7 Posted by christine joy on 14 Jul, 2020 09:19 AM

    christine joy's Avatar

    Thanks for the suggestions Ben

    Christine

  8. Maddy closed this discussion on 14 Jul, 2020 02:40 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac