Moneydance 2021 (2010) Download of Fidelity transactions

elliot.abrons's Avatar

elliot.abrons

07 Dec, 2020 07:05 PM

On 12/20/20 using MAC OS 10.15.7 (Catalina):
1) MoneyDance Version 2020 (1917) downloaded transactions from all my Fidelity accounts.
2) MoneyDance Version 2021 (2012) has progressed from not responding to providing the following message,
"There was an error communicating with the server. This could be the result of a network problem, or the server may be offline or not responding. Please try the operation again later. Error Description: java.net.ConnectException: Connection refused".

Until Version 2021 consistently downloads Fidelity transactions, I'll use Version 2020 (1917). That's the beauty of Moneydance. It allows the use on an older version of the App if there is a problem with a new version.

Showing page 2 out of 2. View the first page

  1. 31 Posted by dwg on 04 Jan, 2021 02:41 AM

    dwg's Avatar

    I'm a fellow user.

    According to the change log, Build 3034 was supposed to have addressed the Fidelity issue, it appears that there is still a problem however.

    I can see that the issue has been reported to the developer.

  2. Support Staff 32 Posted by Maddy on 04 Jan, 2021 11:00 AM

    Maddy's Avatar

    Hi all,

    After running the update you might need to recreate the connection with Fidelity.

    Moneydance 2021.1 (3034) is now available to download from this page.

    • Restored custom TLS layer settings for connections requiring custom tweaks (including Fidelity)

    You will need to disable your current connection and then recreate it using the New Connection button on the Online Banking Setup screen. To do so, you can follow these steps:

    1. Select your bank account in Moneydance

    2. Select Online --> Setup Online Banking
    3. Click the "Disable" button. If you don't see this button, just close the window.

    4. Repeat the previous steps for any additional accounts at the same institution.
    5. Select Online --> Setup Online Banking (again)

    6. Click the "New Connection" button and select your bank and hit OK
    7. Continue with the setup process, entering your username/password


    Make sure you pick "New Connection", even though your bank is still one of the connection choices after you disable it. Choosing your bank from the long list of available banks will force Moneydance to download the updated information, which should then allow you to connect.

    Please let us know if you continue to have connection problems after recreating your connection and we'll troubleshoot further.

    --
    Maddy, Infinite Kind Support

  3. 33 Posted by tonyblunt on 04 Jan, 2021 12:17 PM

    tonyblunt's Avatar

    Thank you, that worked.

  4. Support Staff 34 Posted by Maddy on 04 Jan, 2021 03:13 PM

    Maddy's Avatar

    You are welcome, Tony!

    I'm very pleased to hear that.

    I'll close this discussion for now, but do not hesitate to contact us again, if you need further assistance.

    --
    Maddy, Infinite Kind Support

  5. Maddy closed this discussion on 04 Jan, 2021 03:13 PM.

  6. mhoggie re-opened this discussion on 05 Jan, 2021 01:59 PM

  7. 35 Posted by mhoggie on 05 Jan, 2021 01:59 PM

    mhoggie's Avatar

    Thanks for your magic on Fidelity, both my netbenefits (401k) and investments (IRA) accounts are downloading now. I had just given up on Fidelity because I thought they went their way with Quicken like Discover Card. But you saved them.

    Thanks, Mike

  8. 36 Posted by sara.nolan1965 on 07 Jan, 2021 03:30 PM

    sara.nolan1965's Avatar

    I am having a strange thing happen when I try to add the new connection after disabling the old. I go down the list, select Fidelity Investments, proceed, and somehow it changes the institution to Fidelity - MA. It then asks for a broker number, which of course I don't have as I don't have an account there. I have selected Fidelity Investments again from the list that appears with just those 2 Fidelity options, but that doesn't work. I have repeated the disable account option several times, but the same thing happens when I try to establish again.

  9. 37 Posted by sara.nolan1965 on 07 Jan, 2021 03:40 PM

    sara.nolan1965's Avatar

    BTW, I also have a Schwab account and the same thing happens. I did quit MD and restart but that didn't help either.

  10. 38 Posted by sara.nolan1965 on 07 Jan, 2021 06:11 PM

    sara.nolan1965's Avatar

    Another BTW, I am using version 2021.1 (3034), but from the discussion it seems to be a problem with various recent versions.

  11. Support Staff 39 Posted by Maddy on 11 Jan, 2021 09:35 AM

    Maddy's Avatar

    Hi Sara,

    Can you try completely resetting your connection to your bank and see if that fixes the problem you're seeing?
    To do this, you'll need to force clear the current connection information for your bank in Moneydance. I'm sending a file called 'remove_one_service.py_' that will help do that.

    Before proceeding, take a manual backup via File --> Export Backup.

    To use the .py file, first save it to your computer and then follow these steps:

    1. In Moneydance, select Window -->'Show Moneybot Console'
    2. In the window that opens, select 'Open Script' then navigate to the .py file wherever you saved it on your system.
    3. Select 'Run' to execute the file - you may need to drag the window to the right to reveal the button.
    4. You will be asked to select which connection you want to clear. Choose your bank, and click OK. You'll get a confirmation message when the connection has been removed. Close the window when done.
    5. Set up the connection to your bank like normal choosing the "New Connection" button. Since all of your settings have been cleared, you should get the most recent connection information for your bank.

    Hopefully, that will work. If it doesn't, please let us know and we'll continue troubleshooting.

    --
    Maddy, Infinite Kind Support

  12. 40 Posted by Stuart Beesley ... on 11 Jan, 2021 10:02 AM

    Stuart Beesley - JUST A FELLOW USER's Avatar

    An FYI - if you are using MD 2021 build 2012 onwards then my Toolbox extension includes the remove_one_service.py script with intelligence wrapped around it.... It's the Delete OFX Bank Logon Profile/Svc button in advanced mode..: https://yogi1967.github.io/MoneydancePythonScripts/

    (not support, just a fellow user)

  13. 41 Posted by sara.nolan1965 on 14 Jan, 2021 08:47 PM

    sara.nolan1965's Avatar

    Pulling out my hair, as nothing working. Getting very frustrated and have spent hours on this. By way of history and other information that might be important: I do ouse a MacBook Pro and am running Big Sur. However, the problem occurred before I got the computer I am working on now. (It was running Mojave.) The problem started in Dec. with Schwab, which was intermittent for some reason, but then stopped entirely with Fidelity. I thought the whole thing was intermittent so I waited longer to contact you all, thinking it would sort itself out. You have done lots of Updates and I know you were trying to get out your new web first version, so I cut it some slack.

    I did as you instructed below, 1/11. Everything seemed fine, and my data downloaded.
    THEN yesterday, 1/13, I reopened a MD file, everything seemed fine, didn’t report any problems.
    I was finishing my merge with the earlier download (there was a lot, nothing since 12/15 from Fidelity and end of year etc,) Scroll at bottom said downloading each of the files, but 0 transactions loaded from the 3 Fidelity accounts or the single Schwab account. I needed to go to the Fidelity website, and noted that although the latest transaction in any MD file was 1/8, Fidelity had quite a number of transactions after that date.
    Tried downloading files again, didn’t download anything. Didn’t have time to troubleshoot, so quit and resumed today.
    NOTHING from those 2 institutions.
    Thought perhaps I had made a mistake somewhere, got out your instructions again and CAREFULLY followed each step after disabling my connections. NOTHING again.
    Opened another MD file that only includes one account (Fidelity) No accounts to download it said.
    Redid entire process with that file. NOTHING. Nothing showed when I tried disable connection to see about any edit needed, but there was NOTHING there.
    Returned to the file with multiple accounts. Redid whole process. Again NOTHING.
    Looked at the Set-up from the menu for all 3 Fidelity and nothing there, same for Schwab. Other accounts (other institutions for checking and charge accounts) and of course they showed the set-up data.
     Next tried to establish connections again, and none of them took. I have no idea why.

    What do I do now? I have a lot of end-of-year things to do, and really need and appreciate your help.

    Sara Nolan

  14. 42 Posted by dwg on 14 Jan, 2021 09:04 PM

    dwg's Avatar

    I'm a fellow user.

    All the reports I have seen are saying that Schwab and Fidelity will work with Build 3034, however it my well be the case that you need to reset your settings i.e. clear out the existing connection information and in some cases forcefully do it.

    Maddy has provided the instructions in Post #39 to forcefully clear the connections.

  15. Support Staff 43 Posted by Maddy on 14 Jan, 2021 09:29 PM

    Maddy's Avatar

    Sorry to hear that the problem persists, Sara!

    Please could you try the following:

    1) To ensure that you are definitely running Moneydance 2021.1 (3034), open Moneydance and select Help --> About Moneydance (or Moneydance --> About Moneydance on a Mac) where the version and build number will be displayed.

    2) Please select Online --> Setup Online Banking, do you see an option to 'Reset Sync'? If so, select this option then attempt to connect with the bank/s again and let us know if you see any difference.

    Thank you

    --
    Maddy, Infinite Kind Support

  16. 44 Posted by sara.nolan1965 on 14 Jan, 2021 09:40 PM

    sara.nolan1965's Avatar

    This comment was split into a new private discussion: Fidelity and Schwab persistent connection issue

    Thanks for the response. Actually those were the instructions I was following, and all of those were force clearing it out with the file given. At this point it almost seems I have cleared out too much. I can’t set-up the connection any more. Any ideas on what the problem could be here?
    Sara

  17. 45 Posted by sara.nolan1965 on 14 Jan, 2021 09:48 PM

    sara.nolan1965's Avatar

    I have seen, but not used, the Reset Sync button in the past. Now, there is nothing in the Set-Up function for these accounts. Do I use it in one of the other non-involved files, such as a checking account? I’m hesitant to try that unless I’m certain that won’t make things worse.

    Sara

  18. 46 Posted by sara.nolan1965 on 26 Jan, 2021 06:39 PM

    sara.nolan1965's Avatar

    I just sent you a message about my frustrations with Fidelity. I then went to MD and noticed that some transactions were new. I reset-up online banking and everything seems to be working. I guess you all must have fixed something, but I didn’t know.
    I then went to Schwab. Had to disable the connection that was there and set up another.Then it downloaded. However, somehow in all of the confusion and trying and retrying t fix things, I lost all my data from 12/26 2019 until 1/12/21. I do have time machine backups so I assume I could open the most recent I had, export the data in QIF and import that file. Correct?

    I must admit, I’m really frustrated by the whole experience.
    Sara

  19. Support Staff 47 Posted by Maddy on 26 Jan, 2021 06:47 PM

    Maddy's Avatar

    Sorry to hear you had to go through such a stressful experience with this, Sara!

    I was just reporting back what you have described in the other thread to our connection specialist. However, I'm so glad your connection started working again, finally!

    As for the missing data, from the register view, please ensure the account is selected on the side bar and the All tab (next to date) is selected as well. In this way all your transactions should be displayed.

    Alternatively, you can try restoring from a backup.

    When you restore data from a backup file, a new data file will be created for use going forward. If the restored data file is in the default location, it's accessible from Moneydance via Help --> Show Documents Folder.

    Any data files stored here are accessible from the program by choosing File --> Open. Any files you've created or restored will be listed here.

    If so, you can restore these files into Moneydance by double clicking them.
    Alternatively, choose File --> Restore from Backup (or 'Import New Account Set' from the Welcome window). Then navigate to and select the backup file.

    If you'd like to re-name the restored file, you can follow the steps in this article from the knowledge base.

    It's important you close the Moneydance program fully before you make any changes.

    Then change the data file name to whatever you want - just be sure to retain the .moneydance file extension at the end of the file name.

    Please let us know if you have further questions or need more assistance.

    --
    Maddy, Infinite Kind Support

  20. 48 Posted by sara.nolan1965 on 26 Jan, 2021 07:20 PM

    sara.nolan1965's Avatar

    Maddy, thanks so much for your help. All is under control again. You folks do provide great support, and you’ve been very patient through all of this. I’m sure it was frustrating for all of you as well!

    Sara

  21. Support Staff 49 Posted by Maddy on 26 Jan, 2021 07:27 PM

    Maddy's Avatar

    You are welcome, Sara!
    We are glad it's all back to normal now! Also, thank you for your kind words.

    I'll close this discussion for now, but do not hesitate to contact us again, if you need further assistance.

    --
    Maddy, Infinite Kind Support

  22. Maddy closed this discussion on 26 Jan, 2021 07:27 PM.

  23. elliot.abrons re-opened this discussion on 27 Jan, 2021 05:12 AM

  24. 50 Posted by elliot.abrons on 27 Jan, 2021 05:12 AM

    elliot.abrons's Avatar

    I updated to a later version for the Mac and everything started working..

    Sent from my iPad

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac