Finding my old data

Bob Schoettle's Avatar

Bob Schoettle

07 Jan, 2021 10:00 PM

I just purchased a new Macbook Air - fried my old one by spilling water on the keyboard. Trying to setup/use Moneydance on the new Mac, I just upgraded to Moneydance 2021 and am running Big Sur OS. I can't figure out how to load my old data as all I get is the generic start as if I was a first time Moneydance user. I have all my data backed up in iCloud as well as on an external hard drive, but when I try and navigate to where the backup files should be nothing opens. Suggestions/help please. Thanks

  1. 1 Posted by Stuart Beesley ... on 07 Jan, 2021 10:18 PM

    Stuart Beesley - JUST A FELLOW USER's Avatar

    Make sure you’re on the latest build from here:
    https://infinitekind.com/preview

    Can you find your .moneydance file in your backup? If so, restore that to your Mac.

    At the moneydance welcome screen, select open other, then this file. Or at the menu file open.

    (Not support, just a user)

  2. 2 Posted by Bob Schoettle on 07 Jan, 2021 10:40 PM

    Bob Schoettle's Avatar

    Stuart,
    Thanks for the suggestion but while I find lots of files on my hard drive
    backup none of them seem to do anything. Attached is screenshot of what I
    see. Any suggestions?

  3. 3 Posted by Stuart Beesley ... on 07 Jan, 2021 11:11 PM

    Stuart Beesley - JUST A FELLOW USER's Avatar

    So what actually happens when you choose file open in moneydance? What does it say?

    Are you on 2021 build 3034?

    You have lots of *.moneydance files which is very strange. Which one is the largest and the most recent?

    Perhaps attach the errlog.txt file?

  4. 4 Posted by Bob Schoettle on 07 Jan, 2021 11:53 PM

    Bob Schoettle's Avatar

    Some answers/questions

    How do I find what the build # is that I'm on? I've tried looking
    everywhere but all I can find is 2021?

    All of the Moneydance files seem to be almost no content - either zero KB
    or just a few. When I click on them all it does is take me back to the
    Moneydance App but nothing is there. It looks like the reason I have so
    many is that each time I open one it then creates a new one?

    When I go to File/Open I get the following screen (attached). I've also
    attached what I get when I do Open Other but none lead me to any files with
    data?

    I'm not sure I'm doing much to help you understand what's going on but let
    me know if you have any other thoughts. Thanks so much!

  5. 5 Posted by dwg on 08 Jan, 2021 12:02 AM

    dwg's Avatar

    I'm a fellow user.

    There are a number of ways to determine the version of Moneydance you are using.

    If Moneydance is open you can:

    1. The version and build number of Moneydance you are using can be found under the menu item:

    Windows/Linux:

     Help --> About Moneydance.

    Mac:

     Moneydance --> About Moneydance

    OR

    2. Open the console window (Menu Bar item: Help --> Console Window)

    The version and build number will be at the top of the console output

    ------

    If Moneydance is not open you can obtain the information from the error log. Open the error log in a text editor or word processor, the Moneydance version is given in the first few lines of the file, the file can be found at:

    If you're using Mac OS, it should be located at one of these locations within your Home folder:

    ~/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance/errlog.txt

    or:

    ~/Library/Application Support/Moneydance/errlog.txt

    If you have any trouble finding your Home Library folder you can open Finder and hold down the option key while selecting the Go menu and the Library folder option should occur or you can open Finder and select Go -> Go to Folder and copy and paste in the following:

    ~/Library

    This should pull up your local Library folder.

    If you're using Windows, it should be located under your login directory at:

    C:\Users\(yourusername)\.moneydance\errlog.txt

    or

    C:\Documents and Settings\(yourusername)\.moneydance\errlog.txt

    Depending on your version of Windows

    If you're using Linux it should be located in your home folder at:
    ~/.moneydance/errlog.txt

    To find Moneydance data sets on your system look for any files/folders/bundles with the extension .moneydance or ,moneydancearchive

  6. 6 Posted by Bob Schoettle on 08 Jan, 2021 12:26 AM

    Bob Schoettle's Avatar

    Thanks for the info - I did find the build number, it's 2021.1 (3034) so I
    believe I have the latest.

    When I search for the .moneydance I get a number of files titled "Personal
    Finances.moneydance" but all of them are basically empty - either Zero, 753
    Bytes or 1Kb - and when I doubleclick to open nothing happens other than it
    takes me back to Moneydance but no data. The date stamps all indicate the
    file was created Nov 15 2013 (when I first bought Moneydance) and then the
    modification is either Dec 30/2020 (when I first tried to open Moneydance)
    or today (1/7/20) with various timestamps - looks like each time I open one
    it either updates the time stamp or creates a new on.

  7. 7 Posted by dwg on 08 Jan, 2021 12:35 AM

    dwg's Avatar

    What version of Moneydance did you upgrade from?

    This can have a bearing on what files should exist.

  8. 8 Posted by Bob Schoettle on 08 Jan, 2021 12:37 AM

    Bob Schoettle's Avatar

    I was using 2017.8

  9. 9 Posted by dwg on 08 Jan, 2021 12:40 AM

    dwg's Avatar

    That means the file extensions I gave are correct for that version.

  10. 10 Posted by Stuart Beesley ... on 08 Jan, 2021 09:38 AM

    Stuart Beesley - JUST A FELLOW USER's Avatar

    Clearly a zero byte or nearly zero won’t open. Do you have a time machine backup? Anywhere with a file that’s larger?

    Note. This is not really a file. It’s a ‘package’ (directory). You can right click and view contents......

    Do you have any *.moneydancearchive files?

    Did you have sync (ie to Dropbox) for iOS apps or second machines turned on?

    We can’t help if you can’t find a valid file.....

    One idea, download and install my Toolbox extension:
    https://yogi1967.github.io/MoneydancePythonScripts/

    Instructions on the same page. When installed, click the search for datasets button and then search from root. Try both file types.

    ?

    (Not support).

  11. Melissa closed this discussion on 25 Feb, 2021 07:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac