Another Importing CSV problem

ljpierce_ely's Avatar


24 Sep, 2021 05:01 PM


I just installed Moneydance 2021 this morning and I am having an issue importing a CSV file.

First off, I would love to try another format but my credit union, in their system change a couple years ago, took away all exporting formats except for CSV. So I have no choice at this institution.

I have opened my CSV file and on the first line is this: "Date","Type","Description","Debit","Credit","CheckNumber",

I attempt to import the file and have set my first selections as FIELD DELIMITER to a comma, MONTH DAY YEAR, and DECIMAL POINT to the decimal point (the only choice available).

Next, on the field selector, I have selected DATE, IGNORE, DESCRIPTION, DEBIT, CREDIT, Check #. I chose ignore for the second field because as you can see in the description above, the word TYPE, is not available as a choice in the field selection.

The program then imports the file and puts all amounts AS A DEPOSIT. I looked through the CSV file specifically at deposits and debits. Deposits are shown without a negative sign, debits are shown WITH a negative sign. All in the same column. Examples:
"9/18/2021","Withdrawal","POS PURCH - AMAZON.COM*2G67N 4816 WA SEATTLE AMAZON.COM US","-$29.91","",""
"9/8/2021","Deposit","ACH TRANS - PAYPAL ;090821;TRANSFER","","$46.03",""

I have also tried to download the CSV IMPORT Extension but the program won't "fully" read it. It is listed in the extensions as just IMPORTER and won't function.

I'm at a loss.


  1. 1 Posted by -Kevin N. on 25 Sep, 2021 01:59 PM

    -Kevin N.'s Avatar

    Hi ljpierce_ely,

    There is a contradiction in your post.

    You state that in your CSV file that debits and credits are "All in the same column.". However, the two examples of your transactions place debits and credits in separate columns.

    Can you attach a sample of the actual CSV file? It's fine if you sanitize it down to just those two transactions but It should contain at least 1 debit and 1 credit transaction.

    -Kevin N. (not a member of MD support)

  2. 2 Posted by ljpierce_ely on 25 Sep, 2021 09:20 PM

    ljpierce_ely's Avatar

    The two examples I included, one from Amazon and the other a deposit from Paypal, are copy and pasted directly from the CSV file.
    I draw your attention to the amounts shown. The amount from Amazon has a - in front of the amount and the amount from Paypal does not have that character.
    As for whether they are in the same column I have to admit that I'm not sure. I assumed and we all know that assumptions are the mother of all F-ups.
    The only difference I can readily see, and admittedly it may be significant, is that the withdrawl from Amazon has two "," after the amount, and the deposit from Paypal has two "," before the amount.
    Nevertheless, the program puts all amounts into the deposit column within the applicable account.

        On Saturday, September 25, 2021, 06:59:14 AM PDT, -Kevin N. <[email blocked]> wrote:


  3. 3 Posted by -Kevin N. on 25 Sep, 2021 10:08 PM

    -Kevin N.'s Avatar

    Hi Lance,

    Try this...

    Since the payment amount is represented by a negative value, set both fields of the importer to 'Credit Amount'. (see screenshot)

    Using the attached CU.txt file, I was able to successfully import the two transactions as expected.

    -Kevin N. (not a member of MD support)

  4. 4 Posted by ljpierce_ely on 26 Sep, 2021 01:30 AM

    ljpierce_ely's Avatar

    That did it. Thank you!!!!!

        On Saturday, September 25, 2021, 03:08:18 PM PDT, -Kevin N. <[email blocked]> wrote:

  5. 5 Posted by -Kevin N. on 26 Sep, 2021 01:43 AM

    -Kevin N.'s Avatar

    Hi Lance,

    I'm glad to hear that it worked.

    Thank you for reporting back with your results.

    -Kevin N. (not a member of MD support)

  6. Ethan closed this discussion on 26 Sep, 2021 03:49 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac