Unable to start MD

Lou S's Avatar

Lou S

29 Nov, 2021 09:39 PM

Hi-

I spent a day porting quicken to MD on a new machine (windows 11). The last thing I did was add toolbox to exclude some accounts from the net worth calculation. I also put quicken on the new machine to help with the port.

Today I am unable to run MD. The errlog shows a java error (java.lang.OutOfMemoryError: Java heap space). I've seen old references to this error that were mostly solved by using 32 bit MD...is that still the recommended solution? Box has plenty of memory available

Full err log attached. Any advice appreciated.

Thx,
Lou
Lou

  1. 1 Posted by Stuart Beesley ... on 29 Nov, 2021 09:50 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    You can allow for more memory by editing the 'Moneydance.vmoptions' file and set it to increase the amount of memory that
    Moneydance is allowed to use. To achieve this you can try the following:

    Navigate to the Moneydance.vmoptions file, located in the folder where Moneydance is installed:

    If you open that file with Notepad or any other text editor, you'll see some instructions for how to change it.
    Close Moneydance first!

    The basic recommendation is to changing the -Xmx1024m setting to -Xmx2048m which doubles the amount of memory that Moneydance is allowed to use.
    You can give it more if you wish, E.g.: you make it -Xmx3072m, for optimal results.

    NOTE: The limit is set deliberately low to enable it to work with computers having very small amounts of RAM.

    Windows file location: c:\Program Files\Moneydance\Moneydance.vmoptions

    In Windows - due to permissions, you will need to do this:
    In the 'Type here to Search' box on the Windows 10 Toolbar, type CMD (do not press enter)
    When Command Prompt appears, click Run as Administrator
    Click yes/agree to allow this app to make changes to this device / grant administrator permissions
    cd "\Program Files\Moneydance" (and enter)
    notepad Moneydance.vmoptions (and enter)
    edit the file and change the -Xmx1024 setting
    ctrl-s to save and then exit Notepad
    exit
    restart Moneydance

  2. 2 Posted by Lou S on 29 Nov, 2021 10:04 PM

    Lou S's Avatar

    That worked, @Stuart Beesley!

    I set to 4GB and the file opened. Thanks for the advice!

    /lou

  3. 3 Posted by Stuart Beesley ... on 29 Nov, 2021 10:18 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    👍

  4. Maddy closed this discussion on 30 Nov, 2021 04:52 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac