Moving to a new MacBook Pro M1 from old MBP 2011.

bepilot's Avatar

bepilot

12 Dec, 2021 03:31 PM

I started the transfer of data from my old MacBook Pro 2011 last night to my new MacBookPro M1 2020. I found that Dropbox which used to be my sync system I thought would not copy the Moneydance data files to the new system. After hours of work I discovered the data files are in the Library-containers file.

I then decided to just get the system running as a stand alone system and worry about syncing later after it was working. I followed the instructions to set up a stand alone system when transferring from the knowledge base. I had to make a copy of the file from the old computer to get it to the desktop of that machine. Then thru file sharing I brought that file to the new computer. I installed the same version of the MD (2021) on the new computer. The file opened and I put in data to make sure it updated the files. That worked. Then I upgraded the MD to the latest version(which was 2022.2 - 2022.3 is not available?). However when I try to open the file it is greyed out. I reloaded the 2021 version and have the same problem. I can no longer open the data file. What am I missing here?

  1. 1 Posted by Stuart Beesley ... on 12 Dec, 2021 03:52 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Try opening the dataset in Finder with double click.....

  2. 2 Posted by bepilot on 12 Dec, 2021 03:58 PM

    bepilot's Avatar

    I tried that and it doesn’t open that data file? It opens a file with a modified title that has no data in it. After closing that empty file and it “saves” it. I find the file I opened did not show the time stamp updated for being modified. I assume it is opening another data file.

  3. 3 Posted by bepilot on 12 Dec, 2021 04:30 PM

    bepilot's Avatar

    Stuart,

    I did finally get it to open the data file. However this is how I did it. Instead of double clicking it I used “right click” and selected to open it with the 2021 version rather than the 2022 version that opened when I double clicked it. The title of my file in the Document folder is md2019. When the MD2022 opened it when I double clicked it showed no data and it had modified the title to md2019 - md2021.

    Then after your suggestion and finding the double click didn’t work, I used the right click and selected the version of MD as I have both in my applications folder and the first window opened with the modified title and no data. However within seconds the encryption password window appeared, which before it had not. After filling in the password the title changed to md2019 - md2019. The data then filled in and it appears to be all correct. I then quit the program and right clicked the data file again and this time selected the MD2021 version and it requested the password and now opens the data file. So problem solved, just don’t understand what happened.

    I also notice the Maddy told several users they should be on 2020.3, however downloads only are showing the 2021.2.

    John DeCarli

  4. 4 Posted by dtd on 12 Dec, 2021 07:20 PM

    dtd's Avatar

    just a user - I assume your last sentence meant 2022.3 and 2022.2 ?

    If so, go to

    moneydance.com/preview

    which has 2022.3(4063) whereas the current release version is 2022.2(4060).

    Often, the preview is meant for those who want to check out what is basically a beta and a preview of what is coming, but in this case 4063 is primarily bug fixes for 4060, which is why you are seeing the recommendation to get 4063 even though it is officially a preview at this point.

  5. 5 Posted by Stuart Beesley ... on 12 Dec, 2021 07:53 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Probably Gatekeeper blocking access - when you manually open then you tell Gatekeeper it’s safe..

  6. 6 Posted by bepilot on 12 Dec, 2021 09:08 PM

    bepilot's Avatar

    Yes - my typing error - I meant 2022.3 and 2022.2. So far it is still running well. I will work on syncing it with my iPhone and my iMac later. It is doing the job for now. I appreciate the input.

  7. Maddy closed this discussion on 13 Dec, 2021 12:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

25 Jun, 2022 01:07 AM
24 Jun, 2022 11:56 PM
24 Jun, 2022 10:22 PM
24 Jun, 2022 10:10 PM
24 Jun, 2022 10:08 PM