Moneydance+ & USAA: can't connect via Plaid

layer's Avatar

layer

09 Jan, 2022 08:53 PM

It said "Your account settings are incompatible". It asked for a username, PIN and password, and I gave all 3.

I do NOT have 2FA turned on for USAA. I used to LONG AGO, but disabled it because of problems (random failures to login would lock my account!).

  1. 1 Posted by layer on 09 Jan, 2022 09:11 PM

    layer's Avatar

    This happened with Paypal where I DO have 2FA turned on.

    I assume I must turn it off to connect w/Plaid?

  2. 2 Posted by dwg on 09 Jan, 2022 09:16 PM

    dwg's Avatar

    I'm a fellow user.

    It is my understanding that Multi Factor Authentication is supported by Plaid (Moneydance+).

    Setting up Moneydance+ for account access should support multi factor authentication by prompting for the access code. However for ongoing use your financial institution must allow for trusted devices as the system does not allow for authentication that needs to be provided at every login, the transaction downloads is not an interactive process hence there is no ability to support prompting for a code.

  3. 3 Posted by layer on 09 Jan, 2022 09:30 PM

    layer's Avatar

    @dwg USAA is listed as supported, so I'm confused by what you're saying. When I login in the browser, my browser is a trusted device... not sure how I make the Plaid connection trusted.

    Are you saying USAA is not supported?

  4. 4 Posted by dtd on 09 Jan, 2022 09:35 PM

    dtd's Avatar

    just a user

    It appears USAA web site has been down most of the day. (I can't sign in at the moment either).

    That may or may not be part of the issue, but you may want to wait till the web site is up and you can log in and see what multi-factor authentication you are using (if any), and try setting up with Plaid again.

  5. 5 Posted by layer on 09 Jan, 2022 09:38 PM

    layer's Avatar

    @dtd I just logged into my USAA account. I had to give password and PIN, since I was on a trusted device. I have no MFA (other than PIN, which is mandatory, AFAIK).

    I just tried connecting again and got the same error message.

  6. 6 Posted by dtd on 09 Jan, 2022 09:40 PM

    dtd's Avatar

    USAA's OFX connection to Moneydance is working (just checked), but that doesn't depend on login methodologies like Plaid or logging into the website.

    So it appears there is a general login issue going on with USAA today that may be causing or exacerbating your setup.

  7. 7 Posted by layer on 09 Jan, 2022 09:42 PM

    layer's Avatar

    I will try again tomorrow.

    I thought OFX was disabled for USAA a long time ago. Maybe I should just use that, instead of Plaid. I only need to download transactions once, since I'm about to close all those accounts.

    Thanks.

  8. 8 Posted by dtd on 09 Jan, 2022 09:43 PM

    dtd's Avatar

    Are your error messages from trying to use Plaid, or logging into the website itself?

    I cannot login to the USAA website at all right now, and
    https://downdetector.com/status/usaa/

    says that quite a few people are reporting login difficulties. (This is to USAA, not talking about Plaid) That said, if you (or I or others) cannot login, it is not surprising that Plaid cannot either.

  9. 9 Posted by layer on 09 Jan, 2022 09:44 PM

    layer's Avatar

    @dtd did you use your OFX hack to download transactions? If so, I'll wait for Plaid's connection, as that's more than I want to do...

  10. 10 Posted by layer on 09 Jan, 2022 09:44 PM

    layer's Avatar

    @dtd error messages are from Plaid. See the picture in my first message at the top.

  11. 11 Posted by dtd on 09 Jan, 2022 09:48 PM

    dtd's Avatar

    OFX was disabled for USAA last January (2021), but was fixed in February 2021. The fix was then simplified last October.

    This has been recommended as the appropriate fix by Moneydance.

    As for "it's more than you want to do", you've already spent more time on this issue with Plaid than it takes to make USAA OFX work.
    But your choice, of course.

  12. 12 Posted by dtd on 09 Jan, 2022 09:48 PM

    dtd's Avatar

    ok - your error messages are from Plaid. Can you login to USAA right now? (I cannot).

  13. 13 Posted by layer on 09 Jan, 2022 09:49 PM

    layer's Avatar

    Yes, I can login to USAA. Have several times today.

    As for the OFX connection, OK, I will try it.

  14. 14 Posted by layer on 09 Jan, 2022 09:53 PM

    layer's Avatar

    Using the "Set Up Online Banking" and choosing OFX did nothing, so maybe USAA is having issues. I'll try all this tomorrow.

  15. 15 Posted by dtd on 09 Jan, 2022 09:58 PM

    dtd's Avatar

    If you wish to try it, have you ever used the Toolbox extension? You will need it as that is where the simple fix is now.
    Also, you can read the Moneydance article on the subject.
    https://infinitekind.tenderapp.com/kb/online-banking-and-bill-pay/connecting-with-usaa

    The ironic part of this is that you need to be able to login to the USAA website (which *I* cannot do right now. ;) )

    Good luck, and if it still seems frustrating, I recommend you try the Plaid connection tomorrow as Plaid may be having the same problems I am getting login authentication. Then again - it may be something else, with the logging in (today) being only part of it.

    Good luck.

  16. 16 Posted by dtd on 09 Jan, 2022 10:00 PM

    dtd's Avatar

    You cannot just do setup online banking and choosing OFX for USAA, but yes, I think you're right. Try again tomorrow.

  17. layer closed this discussion on 10 Jan, 2022 04:23 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac