Moneydance sync -- nothing works

schveiguy's Avatar

schveiguy

10 Jan, 2022 01:06 AM

I have used moneydance for years, since at least 2012. I have been using the dropbox sync (using dropbox connection) to connect first to my iOS devices, and then when it was supported, to other macs.

Now, I have a new mac and I wanted to add it to the mix. I have upgraded to the latest 2022 version. I installed 2022 moneydance on the source computer and the target one. The target one I opened the sync file, and it was taking AT LEAST an hour, so I force quit.

I removed everything on my ios devices, removed my .moneydancesync folder from dropbox, turned off syncing, then re-added syncing. Now it syncs quickly -- but nothing comes over except the name of the file. No accounts, no transactions, nothing. Net worth 0.

How do I reset everything so it starts working? I tried backing up my data, deleting the moneydance folder and starting over, restoring the data. Same result.

Source system is using Monterey 12.1, Target is stuck on High Sierra (older mac). At one point it was the one with the original moneydance files, but then I moved it. I also have a third mac I want to add, which has the same problem.

Please help!

  1. 1 Posted by Stuart Beesley ... on 10 Jan, 2022 07:10 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Two options, both on the original md that was working.

    Ensure that sync is turned on.

    1. Install/run toolbox extension. Turn on hacker mode. Hacker menu. Option force push sync. Wait…. Restart md. try enabling sync on the others, or rather file/new/open sync copy.

    Or

    1. File/export backup. File / restore backup. Enable sync. Wait. Restart md. Then enable sync / file/new/open sync copy on others.
  2. 2 Posted by schveiguy on 11 Jan, 2022 02:04 AM

    schveiguy's Avatar

    I'll try option 1. The second one I already did (backup, then removed moneydance data completely, restored from backup and it still didn't sync).

    A question: what does "Wait" entail? Is there a certain time I have to wait to ensure it's synced fully?

  3. 3 Posted by Stuart Beesley ... on 11 Jan, 2022 08:05 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    On option 2. When you say you restored from backup… How did you restore? If you did MD menu / file / restore from backup, then ok. But if you did some other type of restore then that will be no good for this problem.

    Wait.. a few mins that’s all.

    Also, pls use Dropbox folders and not Dropbox connection. Install Dropbox on each device and ensure it’s logged in and working before starting. Sync method should all be set to DB Folders.

    Lastly, if it still doesn’t work. Find help/console and post the contents here as an attached txt file.

  4. 4 Posted by schveiguy on 11 Jan, 2022 09:14 PM

    schveiguy's Avatar

    In toolbox I got message:

    "This Dataset is running as a 'Secondary Node'
    - either you are Synchronising to it,
    - or you have restored it from a backup/sync copy.
    If these statements are true / OK, then ignore this message...
    >>Otherwise, to convert to Primary, use Advanced Tools Menu."

    Switched to Primary dataset and...

    It works! So the issue must be that the computer I'm using now is not the one that I started using Moneydance on?

    If this is the case, then I'd say it would be a very useful feature for the main Moneydance application to support the "reset sync system with this as the primary dataset". As I imagine it's uncommon but not unreasonable for someone to just assume you can get rid of an older computer without worrying about it being the primary dataset, since the data is synced to your new one. The steps to do this with the toolbox were NOT user-friendly (I'm a developer, so it was OK for me).

  5. 5 Posted by schveiguy on 11 Jan, 2022 09:19 PM

    schveiguy's Avatar

    BTW, still using dropbox connection. I need to use that instead of dropbox folders because on at least one of my systems, it is already logged into a different user for dropbox.

  6. 6 Posted by dwg on 11 Jan, 2022 09:38 PM

    dwg's Avatar

    I'm a fellow user.

    Yes your restored backup was from a secondary machine, hence why you cannot initiating syncing from it.

    It is an uncommon problem but it does occur.

    The original approach was that a script would be provided that changes the designation of the restored backup. This along with other scripts were collected and bundled together into the toolbox extension so that they would all be in a common place and as a single extension easy to distribute. Toolbox has since been enhanced with many other useful tools and the older scripts have also been enhanced.

    I'm not sure that being a menu item in Moneydance would be such a good idea, it is not the sort of thing that you want to be mainstream, like many of the tools you want its use to be very deliberate hence the many warnings in toolbox and I think the preference is if you do not understand what is going on then ask.

  7. 7 Posted by Stuart Beesley ... on 11 Jan, 2022 10:08 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    @schveiguy - so are your issues all resolved now?

    Toolbox is technical. It was a voyage of discovery to write. MD is a technical system and yes, I guess the language of it is probably too technical for lots of users. BUT it was really intended for knowledgable users/support to point users to the toolbox options to self-apply the fixes - in a safe way. Much better than a) no help, or b) run these scripts with no safety features.

    Over time, as we become comfortable with it, I can try to make it more user friendly.

  8. 8 Posted by schveiguy on 12 Jan, 2022 03:12 AM

    schveiguy's Avatar

    Thanks Stuart, it seems my issue is resolved.

    I understand and appreciate how it came to exist. My point is that this is the current status quo:

    1. I have a system that has data in it
    2. Moneydance claims to be able to sync this with other systems
    3. I set up syncing, setup appears to succeed
    4. Nothing syncs. No error messages.

    This is not a good user experience.

    Now, it's obvious to the toolbox that this is a problem, the message I posted shows that. It would not be unreasonable for a moneydance installation that has no syncing enabled when set up to *start* syncing existing data, to identify that "hey, this isn't a primary dataset, only updates will be synced, not the current data. Otherwise, click this button to set this data as the primary data source".

    This does not seem dangerous to me. Or maybe "This can only be done by installing the toolbox extension".

    Just, to have it appear to succeed and then sync nothing is really frustrating.

    I've said my piece, just a suggestion in case anyone thinks it's a good idea.

  9. 9 Posted by dwg on 12 Jan, 2022 03:24 AM

    dwg's Avatar

    I would take a different approach in the core program. The backup/restore capability in Moneydance currently disables syncing, I would extend this to also reset the dataset type.

  10. 10 Posted by Stuart Beesley ... on 12 Jan, 2022 07:55 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    From memory, the latest preview resets the flag to primary upon restore?

  11. 11 Posted by schveiguy on 13 Jan, 2022 01:58 PM

    schveiguy's Avatar

    OK, while I have you guys here, now that I got my second computer syncing, my iPhone is not!

    I open the app, select DropBox, log in, then it says I'm connected, and it says "Select File to Sync", with a spinner that runs forever. No items ever come up.

    How do I fix this? I tried deleting the app and reinstalling, still doesn't work.

  12. 12 Posted by Stuart Beesley ... on 13 Jan, 2022 02:23 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Personally, I would install the dropbox app on the iPhone and ensure that is logged in and syncing OK, Then try MD app again

  13. 13 Posted by schveiguy on 13 Jan, 2022 02:31 PM

    schveiguy's Avatar

    I installed the dropbox app. Changed nothing.

    Uninstall moneydance reinstall. The only thing i can do is tap the "Dropbox" button. I log out, tap to authorize dropbox, it brings me to the dropbox app (instead of safari) where I authorize. Then -- infinite spinner.

  14. 14 Posted by schveiguy on 13 Jan, 2022 03:29 PM

    schveiguy's Avatar

    Update: I installed the preview release, deleted everything, restored from the backup file, and indeed it sets it to primary.

    Now my phone is working. Whatever toolbox did it didn't work right. But preview release does work right.

  15. System closed this discussion on 14 Apr, 2022 03:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 May, 2022 08:42 PM
23 May, 2022 07:41 PM
23 May, 2022 07:40 PM
23 May, 2022 07:20 PM
23 May, 2022 07:18 PM