I'm trying to try Moneydance, but I get a really odd bunch of characters displaying

's Avatar


21 Apr, 2015 03:31 AM

See the attached file. I saw a really old knowledgebase article on this, and tried to follow the tips therein (mostly just making sure Java was up to date). I also uninstalled the 64-bit version to try the 32-bit, and the problem still occurred.

Any ideas?


  1. 1 Posted by Matt Bisgaier on 21 Apr, 2015 02:34 PM

    Matt Bisgaier's Avatar

    I selected the top option and got it to load, but it's still not looking good. Oddly, however, a few words ARE legible.

  2. 2 Posted by David Hanley on 21 Apr, 2015 03:34 PM

    David Hanley's Avatar

    Hi Matt,

    Could you try installing this preview build version of Moneydance to see if it resolves your problem?


    If that fails to resolve this issue, can you send us the output of your console log? This can be found by going to Help -> Console window in Moneydance, then clicking the "Copy to clipboard" button and pasting the output to us here.

    Hope this helps, and feel free to contact me with any questions about this process!

    David Hanley
    Infinite Kind Support

  3. 3 Posted by Matt Bisgaier on 21 Apr, 2015 07:19 PM

    Matt Bisgaier's Avatar

    The issue is still there. Here's the log:

    Starting Moneydance 2015.4 (1198) at Tue Apr 21 15:17:30 EDT 2015

    Settings Folder: d:\Users\Matthew\.moneydance

    OS: Windows 8 6.2 amd64

    Java: 1.8.0_31 (Oracle Corporation)

    Is in sandbox: false; restricted file access: false

    Initializing Moneydance SSL

    Created new custom trust manager

    TRUSTMGR: initialized custom stream handler factory...

    initialised mono font: java.awt.Font[family=Dialog,name=Gill

    initialised fonts:
    base=java.awt.Font[family=Helvetica Neue,name=Helvetica
    numeric=java.awt.Font[family=Dialog,name=Gill Sans,style=plain,size=12];
    header=java.awt.Font[family=Helvetica Neue,name=Helvetica

    multires images available: true

    initialised mono font: java.awt.Font[family=Dialog,name=Gill

    opening last file: Business Finances

    loading dataset: d:\Users\Matthew\.moneydance\Documents\Business

    loading with 128 bit encryption key

    book:Business Finances; uuid:7b60b1cd-cd03-48c3-b505-7ceaa49a0b01

    trunk data loaded (0.05 seconds), checking for incremental updates

     reading txn file 20150421032830_650.txn

    error loading txn file tiksync/out/20150421032830_650.txn; continuing.
    error: java.io.IOException: javax.crypto.BadPaddingException: Given final
    block not properly padded

     reading txn file 20150421032832_489.txn

     reading txn file 20150421032832_538.txn

    replacing root: null () with new root: Business Finances

    set antialiasing to HRGB

    invalid or null sync type ID; detecting best method...

    Dropbox folder method is valid. Using it: Dropbox Folder:

  4. 4 Posted by Ben Spencer on 26 Jul, 2015 07:48 PM

    Ben Spencer's Avatar

    I think this might be caused if you have clear type fonts enabled on windows. Can you try disabling clear type fonts with the instructions below:


    Ben Spencer
    Infinite Kind Support

  5. 5 Posted by Matt Bisgaier on 26 Jul, 2015 08:34 PM

    Matt Bisgaier's Avatar

    Yup, it works! But...

    As I suspected, everything looks really horrible with ClearType off. Not
    only in Moneydance (see below), but everywhere. Not really a viable
    solution, unfortunately.

    [image: Inline image 1]

  6. 6 Posted by Ben Spencer on 26 Jul, 2015 08:42 PM

    Ben Spencer's Avatar

    Other have reported that updating to the latest preview fixes the cleartype issue. Can you try updating from the link below:


    Ben Spencer
    Infinite Kind Support

  7. System closed this discussion on 19 Mar, 2016 04:55 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac