Line thickness and zooming

Shinoda's Avatar

Shinoda

13 Apr, 2013 07:10 PM

I understand that the SyncSpace controls the thickness of the line proportional to the zoom factor.

However, if I zoom-in beyond some point, the line suddenly gets thinner, and resumes proportional behavior.
This behavior is repeated when I continue zooming-in.

Is this the expected behavior?

I would expect line thickness held at the same size regardless of the zoom factor...

  1. Support Staff 1 Posted by Sean Reilly on 14 Apr, 2013 03:14 PM

    Sean Reilly's Avatar

    Hi Shinoda,

    Thanks for your message! What you describe is the intended behaviour but we're very open to feedback on it.

    We call this feature "line width matching" and it has evolved from previous similar features. With SyncSpace's zooming we had two ways of dealing with line widths:
    1) line widths could be constant across zoom levels. 2) line widths could be relative to the current zoom level

    Of course, if we went with #1 then lines would be invisible when zoomed out beyond a certain length and overwhelmingly large if you zoomed in a couple of times. If we went with #2 (as we did prior to the 1.0 release) many drawings and diagrams would have slightly varying line widths if you pan and zoom around a bit when drawing. That gets annoying very quickly.

    The current behaviour is our attempt to solve both problems. If you draw a line with the same width setting as a line that is nearby and was drawn at a similar zoom threshold, then the new line will have a width that exactly matches that similar line.

    I think this does a good job in helping create consistent looking sketches, but perhaps we could make this a customisable option or tighten up the matching threshold. I'd love to hear your thoughts given the explanation above of how it works.

    Thanks!
    Sean

  2. System closed this discussion on 31 Mar, 2015 04:04 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac