Bug in Budget reports

ceejayt's Avatar

ceejayt

27 Dec, 2016 01:56 PM

Hi

When I create a budget for a whole year with custom dates 1st January to 31st December and there is a category with no budget value but an actual expense it is shown (with a foyer in brackets (not in budget)

The same report run for This Month pr even using Cistom Dates for the month does not show that expense category.

Am I doing something wrong or is there a bug somewhere in here?

Thanks

  1. 1 Posted by Ian O on 01 Mar, 2017 10:54 AM

    Ian O's Avatar

    Hi,

    Please accept my apologies for the delayed your response on this discussion. Has this issue arisen since your recent upgrade to Moneydance 2017?

    Can you send me your errlog.txt file? This will hopefully highlight any strange behaviour occurring on your system. As you're using Mac OS X, it should be located at one of these locations within your Home folder:

    ~/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance/errlog.txt

    or:

    ~/Library/Application Support/Moneydance/errlog.txt

    If you have any trouble finding your Home Library folder, open Finder and select Go -> Go to Folder and and copy and paste in the following:

    ~/Library

    This should pull up your local Library folder.

    Ian O
    Infinite Kind Support

  2. 2 Posted by ceejayt on 01 Mar, 2017 11:08 AM

    ceejayt's Avatar

    This has been an issue since Moneydance 2015 - was incorrect in that version also.  Error log attached

    Here is the current problem with a little more detail to help you identify what is wrong:

    Let me say I have an expense category called Heating and I enter a budget as follows:

    Jan £100
    Feb  £0
    March £100

    Actual expense is as follows:

    Jan £0
    Feb £75
    March £75

    Now run budget v actual for January - the answer is correct Budget £100 actual zero and underspend £100

    Now run Budget v Actual for Feb - the correct answer would be Budget £0 Actual £75 and overspend £75 but the system DOES NOT REPORT the budget line at all

    The result of the above is that if you run an expense report for February you will see you have spent a total of £75, if you run a budget report it shows you have not spent anything giving a mismatch between the reports.

    The work around is to put budget of £1 into February and then the expense reports and budget reports will tie up.

    I think the problem is inherent in the workings of the software and not a bug at all - but it is wrong.  Last year it led me badly astray as I was only looking at budget reports and in the end I had spent much more money than I budgeted because of these non reports where the budget was zero.

    I am a qualified accountant so i do know what I am looking at and what I would expect the system to report.  I now run bith the expenses report and the budget report and then add budgets of £1 where the system has failed to report spend in order to ensure actual soend per expenses matches actual spend per the budget report.

    Hope that helps

    Chris

    Sent with Unibox

  3. 3 Posted by ceejayt on 01 Mar, 2017 11:10 AM

    ceejayt's Avatar

    However, i should add - I really love Moneydance despite this!

  4. System closed this discussion on 31 May, 2017 11:20 AM.

  5. ceejayt re-opened this discussion on 14 Oct, 2017 01:15 PM

  6. 4 Posted by ceejayt on 14 Oct, 2017 01:15 PM

    ceejayt's Avatar

    Budgeting and the reporting of budgeting remains a serious problem - bit fed up with this now.

    For example, I have a budget for Home furnishing for the year of £1050 and all the budget reports tell me I have spent £1097 - however, the income and expense report correctly tells me I have spent £3200 this year.

    Is this part of the product getting any attention at all?

  7. 5 Posted by ceejayt on 14 Oct, 2017 01:18 PM

    ceejayt's Avatar

    BTW - this problem occurs when there is zero for the budget month and expenditure in the month eg £1900 actual but zero budget - it then simply does not include the actual costs in the budget - this has to be a simple report fix

  8. 6 Posted by Tightpants on 17 Dec, 2017 08:46 AM

    Tightpants's Avatar

    I am having the same issue with MD v2015.8. When the budgeted amount is 0 but you spend against this category it does not appear in the budget report. This does need to be fixed.

  9. System closed this discussion on 18 Mar, 2018 08:50 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac