TD Bank

Alan Belisle's Avatar

Alan Belisle

07 Dec, 2009 01:31 PM

Looks like TD Bank made changes over the weekend of late last week. Used to work and now I get "Error: java.net.UnknownHostException: ofx.tdbank.com". I'm currently running Moneydance 2008R4 (641). The name of my bank in Moneydance is "TD Bank Online Banking".

Thanks in advance for your help.
Alan Belisle

  1. 1 Posted by Alan Belisle on 07 Dec, 2009 01:35 PM

    Alan Belisle's Avatar

    Just upgraded to latest preview release, which is 2008R4 (643), and I get the same error.

    Cheers,
    Alan Belisle

  2. 2 Posted by Angie Rauscher on 07 Dec, 2009 06:24 PM

    Angie Rauscher's Avatar

    A few weeks ago we updated our connection information for your bank. Would you please try creating a new connection? You will need to disable your current connection to your bank and then recreate it using the New Connection button on the Online Banking Setup screen. To do so, you can follow these steps:

    1) Select your bank account in Moneydance
    2) Select the Online->Setup Online Banking button/menu
    3) Click the "Disable" button
    4) Select the Online->Setup Online Banking button/menu (again)
    5) Click the "New Connection" button and select your bank and hit OK
    6) Continue with the setup process, entering your username/password
    7) Repeat steps 1-6 for each account

    Make sure you pick new connection, even though your bank is still one of the connection choices after you disable it. Choosing your bank from the list of available banks will force Moneydance to download the updated information, which should then allow you to connect.

    Please let me know if you continue to have connection problems after recreating your connection and we will look further into the issue.

    Angie Rauscher
    Moneydance Support

  3. 3 Posted by Howard Kaufman on 21 Dec, 2009 01:21 AM

    Howard Kaufman's Avatar

    Sorry to report that I too am having trouble with TD Bank again. I can download transactions but I can no longer pay bills online. I tried to disable and recreate the payment account from scratch but still get the following error:

    There was an error communicating with your financial institution. The details of the error are below: Bank Name: TD Bank Online Banking.

    This started a couple of weeks ago and this is the first chance I've had to report it. Using MD 2010 (721)

    Regards,

    Howard

  4. 4 Posted by Howard on 27 Dec, 2009 06:44 PM

    Howard's Avatar

    Sorry, still having the same problem. I realize it's holiday season, but I wonder if anyone can help resolve this.

    Thanks!

    Regards,

    Howard

  5. 5 Posted by Angie Rauscher on 28 Dec, 2009 02:43 PM

    Angie Rauscher's Avatar

    Howard,

    What version of Moneydance are you using? You can find out your version by going to the Help Menu and choosing the About Moneydance option. If you are not using the most recent version (2010 build 735), please update to that version. You can download the update [here]http://moneydance.com/other). This update has resolved a few key issues our users have been experiencing. Please let me know if your issue persists and we will look into other solutions.

    Most financial institutions will require you to enable your accounts for application-based online banking. If you have your financial institution set up your account as if you were using Quicken 2008 for Windows then it should also work with Moneydance since they use the same protocol. This is sometimes necessary as many banks don't yet recognize Moneydance or know how to deal with it.

    Keep in mind that application-based online banking often requires a different login/PIN than the ones that are used for ATM or web-based banking. When you enable your account for access from Moneydance or Quicken, your financial institution should let you know what customer ID/login and PIN to use. We have heard of some users needing to re-enable their accounts after the TD server upgrade went into effect.

    Please let me know if I can be of further assistance, and thank you for your interest in Moneydance.

    Angie Rauscher
    Moneydance Support

  6. 6 Posted by Howard Kaufman on 28 Dec, 2009 03:26 PM

    Howard Kaufman's Avatar

    Hi Angie,

    On Dec 28, 2009, at 9:43 AM, Angie Rauscher wrote:

    > Keep in mind that application-based online banking often requires a
    > different login/PIN than the ones that are used for ATM or web-based
    > banking. When you enable your account for access from Moneydance or
    > Quicken, your financial institution should let you know what
    > customer ID/login and PIN to use. We have heard of some users
    > needing to re-enable their accounts after the TD server upgrade went
    > into effect.

    I did re-enable the account after the TD server was upgraded and it
    worked for about a month until a couple of weeks ago. Now it gives
    the error every time. I tried to re-enable it again several times to
    no avail. My version of MD is 2010 721. (That is the latest I
    think). I have it working in Quicken with the same login info.

    I've attached a screenshot of the final setup screen in MD that shows
    a lack of detail for most of the institution's data. That seems
    strange. Clicking on Refresh does not change any of the data.

    I'd love to get this working again.

    Thanks!

    Regards,

    Howard

  7. 7 Posted by Jessica Little on 29 Dec, 2009 04:35 PM

    Jessica Little's Avatar

    Hi Howard,

    It may be the case that our connection information for TD is out of date, especially if they made more server changes recently. I'll research their information and let you know once we've either updated it or verified that our database is current.

    I'm sorry for the inconvenience. Hopefully we can get this working shortly.

    Jessica Little
    Moneydance Support

  8. 8 Posted by Howard Kaufman on 29 Dec, 2009 07:00 PM

    Howard Kaufman's Avatar

    OK sounds good.

    Regards,

    Howard Kaufman
    Lectrosonics
    (516) 557-5213

  9. 9 Posted by Jessica Little on 29 Dec, 2009 08:40 PM

    Jessica Little's Avatar

    OK, we've updated our connection information for TD Bank. You'll probably need to reset your connection using the steps outlined above, but it should work now. Please let me know if you continue to have problems connecting to TD.

    Jessica Little
    Moneydance Support

  10. 10 Posted by Howard Kaufman on 29 Dec, 2009 09:10 PM

    Howard Kaufman's Avatar

    Hi Jessica,

    Sorry to report that it's still not working. I did disable and then
    re-create the online bill payment from scratch and still get the same
    error as before. See attached error message.

    Regards,

    Howard

  11. 11 Posted by Howard Kaufman on 29 Dec, 2009 09:12 PM

    Howard Kaufman's Avatar

    BTW, just as a test I booted up Quicken and sent a test payment to TD bank with the same credentials. It worked as expected.

  12. 12 Posted by Jessica Little on 30 Dec, 2009 08:15 PM

    Jessica Little's Avatar

    Hi Howard,

    In the most recent error message screenshot you sent, it looks like there might be more information hidden in the window. Could you please try to connect again and, when you get the error, click and drag the lower right-hand corner of that window to enlarge it? There may be more useful information hidden away. I've reported this bug to our lead developer, by the way, so hopefully in the future the window will have scroll bars.

    If that really is the full error message, than I'll need more information in order to troubleshoot what's going on. In that case, would you be willing, could you send me the contents of your error console? Here's how to get the log in Moneydance 2010:

    1) In Moneydance, click on the Help menu and select the Console Window option. This will open the console messages window.
    2) While the Console Window is open, attempt to connect to your bank. Any error messages should be recorded to the Console.
    3) Select all of the text in the Console and use the "Copy to Clipboard" button at the bottom to copy the text.
    4) Paste the text from the message window into a text file (preferably saved with a .txt extension) and email that file to me at [email blocked].

    The debugging logs that this produces will contain your account information. Because of this, please don't post the file to this public forum. Also, you should redact any account info in the debug logs. Just replace it with something like "ACCOUNT NUMBER HERE" and it should be fine.

    Jessica Little
    Moneydance Support

  13. 13 Posted by Howard Kaufman on 31 Dec, 2009 02:32 AM

    Howard Kaufman's Avatar

    Wow, I feel dumb! I did expand the error window and the missing info
    said that the error was caused by having a date that was too soon! I
    tried again with a date a few days later and the payment went
    through! So sorry to put you to this trouble. I didn't notice that
    the error window could be expanded so I had no clue as to why it
    errored.

    Oh well, at least it's working. It does bring to mind a small
    suggestion for the suggestion box: Allow a preference to set the
    number of days lead time that appear as the payment date when calling
    up the Send Online Payment window. Then the user could have it as a
    default, depending on the particular financial institution.

    So thanks for helping to solve this. It was "operator error" -
    something I'm sure you deal with all the time!

    Happy New Year!

    Regards,

    Howard

  14. 14 Posted by Jessica Little on 02 Jan, 2010 02:10 PM

    Jessica Little's Avatar

    Hi Howard,

    happy New Year to you too! I hope you had an enjoyable New Year's Eve.

    I also missed that the error window could be expanded at first. Sean (our lead developer) noticed it when I was asking him about why your error message was so short and seemingly useless. Needless to say, he's planning on fixing things in a future build of Moneydance so that there's at least a scrollbar to show that there's more to the error message than first appears!

    As for you date restrictions, I'll pass your suggestion on. I think it's set the way it currently is because that's the lead time many banks suggest to ensure that you're payment arrives on time. There is currently a way to completely turn off the date restriction however. If you go to your preferences window and look under the Network tab, you should see a checkbox towards the bottom that says "Observe Online Payment date Restrictions." If you uncheck that box, you'll be able to submit payments for any future date.

    Please let me know if I can be of any further assistance, and thanks for using Moneydance!

    Jessica Little
    Moneydance Support

  15. 15 Posted by Howard Kaufman on 03 Jan, 2010 03:11 AM

    Howard Kaufman's Avatar

    It's all good. Thanks for the great follow-up!

    Regards,

    Howard

  16. Raimund Buchholz closed this discussion on 13 Apr, 2010 11:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac