USAA connection

dwk's Avatar

dwk

31 Jul, 2021 02:39 AM

30 July 2021
Looking at the current IK information on this website it appears that no progress has been made on the USAA problem in June and July, 2021. Is that the case, or am I missing something important?

THIS IS NOT 'PRIVATE'

  1. dwk closed this discussion on 31 Jul, 2021 02:44 AM.

  2. dwk re-opened this discussion on 31 Jul, 2021 02:44 AM

  3. 1 Posted by dtd on 31 Jul, 2021 02:55 AM

    dtd's Avatar

    There's no progress, because the primary issue was solved on February 23.

    If you are willing to follow the process, you can achieve access to USAA by following the directions and the script.

    You know where to find the links.

  4. 2 Posted by dwk on 31 Jul, 2021 04:57 AM

    dwk's Avatar

    Your email was a bit strong and overstated, but I know you have put a lot of work into a solution as a knowledgeable user. Though I note from other comments that there still appear to be problems that arise.

    However, my question was primarily directed at Infinite Kind staff, and concerned with whether discussions with USAA have resulted in any permanent solution at that level. It appears that the answer is no, and IK has been lucky to have you and others provide external solutions in the meantime.

  5. 3 Posted by dtd on 31 Jul, 2021 10:03 PM

    dtd's Avatar
  6. Support Staff 4 Posted by Jenny on 02 Aug, 2021 10:01 AM

    Jenny's Avatar

    Hi,

    You can find the latest update from our lead developer in post 417 of this thread.
    I have also included the reply below:

    "There have been some great questions recently about our long-term fix for the USAA situation.
    In the short term, we're very grateful for Stuart's script and would recommend that people use it for now.
    In the medium term, we are working on an update that will make signing up for OFX connections with a web-based flow and authentication much simpler and friendly.
    In the long term, we are working on an implementation of FDX which will make use of the web-based authentication flow, followed by a more friendly API which is likely to eventually eclipse the capabilities of OFX.

    An official announcement will be coming soon, but The Infinite Kind is now a full member of the Financial Data Exchange (FDX) which is the organization behind the FDX protocol. USAA is possibly the biggest driver of FDX and is one of the most prominent technical leaders. I've been spending the last few days soaking up information and making contacts at their annual summit/conference.
    FDX is coming to Moneydance and I'm confident that we'll soon have a solid long-term connection to USAA.
    "

    I hope this information is helpful. Please let us know if you have further questions.

    --
    Jenny, Infinite Kind Support

  7. 5 Posted by dwk on 02 Aug, 2021 06:33 PM

    dwk's Avatar

    Thank you, Jenny. I look forward to the long-term connection with USAA. I still see enough comments re glitches in use of the Stuart script that I am anxiously awaiting an official MoneyDance-USAA solution. If possible, please keep me informed when that happens.

    Best,
    David

  8. 6 Posted by guyver0313 on 23 Sep, 2021 11:42 AM

    guyver0313's Avatar

    So, after using the workaround for several months, it seems to have stopped working. Suddenly, about 2 weeks ago, it has stopped downloading transactions. I know there are cleared transactions, but none get downloaded for any of the accounts. Is there something new?

  9. 7 Posted by Pete on 23 Sep, 2021 12:24 PM

    Pete's Avatar

    Guyver0313 - greetings.

    I reluctantly purchased a version of Quicken to run in parallel with Moneydance. I receive the same errors in both. I speculate that the issue is on the USAA side.

    My workaround is to download .csv files from USAA and import them into Moneydance. I have not had any success fixing Quicken entries unless I manually enter and clear them myself.

    FWIW

    Pete

  10. 8 Posted by dtd on 25 Sep, 2021 04:33 AM

    dtd's Avatar

    just a user,
    I've been out of town, but checked tonight,

    FOR ME, the USAA connection to checking is working fine as of today.

    The USAA connection to credit cards is also working, but I do get duplicate transactions as the FITID is not always correct, same as with Quicken users.

    If you are not getting anything, Im not sure what is happening.

    So, nothing new from my end at least.

  11. 9 Posted by guyver0313 on 26 Sep, 2021 10:06 PM

    guyver0313's Avatar

    So, I checked my console window and downloaded from one account. It all reads like gibberish to me. I have removed ID information but I got the following:

    Sending message to https://df3cx-services.1fsapi.com/casm/usaa/access.ofx

    using internal https checking

    OFXHEADER:100
    DATA:OFXSGML
    VERSION:103
    SECURITY:NONE
    ENCODING:USASCII
    CHARSET:1252
    COMPRESSION:NONE
    OLDFILEUID:NONE
    NEWFILEUID:NONE




    20210926165939.682
    **************
    *
    N
    ENG

    USAA Federal Savings Bank
    67811

    QMOFX
    2300
    *******************************************




    1632693579682-80


    *********
    **************
    CHECKING


    Y




    <<<<77<<<<
    connecting to: https://df3cx-services.1fsapi.com/casm/usaa/access.ofx with method: POST
    Connecting with https headers:
    POST /casm/usaa/access.ofx HTTP/1.1
    Host: df3cx-services.1fsapi.com
    Content-Type: application/x-ofx
    Accept-Language: en-us
    Cookie: visid_incap_2454689=/QsTdSnJTd6YYb1N8qxtOMXxR2EAAAAAQUIPAAAAAADDmXQb1n9N/jJretDAAmOV; incap_ses_1325_2454689=VUxHIOyDjzw1GLEYp1hjEjp2T2EAAAAAB/NGyeO/xoLNkU/jgc+DDA==; incap_ses_1417_2454689=YNv2bTQMr1tbylf/IDKqE/55T2EAAAAADUJXo9uw8cOuwCtEB6qZIQ==; incap_ses_1327_2454689=0YocY3rh1mTf2Tm1pnNqEqfsUGEAAAAAPq6GjgyfYAzZ4C+AS9Sr6g==
    Date: Sun, 26 Sep 2021 16:59:39 CDT
    Accept: /
    User-Agent: InetClntApp/3.0
    Content-Length: 680
    Cache-Control: no-cache
    Connection: close

    ---end headers HTTP/1.1 403 Forbidden
    Content-Type: text/html
    Cache-Control: no-cache, no-store
    Connection: close
    Content-Length: 837
    X-Iinfo: 14-81614067-0 NNNN RT(1632693577805 55) q(0 -1 -1 -1) r(0 -1) B15(14,0,0) U6
    Strict-Transport-Security: max-age=31536000

    HTTP response headers:
    content-length: [837]
    content-type: [text/html]
    connection: [close]
    cache-control: [no-cache, no-store]
    x-iinfo: [14-81614067-0 NNNN RT(1632693577805 55) q(0 -1 -1 -1) r(0 -1) B15(14,0,0) U6]
    strict-transport-security: [max-age=31536000]
    Reading message from https://df3cx-services.1fsapi.com/casm/usaa/access.ofx

    uh oh, we've gotten some OFX with no headers:

    Request unsuccessful. Incapsula incident ID: 1327000200056265183-374203174689375502Warning: unidentified entity: &xinfo=14-81614067-0%20NNNN%20RT%281632693577805%2055%29%20q%280%20-1%20-1%20-1%29%20r%280%20-1%29%20B15%2814%2c0%2c0%29%20U6&incident_id=1327000200056265183-374203174689375502&edet=15&cinfo=0e000000eeb3&rpinfo=0&mth=POST
    BEGINRESPONSE>>>>>









    Request unsuccessful. Incapsula incident ID: 1327000200056265183-374203174689375502

    <<<<<<<<ENDRESPONSE
    Unhandled OFX message set: HEAD
    Unhandled OFX message set: BODY

  12. 10 Posted by dtd on 26 Sep, 2021 10:20 PM

    dtd's Avatar

    I'm no expert on error logs either (you need Stuart, or someone like that to interpret), but I do peg on this line:

    ---end headers HTTP/1.1 403 Forbidden

    From the documentation I wrote on the USAA fix:

    HTTP/1.1 403 FORBIDDEN – USAA appears to have more restrictions on who can download OFX transactions. One seems to be “U.S. only” which is odd given USAA is all about the military but let’s move on. If you are outside the U.S., you may encounter this, and must use a VPN to “be in the U.S.”. Another issue that triggers this is connecting too many times quickly. You get banned from connecting, but this appears to be short term, you can try again a few hours later.

    So, I have no more answers, but this may give you some insight. Where are you located? Maybe USAA is tightening even further who can connect?

    Another thought is to call USAA and ask them to look things over (tell them you are using Quicken, of course, but you can no longer connect, otherwise USAA will blame Moneydance).

    Hope that helps.

  13. 11 Posted by Stuart Beesley ... on 27 Sep, 2021 06:43 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @guyver0313 has the script solution for usaa been working for you ok before this, or is this your first attempt to set it up?

  14. 12 Posted by dtd on 27 Sep, 2021 09:34 PM

    dtd's Avatar

    @guyver0313 said this has been working for him for "several months" and it quit working 2 weeks ago.

  15. 13 Posted by Stuart Beesley ... on 27 Sep, 2021 09:41 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Then, sorry I don’t know…

  16. 14 Posted by dtd on 27 Sep, 2021 09:53 PM

    dtd's Avatar

    that's where my "HTTP/1.1 forbidden" bit comes in, it's all I could figure out from the error log he posted.

  17. 15 Posted by guyver0313 on 28 Sep, 2021 02:37 AM

    guyver0313's Avatar

    Sorry to take so long responding. So, it worked up until I was on vacation at the beginning of September. I am in the US and I use a VPN that is set to Houston, TX. So, that's not an issue. I have also tried it without my VPN turned on and same results.

  18. 16 Posted by guyver0313 on 28 Sep, 2021 02:39 AM

    guyver0313's Avatar

    UPDATE: I just changed my VPN to Denver and it suddenly started to work. But really, that should not have been an issue as long as I am in the USA. So, weird....

  19. 17 Posted by dtd on 28 Sep, 2021 04:00 AM

    dtd's Avatar

    Obviously, this is all on USAA and I personally have no idea who they are blocking and who they are allowing. Glad you have it working again.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac