Wachovia Securities download

arfinger's Avatar

arfinger

11 Apr, 2009 01:05 PM

I see that you have added Wachovia Securities to the financial institution list for direct download. Thanks.....almost!

However, I can't seem to get it to work. I go set up a new connection and select Wachovia Securities. I then select one of the accounts I have with them and hit next. Then I add my ID and password (I know these are correct because I can log in to the website). I now am at a screen that says "Please choose the account that you wish to use." I have check boxes for online banking and bill payment. Under each check box is a drop down account list. I can not select the check boxes or the drop down list. I can not select next at the bottom of the window. All I can do is hit cancel and exit the online banking sign up. Am I doing something wrong or is something wrong with MD or Wachovia Securities? Any help is appreciated.

  1. 1 Posted by avp2 on 12 Apr, 2009 01:19 AM

    avp2's Avatar

    According to Wachovia on-line support, "direct access" to securities accounts is not available as of 3/31/09. The person I talked to seemed pretty knowledgeable (not always the case when talking to support people about direct access) and said he knew of no current plans to offer that service.

    I get the same thing you get when trying and I had checked because I have an AG Edwards account that was switched to Wachovia.

    I have found the same situation with Banc of America (Bank of America securities) too.

  2. 2 Posted by arfinger on 12 Apr, 2009 11:36 AM

    arfinger's Avatar

    I can currently do "direct access" through quicken and per their website they do offer "direct access".

    http://www.wachoviasecurities.com/pfm/softwarehelp/money2008/usingsoftware/download/software.html

  3. 3 Posted by avp2 on 12 Apr, 2009 11:27 PM

    avp2's Avatar

    From the info link you provided, it seems like it should be possible to "direct access". However, what I see is that my Wachovia Bank and Wachovia Securities on-line access id's and passwords are kept the same by the new Wachovia web site. If I change the password after logging into the Securities site, it changes the password to match for the Banking login. Then in MD, if I try to direct access the securities account using "Wachovia", it shows me the bank accounts to choose from. If I try to direct access using "Wachovia Securities". it show me the account drop down boxes greyed out. Seems like they may have combined their access in such a way that it confuses MD.

    Do you have both a Wachovia Bank and Wachovia Securities account that direct access? And, do you go to the same log on web page for both (I have been using www.wachovia.com) when you want to web access your accounts?

    I also tried the older logon page for retirement accounts (my securities account is for a retirement plan), but my old pre-AGEdwards being purchased by Wachovia id and password would no longer work there; neither would my newer Wachovia credentials.

    I guess I will have to contact them again to see if they can explain what is going on.

  4. 4 Posted by synapcoreb on 13 Apr, 2009 08:25 PM

    synapcoreb's Avatar

    I have a few Wachovia Securities (not Wachovia Bank) accounts. When trying to download the account information, I get an error "2000", informing me that it would take two (2) days before I could complete my download. It also states this applies to Windows: Quicken and MS Money: no mention of any other format. While it would be great to have this feature in MoneyDance for my Mac, it looks like this may be only a Windows feature. However, I will wait a couple of three days and try again. If I am successful, I will update my post.

  5. 5 Posted by randyfinger on 14 Apr, 2009 11:02 PM

    randyfinger's Avatar

    If helpful I can attach the OFXLOG.txt file from Quicken that shows the communication between the software and Wachovia Securities if that would help the MD staff fix the problem.

  6. 6 Posted by Brian Adler on 17 Apr, 2009 07:07 PM

    Brian Adler's Avatar

    One thing that may be occurring is an account type mismatch. Bank accounts in Moneydance must connect with Bank accounts via direct account, likewise investment accounts with investment accounts. Are you sure you have matched type with type?

    Randy can you install this debugging tool to help us clarify what is happening?

    1) Download this file: http://moneydance.com/preview/miscdebug.mxt 2) Select the Extensions->Add Extension menu and select the "From a File" option 3) Select the miscdebug.mxt file downloaded in step 1, and continue to install the extension 4) Select the Extensions->Moneydance Debugging Helper menu. This displays a window that will capture any error messages and OFX messages. 5) Attempt to download transactions until the error occurs 6) Select all of the text in the error message window and use command-C (ctrl-C on win/linux) to copy the text 7) Paste the text from the error message window into a response to this message.

    Please make sure to erase any mentions of your user/login ID and password/PIN from the copied text!

  7. 7 Posted by randyfinger on 17 Apr, 2009 08:59 PM

    randyfinger's Avatar

    I Can't add the extension in the link provided. I get the following error message from MD:

    Error: java.util.zip.ZipException: error in opening zip file

    Randy

  8. 8 Posted by avp2 on 21 Apr, 2009 04:21 PM

    avp2's Avatar

    I think I have found the problem. I opened a completely new db in an older version of MD (609 I believe), added the debug extension and was able to set up my Wachovia Securities and Wachovia Bank accounts for direct access with no problems and in the normal (via MD setup wizard) way. I then upgraded the older version to the current preview (635), tried the same thing and got a failure for the Wachovia Securities; it showed the bank type drop down menu for the Wachovia Security logon in the setup wizard. I had been using the 635 build when I tried before.

    It seems something went haywire in the OFX connection function at build 635 (or earlier). I did not try any builds between the earlier version that worked (I think 606) and 635. Also, unfortunately, I did not record the earlier version build number before I upgraded so I could be mistaken about whether it was build 606.

  9. 9 Posted by avp2 on 22 Apr, 2009 01:52 AM

    avp2's Avatar

    I just downloaded build 631 and it worked no problem with Wachovia Securities. Guess I will go back to using build 631.

    I am running OS Xv10.4.11 on a G4 mac.

    Here is the debug file (less my account data) I get when doing a successful "download transactions" in 631.

    status: Downloading Transactions...; meter: 0.0 running task... HTTP response headers: null: [HTTP/1.1 200 OK] Connection: [keep-alive] Set-Cookie: [st8id=1e1bcc1010b6de32734c584317443b31.00.bbc781d3d7c55fec876cdaf65944fac3; domain=.wachovia.com; path=/] Date: [Wed, 22 Apr 2009 01:31:58 GMT] Server: [MXYZPTLK Server 1.0] Content-length: [1835] Content-type: [application/x-ofx] Received message from https://pfmpw.wachovia.com/cgi-forte/fortecgi?servicename=ofxbrk&pagename=PFM

    OFX data file follows here

    <<<<<<<< elapsed time (balance recalc): 2 ms account modified: Ra-Wach SIMPLE IRA 7589 elapsed time (balance recalc): 2 ms account modified: Ra-Wach SIMPLE IRA 7589 ended task status: ; meter: 0.0

    ************ Oh man, figured I would run the 635 build on my db with the debug unit to see if its log looked like randyfinger's. To my surprise, my 635 build now works. I used the my real db in both runs and it never worked before. The debug log follows and is different too; it looks like there is a non-wachovia session opened with another institution. What is going on?

    status: Downloading Transactions...; meter: 0.0 running task... Sending message to https://pfmpw.wachovia.com/cgi-forte/fortecgi?servicename=ofxbrk&pagename=PFM

    OFXHEADER:100 DATA:OFXSGML VERSION:102 SECURITY:NONE ENCODING:USASCII CHARSET:1252 COMPRESSION:NONE OLDFILEUID:NONE NEWFILEUID:NONE

    20090421203842.790 my_userid_here * N ENG First Union 4307 QWIN 1800 1240364322793-0 First Union Sec (PCG) my_WachSec_acct_number Y N Y Y

    <<<<<<<< HTTP response headers: null: [HTTP/1.1 200 OK] Connection: [keep-alive] Set-Cookie: [st8id=1e1bcc1010b6de32734c584317443b31.00.73ea7738bea2dbfdd9a861052520a6b3; domain=.wachovia.com; path=/] Date: [Wed, 22 Apr 2009 01:38:45 GMT] Server: [MXYZPTLK Server 1.0] Content-length: [1835] Content-type: [application/x-ofx] Received message from https://pfmpw.wachovia.com/cgi-forte/fortecgi?servicename=ofxbrk&pagename=PFM

    my OFX data here

    <<<<<<<< elapsed time (balance recalc): 2 ms account modified: Ra-Wach SIMPLE IRA 7589 elapsed time (balance recalc): 3 ms account modified: Ra-Wach SIMPLE IRA 7589 ended task status: ; meter: 0.0

  10. 10 Posted by avp2 on 22 Apr, 2009 02:18 AM

    avp2's Avatar

    I have now tried the debugger on a few other account downloads that have always been working and feel a bit relieved to see that most have OFX sections ahead of the transaction data and that First Union is part of Wachovia.

  11. 11 Posted by Brian Adler on 22 Apr, 2009 06:24 AM

    Brian Adler's Avatar

    Randy, Are you certain you are matching your account type in MD with the correct account type at Wachovia Securities? What you are experiencing seems like an account type mismatch. What is the status of your situation?

  12. 12 Posted by randyfinger on 22 Apr, 2009 10:39 AM

    randyfinger's Avatar

    I have several accounts with Wachovia Bank (checking x2 and credit card). All of these download with no problems. With Wachovia Securities I have two accounts. One is a normal brokerage and the second is a Roth IRA. In MD the Roth IRA and the Brokerage are set up as investment accounts. Each currently contains a coash balance and stoack shares that I have been downloading from the Wachovia Securities website. Maybe I am trying to set it up wrong!? Here is what I am doing...

    1. Go to my Brokerage account and select Online > Setup Online Banking 2.Choose new connection.
    2. Select Wachovia Securities from the FI list. Cick OK
    3. Click Next. 5.Select my Brokerage Account. Click Next. 6.Enter my User ID and Password. Press enter.

    Now I am back to where I always am..... at a screen that says "Please choose the account that you wish to use." I have check boxes for online banking and bill payment. Under each check box is a drop down account list. I can not select the check boxes or the drop down list. I can not select next at the bottom of the window. All I can do is hit cancel and exit the online banking sign up.

    I am doing something wrong?

    On Tue, Apr 21, 2009 at 10:19 PM, Infinite Kind Support < [email blocked]> wrote:

  13. 13 Posted by avp2 on 22 Apr, 2009 02:32 PM

    avp2's Avatar

    Randyfinger: I have Wachovia Bank and Wachovia Securities accounts much the same as you, set them up for direct access as you have described and would get the same greyed out account selector when my access was not working.

    If you have been using the 635 build, try the 631, or earlier, to see if it works like it did for me.

  14. 14 Posted by randyfinger on 22 Apr, 2009 08:43 PM

    randyfinger's Avatar

    Sure enough, I changed from build 635 to 631 and it worked flawlessly. I guess this means there is a bug in the 635 build? Need to look into that.

    Thanks for the help Brian and avp2!

    Randy

  15. 15 Posted by avp2 on 24 Apr, 2009 01:22 AM

    avp2's Avatar

    Note that when I ran 631 on my db it apparently fixed something in the file/s so that Wachovia Securities access now works in 635. Build 635 must not be saving the OFX access parameters correctly.

    And, in case it makes a difference for the staff troubleshooters, my db is password protected.

  16. 16 Posted by Brian Adler on 24 Apr, 2009 03:11 AM

    Brian Adler's Avatar

    Tonight we released Build 637 which resolves the issue.

  17. Brian Adler closed this discussion on 24 Apr, 2009 03:11 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac