UBS Simplified Log-in Not Working

jwsizemore's Avatar


26 Oct, 2015 07:19 PM

On October 18, UBS changed their login to require you to use your web login credentials rather than the account and password credentials. I can log into their website using the web login credentials, but MD gives an error from the server that account/password are mismatched. This now happens with both the original credentials and the simplified credentials. UBS says they didn't change from Direct Connect to Web Connect, but just changed the credentials. Any idea how to restore downloading capability from UBS? Thanks.

  1. 1 Posted by aaustin on 27 Oct, 2015 03:19 PM

    aaustin's Avatar

    I am having the same issue.

  2. 2 Posted by David Hanley on 27 Oct, 2015 03:54 PM

    David Hanley's Avatar


    Could you both try recreating your UBS connections using the New Connection button and see if that fixes the issue that you're seeing? By selecting New Connection, Moneydance will download the updated certificates from UBS. You will need to disable your current connection to your bank and then recreate it using the New Connection button on the Online Banking Setup screen. To do so, you can follow these steps:

    1. Select your bank account in Moneydance

    2. Select the Online->Setup Online Banking button/menu

    3. Click the "Disable" button.  If you don't see a disable button, just close the setup window.

    4. Repeat the previous steps for any additional accounts at the same institution.
    5. Select the Online->Setup Online Banking button/menu (again)

    6. Click the "New Connection" button and select your bank and hit OK
    7. Continue with the setup process, entering your username/password

    Make sure you pick new connection, even though your bank is still one of the connection choices after you disable it. Choosing your bank from the list of available banks will force Moneydance to download the updated information, which should then allow you to connect.

    Please let me know if you continue to have connection problems after recreating your connection.

    Hope this helps!

    David Hanley
    Infinite Kind Support

  3. 3 Posted by aaustin on 27 Oct, 2015 05:56 PM

    aaustin's Avatar

    I followed those steps and it still does not work unfortunately.

  4. 4 Posted by Ian L on 28 Oct, 2015 12:10 PM

    Ian L's Avatar

    You may need to reset the passwords in your file using the Online->"Forget Online Passwords" menu option. This will remove all passwords saved in your file. Once you've done that, try connecting again, using your website username and password to log in.

    Infinite Kind Support

  5. 5 Posted by jwsizemore on 28 Oct, 2015 02:14 PM

    jwsizemore's Avatar

    I tried this and still the same result. However, I noticed an interesting thing. After disabling the accounts and selecting them as “new connections” I waited until the new connection had time to download. Once I entered the new credentials, it connected with UBS and gave me a choice of my 3 accounts. After selecting the proper account and adding login credentials for all 3 accounts, I tried downloading and still the same result. It seems like it must have connected earlier in order for UBS to supply my 3 account choices.

    Any ideas?

  6. 6 Posted by Ian L on 28 Oct, 2015 02:21 PM

    Ian L's Avatar

    If you try connecting in a completely new Moneydance file, are you able to connect? You can create a new file using the File->New menu option.

    Infinite Kind Support

  7. 7 Posted by jwsizemore on 28 Oct, 2015 02:27 PM

    jwsizemore's Avatar

    I created a new ‘test’ Moneydance file and added one UBS account. It worked and downloaded that account info.

    So, I have years of info in my existing Moneydance file. I’m hoping the next steps aren’t going to be painful!

    Thanks for your help.

  8. 8 Posted by jwsizemore on 28 Oct, 2015 02:29 PM

    jwsizemore's Avatar

    One more detail. It only downloaded info from 2014 to now. All the balances and positions are incorrect.

  9. 9 Posted by Ian L on 28 Oct, 2015 02:41 PM

    Ian L's Avatar

    OK, it looks like some old connection information might be hanging around in your file and causing this problem. Can you try completely resetting your connection in your original file to see if that fixes it? To do this, you'll need to force clear the current connection information for your bank in Moneydance. I'm sending a file called that will help do that. Before proceeding, please back up your Moneydance data set, just in case something goes wrong. You can create a backup using the File->"Export Backup" menu option.

    To use the file, first save it to your computer and then follow these steps:

    1. In Moneydance, click on the Extensions Menu and choose the Manage Extensions option.
    2. From the list of available extensions, choose the Python Interface extension, then click Install to download the extension and finish to complete the installation.
    3. Close the Manage Extensions window.
    4. Again, click the Extensions menu. This time, choose the Python Interface option.
    5. In the python window, click the read from file button and load the file from whereever you saved it. You will be asked to select which connection you want to clear. Choose your bank, and click OK. You'll get a confirmation message when the connection has been removed. Close the window when done.
    6. Set up the connection to your bank like normal. Since all of your settings have been cleared, you should get the most recent connection information for your bank.

    Hopefully, that will work. If it doesn't, let me know and we'll continue troubleshooting.

    Infinite Kind Support

  10. 10 Posted by conrodi on 29 Oct, 2015 11:25 PM

    conrodi's Avatar

    I'm not sure how this turned out for the other two, but for me the problem still remains unaltered. I followed all the steps earlier in this thread EXCEPT I did not "Forget Online Passwords" (I have many other accounts) and jumped straight to the Python script. In my last try I set up a new account, was able to see all my UBS account numbers, selected one, and exited the setup process normally. Still, when I seek to update the account information I get back the error 2000: "The information you entered does not match our records." This is really strange since it seems to work during the setup process just fine. What to do next?

  11. 11 Posted by jwsizemore on 30 Oct, 2015 01:36 AM

    jwsizemore's Avatar

    I went through the same steps as conrodi took with the same result. I downloaded fresh UBS information for every UBS account and I could match the different account numbers from UBS to my MD accounts. After successful connection, I’m not able to download the account updates due to the error 2000. Any ideas?

  12. 12 Posted by Ian L on 30 Oct, 2015 02:44 PM

    Ian L's Avatar

    I've attached a slightly modified version of the remove_one_service python script. can you try this one and see if it works for you?

    Infinite Kind Support

  13. 13 Posted by conrodi on 30 Oct, 2015 11:20 PM

    conrodi's Avatar

    Ian--SUCCESS!!! Not sure what the script did differently, but this time MD asked for my password twice for each account: once when setting it up and again the first time downloading transactions for that account. Previously it did NOT ask the second time. Thanks for your help!!! Many, many thanks.

  14. 14 Posted by jwsizemore on 31 Oct, 2015 01:24 AM

    jwsizemore's Avatar

    Ian - Success also! Many thanks. All my UBS accounts just completed downloading. Whatever you tweaked in the second file, did the trick. Thanks again.

  15. 15 Posted by aaustin on 02 Nov, 2015 03:58 AM

    aaustin's Avatar

    Unfortunately this is not working for me. I get the below error.

  16. 16 Posted by Ian L on 02 Nov, 2015 01:00 PM

    Ian L's Avatar

    aeweihl, it looks like you're running an older version of Moneydance. That file is for Moneydance 2015. For older versions, you'll need to reset all of your passwords using the Online->"Forget Online passwords" menu option. That should allow you to connect again.

    Infinite Kind Support

  17. System closed this discussion on 19 Mar, 2016 05:02 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac