Current Price is NOT updating portfolio

kking18474's Avatar

kking18474

27 Mar, 2021 04:57 PM

I have seen this issue occasionally, but never tried to sort it out, I guess I'm there now.
Why do some security prices seem to "stick" in the current price field and not allow newer prices from the quote loader to update the portfolio? It seems like DivReinvest transactions have preference?
Attaching screenshot.
In the Security Detail display my Price is NOT the latest, it's from a DivReinvest transaction that pre-dates the last quote loader import.
In the Security History window you can see the prices and the relevant dates of reference in the history list, however the "Current Price" field has an old entry in it and that seems to be the "Price" used by the Security Details display and also in the Portfolio Details page.

Am I doing something wrong to prevent my new data from populating the "Current Price" field? That seems to be the key data field that if updated would solve my issue.
thanks,
KK

  1. 1 Posted by kking18474 on 26 May, 2021 05:08 PM

    kking18474's Avatar

    I'm still seeing this, is there anyone who knows how this works, or how you can bump the update procedure and get current valuations?

  2. 2 Posted by dwg on 26 May, 2021 09:22 PM

    dwg's Avatar

    I'm a fellow user.

    It comes down to how you are getting new prices into Moneydance.

    The price history and the current price are two different things, the latest price entered is not by default taken to be the current price.

    Tools like the Quotes and Exchange rate extension and the Quote Loader Extension do set the latest price they import also as the current price. The Security Price Entry Extension has an option to set the price entered as the current price.

    If you use the New function in the screen you posted in #1 then changing the current price is a separate field you need to edit and change the value of.

  3. 3 Posted by kking18474 on 26 May, 2021 09:53 PM

    kking18474's Avatar

    I'm using MoneyDance Quote Loader 3027 extension right now.
    The sequence would go something like this: I start MD and the Quote Loader goes out and gets pricing updates automatically. Then I either import some other transactions via OFX or manual entry of transactions. These subsequent entries are therefore OLDER than the new price imports from the loader. You will see these as the 3 or more digit pricing entries in the history. Since these were AFTER the loader prices, they seem to hijack the Current Price value.
    If I manually run the Quote Loader extension again and save the prices it updates Current pricing. Is that the quickest/best workaround for this you think?
    KK

  4. 4 Posted by dwg on 26 May, 2021 10:14 PM

    dwg's Avatar

    I have build 3069 installed on this machine, not that I expect the version to make difference.

    In one investment account in a test data set I manually added a buy transaction for a date with no price history - it was a weekend. Transaction added, record in price history added but the current price did not change, So I'm not sure why you are seeing the current price set to the price you are.

  5. 5 Posted by Mike Bray on 27 May, 2021 07:37 AM

    Mike Bray 's Avatar

    Please update Quote Loader to the latest build available through Manage
    Extensions, there was a known issue with this which was corrected in
    build 3034.
    Thanks
    Mike

  6. 6 Posted by kking18474 on 27 May, 2021 02:49 PM

    kking18474's Avatar

    Thank you Mike, just updated to Loader 3036, will give it a test.
    KK

  7. 7 Posted by tahartman on 30 May, 2021 06:49 PM

    tahartman's Avatar

    I am having the same problem. I added a new investment account after the death of my mom. It has some of the same mutual funds as an existing investment account. I then removed and re-installed Quote Loader, running version 3036. Quote Loader updates my existing portfolio price, but not the price for the same security in the new portfolio. Any help for this issue?

  8. 8 Posted by Stuart Beesley ... on 30 May, 2021 06:58 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    You should set up and use one master security in all investment accounts. It sounds like you have set up the same security more than once. E.g. Apple and Apple. If so, to,fix, rename one of them to something + “delete me” then update the investment to use the master security. Then delete the duplicate.

  9. 9 Posted by tahartman on 30 May, 2021 07:05 PM

    tahartman's Avatar

    Moneydance won’t let me build the new portfolio unless I add the security again. It doesn’t show securities from my other investment accounts as a drop down option.

  10. 10 Posted by tahartman on 30 May, 2021 09:25 PM

    tahartman's Avatar

    I found the solution - Search for "Same Bond Fund held in Two Different Accounts - Only One Price Updated by Quote Loader" dated Jun 10, 2020. The fourth post by -Kevin N. on Jun 11,2020 @ 10.15 AM explains clearly how to make Moneydance and Quote Loader update the price in both accounts. This worked perfectly for me and solved the problem. Here is a link to that discussion https://infinitekind.tenderapp.com/discussions/problems/61403-same-bond-fund-held-in-two-different-accounts-only-one-price-updated-by-quote-loader

  11. 11 Posted by kking18474 on 04 Jun, 2021 02:54 PM

    kking18474's Avatar

    Mike Bray, thank you. Confirmed that loader 3036 is working great for me. Past dated transactions are now NOT taking over Current Price from more recent Price entries.

    I'm closing this thread, but would add one more thing for tahartman. Very glad you found this out early in your use. This way of managing just one security rather than multiple copies will benefit you in the future as Stuart B has indicated. I had to clean this up in my own accounts recently and it gets harder to clean up the more you create copies. My $.02.

    KK

  12. kking18474 closed this discussion on 04 Jun, 2021 02:54 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac