Mismatched security download...

feffer777's Avatar

feffer777

01 Aug, 2021 10:21 PM

Only happening for Invesco QQQ ETF owned through Vanguard. Recently, downloads from web-connect created a separate duplicate account for this security. I followed the instructions in "fixing-mismatched-securities-from-downloads." Removed the duplicate security, reset sync, but when I tried to re-download from Vanguard, my choices were either a different VG security (not QQQ) or "none-of-the-above." The correct "invesco QQQ" security choice was not there! Choosing "none-of-the-above" put me in the same spot of having two duplicate accounts for the same security!

  1. 1 Posted by Stuart Beesley ... on 02 Aug, 2021 03:08 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    I just took a peek at the internals of this.. As far as I can roughly tell the process is as follows:

    This is all linked to the 'CUSIP' hidden data that MD stores against the Security Master records (NOTE: This will therefore be shared across all Investment accounts).

    Within the OFX datafile you should see this data for the Security in question:
    UNIQUEID
    UNIQUEIDTYPE
    SECNAME
    TICKER

    The popup match rules are as follows:

    • Search all known Security Master records, checking each one for the hidden CUSIP data using 'UNIQUEIDTYPE' as the key. Return the UNIQUEID found.

    • If a UNIQUEID was found for UNIQUEIDTYPE and only if it MATCHES the UNIQUEID in the ofx download, then use this Security found and continue - No popup screen needed..

    • If there was no data found for UNIQUEIDTYPE against a Security, then add it as a candidate for user selection.

    • HOWEVER, if the search found a Security using UNIQUEIDTYPE, but the UNIQUEID was different to the one in the OFX file, then it's skipped and ignored. Hence, it will be missing from the popup list.

    • Then it sorts the candidates.

    • User selects a candidates

    • If user cancels selection, return None

    • If selected security is None (of the above)... then it creates a new Security and sets the hidden CUSIP data against that new security.

    Function returns the user-selected or new Security.

    Additionally, TICKER gets put into the Security's Ticker field if it is empty.

    Thus, if the popup match screen is not listing some securities, then those Securities must already have the hidden CUSIP using key UNIQUEIDTYPE set to a different UNIQUEID.

    The good news is that the Toolbox extension lets you see/edit the hidden CUSIPs. Assuming you are on MD2021.1(3069), install Toolbox. Advanced Mode. Online Banking (OFX) Tools Menu. Reset/Fix/Edit/Add CUSIP Banking Link

    I would suggest you look to see what data is set and why it's different to your OFX file. Is it possible that two different Financial Institutions are using different IDs for the same Security?

    With more info, I could probably help further.....

    (not support, just a fellow user)

  2. 2 Posted by Stuart Beesley ... on 02 Aug, 2021 03:44 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    PS. I forgot to say. To see the OFX data if using direct connection:

    Help/Console. Keep console open (do not close it)

    Now do your download

    Go back to console and you will see the ofx data.

  3. 3 Posted by Stuart Beesley ... on 02 Aug, 2021 10:27 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Further info. I suspect what you are looking for in your OFX data is something like:

    <SECID>
    <UNIQUEID>78468R622
    <UNIQUEIDTYPE>CUSIP
    </SECID>
    

    Hence, if you use toolbox to look at the CUSIPs, you want to see if the Security NOT appearing in the match list already has a different CUSIP number set.

  4. 4 Posted by Stuart Beesley ... on 03 Aug, 2021 09:12 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    If it helps, I have just added a simple option to list all existing stored CUSIPs to the PREVIEW version of Toolbox. In Online Banking (OFX) Tools menu.

    https://github.com/yogi1967/MoneydancePythonScripts/raw/master/tool...
    (Unzip. Drag toolbox.mxt onto the MD left sidebar to install).

  5. 5 Posted by feffer777 on 03 Aug, 2021 03:46 PM

    feffer777's Avatar

    I'll have time to look into this later today. QQQ was never a problem in VG downloads for years. Some time ago, Invesco changed the name to QQQQ, and then later back...noticed problems some time after this. I used to download the OFX file and import, but as MD was updated and allowed direct online import, I used that feature.

    I do have MD2021.1(3069), so I'll try Toolbox later today.

  6. 6 Posted by feffer777 on 03 Aug, 2021 06:35 PM

    feffer777's Avatar

    Stuart, this is a very powerful extension, congrats. As a Linux user, I'm familiar with getting in deeply and making things worse than they had to be, so please help me understand a few things. In MD > Security History > Edit > for "INVESCO QQQ ETF" the "security ID" = ^46090E103 while Toolbox shows CUSIP ID: 73935A104. Is this where the mismatch is coming from? If so, which do I change?

    I'm reluctant to follow your comment #2 because although I get my FI data via direct download thru MD, I've already downloaded up-to-date info and might only get mismatched QQQ again. Or does everything download but just not get entered into MD if it's duplicate info? In which case it would be meaningful to my situation.

  7. 7 Posted by Stuart Beesley ... on 03 Aug, 2021 06:48 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    A quick Google reports:

    Ticker Symbol: QQQ
    CUSIP: 46090E103
    Previous CUSIP: 73935A104
    

    So. BINGO. YES this is the issue.

    You need to use the advanced mode, edit CUSIP feature to update the security to read
    46090E103

    Please download/use the latest toolbox preview, I updated it only 30 minutes ago.

    (Not support, just a fellow user)

  8. 8 Posted by feffer777 on 03 Aug, 2021 07:15 PM

    feffer777's Avatar

    Got newest toolbox preview & installed. MD complains it is not verified. Assume it's fine and a future update from MD will installed the verified version. Right?

    When doing the fix, got this msg: ERROR: You have old format Security record(s). Consider running 'MENU: Currency & Security tools>Diag/Fix Currencies/Securities' option first. ...not sure what I'm getting into here?

  9. 9 Posted by Stuart Beesley ... on 03 Aug, 2021 07:38 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Ok. Do this. All will be well! Promise!

    Manage extensions. Installed. Toolbox. Remove (the preview).
    Click over to the Available extensions tab. Select Toolbox. Install (the current signed version)

    Now….:
    Tools / securities
    Select and edit the QQQ security
    Change the ‘current price’ to something else. Enter. Save. Exit the window.
    Repeat. Change the current price back to what it was. Enter. Save. Exit the window.
    (I won’t bore you with why, but this fixes a hidden data issue you already have internally, nothing to do with toolbox).

    Now run toolbox (this should be the original version you ran first time now)
    Select the edit CUSIP option.

    Edit the cusip accordingly.

    All will be well.

  10. 10 Posted by feffer777 on 03 Aug, 2021 09:47 PM

    feffer777's Avatar

    OK, followed your info...seemed to work well. However, had a MD freeze at the end...possibly too many balls in the air! Restarted from latest BU and redid the download. That also seemed to work and now there is one QQQ account with the proper shares, price etc. So that problem seems solved. Kudos to your extension and help!

    However, the process uncovered another mismatch also at VG. This does not involve the CUSIP which are correct for both of the MMarket funds involved. VG did a recent switch from my old MM (VMXX) to a new one called VMRXX (the R for "reserve"). Now both appear in this account. Stuart I realize this is sort of a new question, but I hope you can continue with me on this. I need to move VMMXX to VMRXX. Should I simply "sell" the one and "buy" the other or might this tangle things up?

  11. 11 Posted by Stuart Beesley ... on 03 Aug, 2021 09:55 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Toolbox 🧰 +1 😃 (CUSIP fix)

  12. 12 Posted by Stuart Beesley ... on 03 Aug, 2021 09:56 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    It depends whether these are the same security or whether they are two different securities?

    If the same, then the toolbox preview can merge securities for you. If the latter, then it sounds like you should do a sell/buy?

  13. 13 Posted by feffer777 on 03 Aug, 2021 11:41 PM

    feffer777's Avatar

    VG created a new MM security VMMRXX for their purposes and moved my funds from previously long held VMMXX to the new fund. So VMMXX no longer shows up as a security held by me in this account. However, I think it still does exist as a fund but it's used for other purposes. I read the info when they made the change, but in one ear out the other...just another thing FIs do probably to save a dime on their side. I'll probably have to check with VG to see which it is. In any case, you've given me the path. Thx! Everything else looks good...and I've learned how to deal with this issue.

  14. System closed this discussion on 02 Nov, 2021 11:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac