Securities

karigg's Avatar

karigg

21 Oct, 2021 06:06 PM

I have input a number of duplcate securities and when I do a manual price entry I have to also input the duplicate prices.

Is there any way I can delete these security entries,

Showing page 3 out of 3. View the first page

  1. 61 Posted by karigg on 09 Nov, 2021 09:11 AM

    karigg's Avatar

    Stuart

     

    I have left this a few days and upon opening today the duplicates have disappear from the Edit Securities screen but when I run the merge securities in Toolbox I get the attached pop up indicating all is not right.

     

    How do I correct this.

     

    Kevin

  2. 62 Posted by Stuart Beesley ... on 09 Nov, 2021 09:26 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    It’s saying you have no duplicate securities that it can detect and you are also saying that you have no duplicates in tools/securities. Thus, why do you think you have a problem? Have you checked your portfolios; are they correct?

  3. 63 Posted by karigg on 09 Nov, 2021 03:23 PM

    karigg's Avatar

    Stuart

     

    I have just reopened MD and all the duplicates securities reappear. Furthermore the Security ID despite having amend this reappears and shows as the name of the security.

     

    What more can I do to get this sorted

     

    Kevin

  4. 64 Posted by Stuart Beesley ... on 09 Nov, 2021 04:12 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    It sounds to me as if the MD Sync (change management) system is reapplying old data at restart, hence your erratic results... Therefore, if this was me, I would purge the change files (.txn and .mdtxn).... They really are not needed

    Are you using Sync to synchronise between datasets? If you are using Sync, then please make sure each sync copy has opened its dataset and restarted MD (and wait 2 mins) at least twice, before doing this....

    An easy method to purge is this....
    BACKUP
    Toolbox.. Hacker mode.... Option: Hack: Shrink Dataset... Acknowledge. If the option appears, select PURGE-OUT, then type 1 at the days to keep box.. Let it do it's thing...

    Then restart MD, wait 2 mins, restart MD......

    At this point what state are the Securities in?

    If needed, then rename the HSBC security and then Toolbox Merge again... Restart MD twice.... Where are we at?

  5. 65 Posted by karigg on 09 Nov, 2021 07:38 PM

    karigg's Avatar

    Stuart

     

    I have done this but it does not sort out the issue.

     

    When I reopen after waiting at least 2 mins and then go to securities in the edit box comes up a number of duplicate securities. I can remove these when I press the – button at the bottom left of the screen but this does not take effect because when I close down and reopen the duplicates remain.

     

    Kevin

  6. 66 Posted by Stuart Beesley ... on 10 Nov, 2021 09:48 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    When you ran the Shrink Dataset option, did it do anything?
    - Did you get the 'PURGE-OUT' option?
    - How many files did it say it was removing?

    OK, please launch File Explorer and navigate to both these folders.... Can you take a screenshot of both folders....

    C:\Users\Kevin Rigg\.moneydance\Documents\Kevin Personal Finances.moneydance\safe\tiksync\in

    C:\Users\Kevin Rigg\.moneydance\Documents\Kevin Personal Finances.moneydance\safe\tiksync\out

    Then restart MD. Wait 2 mins... Take a screen shot of Tools>Securities (call this before deletion) .... Then use the - button. Does it give a warning, or just allow you to delete it? Make the deletion... Now screenshot again with it gone (call it after deletion)...

    Then get a copy of console (call it after deletion, before restart)..

    Then restart, wait 2 mins.... Go back to Tools/Securities... Screen shot that screen again (call it after restart)...

    Take another copy of console (call it after restart).

    post all the above

  7. 67 Posted by karigg on 10 Nov, 2021 02:36 PM

    karigg's Avatar

    Stuart

     

    Answers to your question:-

    Shrink database. Did it do anything. Yes

    Purge Option Yes

    No of files deleted. I believe around 90 but when I run it again later their were no files to purge.

    There is no file tiksync\in

    Tools>securities. Warning Yes Screen shot attached.

    I have shown two screen shot for two securities

     

    After a wit of a couple of hours I have just reopened MD and find the amendments have not been actioned. I attach two further screen shots both label Final re3start and Final console

     

    Hope this is useful

     

    Kevin

  8. 68 Posted by Stuart Beesley ... on 10 Nov, 2021 03:59 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Ok. Something very odd is occurring. I cannot help you further without seeing your actual dataset. So you have three choices.

    1/ just ignore the duplicates

    2/ if you are willing to share your dataset with me to take a look at, then email me and I will send you instructions.

    3/ ask for support to dial in and look at your dataset

    (not support, just a fellow user)

  9. 69 Posted by karigg on 10 Nov, 2021 04:10 PM

    karigg's Avatar

    Stuart

     

    I shall email you.

     

    Kevin

  10. 70 Posted by Stuart Beesley ... on 10 Nov, 2021 07:53 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    To anyone watching this thread... The issue is fixed.. The 'odd' behaviour was caused by two very old .txn files that were being reported as corrupt, but in actual fact were restoring certain Security records, hence when you restarted, they reappeared. The Dataset has now been fixed...

    I guess I'll be building another Toolbox fix to look for these and take appropriate action...

  11. 71 Posted by Stuart Beesley ... on 10 Nov, 2021 10:08 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    UPDATE. I’ve spoken to the developer (Sean) and he’s applying a fix so that old (damaged) .txn files that throw the bad padding exception will be added to the processed log so that they do not reprocess and cause this type of issue. This also means they will also get auto archived.

  12. System closed this discussion on 09 Feb, 2022 10:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac