Moneydance 2022 syncing between Dropbox and MD iOS app

layman.joe's Avatar

layman.joe

03 Dec, 2021 04:11 AM

I'm having trouble syncing my transactions between Dropbox on my MacBook and the MD iOS app. There was a point when this worked perfectly, but between setting up Moneydance+, trying/failing/trying-again to set up investment accounts, and a plethora of other things - I've clearly messed something up and I'm not sure what did it.

I'll admit I had trouble understanding which method of Dropbox syncing to use - and how to use it. I felt like there was a key piece of information missing in those instructions that prevented me from connecting the dots. If another method is simpler (iCloud Drive), I'm all for it if someone could please offer guidance.

This could be unrelated, but I'll still share just in case. When returning to my laptop sometimes, I receive multiple pop-up error messages relating to Moneydance+. I doubt this has anything to do with my iOS app syncing, so I can save that for another thread if need be.

Thank you

  1. 1 Posted by Stuart Beesley ... on 03 Dec, 2021 05:32 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    You need to rebuild sync. Is your primary dataset in good condition and complete? There are two things to try.

    1. Install and run toolbox extension. Close all other non primary datasets. Then Hacker mode. Hacker menu. Force reset/push is dataset to sync.

    Wait for a bit…

    Then wait for sync to sync.

    Then fire up the other dataset. Wait for sync…. Restart md.

    Best to watch help/console and then I can see the syncs occurring.

    If that’s no good , shout for opt 2

  2. 2 Posted by layman.joe on 03 Dec, 2021 02:11 PM

    layman.joe's Avatar

    Challenging my non-technical side here. Assuming I've followed the instructions correctly, I'm at the "wait for a bit" step and haven't seen any script window movement/changes (10+ min).

    Looking at the instructions ahead, what is meant by "fire up the other dataset"? Your instructions indicate to close all other datasets and my primary dataset was the only one open so I didn't close it. Does this force reset/push process create a new dataset that I'll need to open?

  3. 3 Posted by layman.joe on 03 Dec, 2021 11:30 PM

    layman.joe's Avatar

    I'm not exactly sure what to do next. I'm at this step:

    "Then fire up the other dataset. Wait for sync…. Restart md."

    Thank you

  4. 4 Posted by Stuart Beesley ... on 04 Dec, 2021 04:37 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    OK, it worked. It took 1 minute.

    dropboxsync: saving state to sync folder: mdata-v1
    mobile sync completed in 79 ms
    DATA: finished writing in 0.316 seconds
    DATA: renaming/pushing from temp file took an additional 0.009 seconds
    toolbox.py(Extension):2021/12/03-07:57:10: @@ Called .getSyncer().forceResyncFromLocal() to Force Push (Re)Sync to remotes...
    giving the sync thread a kick
    detected system appearance: org.violetlib.vappearances.VAppearanceImpl@2b8bd14b
    DATA: finished writing in 0.352 seconds
    DATA: renaming/pushing from temp file took an additional 0.001 seconds
    uploading new trunk file v3/trunk-202112030757.mdtxn to syncFolder
    

    Fire up the other dataset means....... Go to your other computer / iOS app and start MD and hopefully you will see Sync catchup...

    ?

    Then try a txn on each and test it gets both ways...

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Online_error_-_401k_Belk.png 333 KB
  • Online_error.png 323 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac