Mobile app Memo Field not synching to Desktop

rayplayer's Avatar

rayplayer

10 Dec, 2021 08:30 PM

I am using the Moneydance app on my iPhone and notice that any entries into the memo field are not being synchronised to my Windows 10 desktop - they appear to get lost during the sync.

This only happens for entries logged using the iPhone app. Anyone else having this problem and know how to fix it?

  1. 1 Posted by rayplayer on 20 Dec, 2021 04:57 PM

    rayplayer's Avatar

    I am now noticing that when I enter details into the memo field on the desktop, to an entry originally made on the mobile app - the text simply disappears? When the same text is added to the memo field of the same enties on the mobile app the text synchs ok.

    Its been 10 days since raising an issue and still no response from the infinite kind?

  2. 2 Posted by jeff_l on 20 Dec, 2021 09:24 PM

    jeff_l's Avatar

    You don’t say what you have tried already, or what desktop vers of MD you are using.

    So forgive me if you’ve done this already. Very occasionally I’ve found that my iPhone does not sync everything perfectly. I’ve found that usually dismissing the iPhone app & restating it returns normal service.

    I usually shut down the desktop app frequently during the day, but sometimes months go by & the iPhone app remains active.

    The other more drastic cure would be to delete the contents of sync folder in Dropbox & let your Primary Win 10 PC rebuild it.

    Hope this helps

    Fellow user

  3. 3 Posted by rayplayer on 28 Dec, 2021 10:14 PM

    rayplayer's Avatar

    Hi Jeff, thanks for your help - I have tried those things including the more drastic option of stopping synch and deleting the Dropbox synch folder. I also restarted the synch then deleted & reinstalled the app on iPhone and iPad but it is still not right.

    To test I created a split entry with memo data on my iPhone 11. This synched correctly. I then adjusted the memo field on the iPhone and that synched to the desktop correctly. I then deleted the entry on the desktop and it disappeared but then it reappeared moments later? I deleted the entry on the desktop several times and each time it reappeared. For some reason It only disappeared if I deleted the entry on the iPhone?

    I am running MD Version 2022.2 (4060).

  4. 4 Posted by rayplayer on 07 Jan, 2022 12:58 PM

    rayplayer's Avatar

    Does anyone know how to get Infinite Kind to respond to these issues - its been nearly a month since I raised this?

  5. Support Staff 5 Posted by Maddy on 07 Jan, 2022 01:14 PM

    Maddy's Avatar

    Hi Ray,

    We are sorry to hear about the problem you have encountered. Please accept our sincere apologies for the lack of response I’m afraid that your request for assistance was missed by the support team, and it’s only now we’ve been able to work through the backlog of older discussions. I must apologise again for the poor level of service and lack of support you have received. I’d like to provide assistance if you’re still in a position to work through these issues.

    Firstly, may I ask which sync method have you selected from File->Syncing?

    • With "Dropbox Connection" Moneydance uses the Dropbox API to talk to the Dropbox service directly. So, you don't need to have Dropbox actually installed on your computer, but you do need to be online when Moneydance is running in order for changes to be synced.

    • With "Dropbox Folder" Moneydance will just read and write files to your Dropbox folder on your computer, which means that you need to have Dropbox installed and running, but you don't need to be online in order for Moneydance to read and write the changes. I would recommend using this sync method especially since you are syncing with the mobile app.

    Also, can you ensure your data file is stored in the default location?

    Finally, can you verify that you are running the these version on your devices?
    Moneydance 2022.3 (4063) on your computer and
    Version 2.23 on you iPhone.

    I hope this information is helpful. Please let us know if you have further questions or need more assistance.

    --
    Maddy, Infinite Kind Support

  6. 6 Posted by Stuart Beesley ... on 07 Jan, 2022 02:48 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Try this.
    Install/load/run Toolbox extension.
    Turn Hacker mode and Advanced mode ON
    Hacker menu
    Force a refresh / Push of your local dataset to Sync.
    Wait a bit
    restart MD
    on iPhone reconnect to the Sync dataset.. Ensure there is only one offered and the correct one,

  7. 7 Posted by rayplayer on 07 Jan, 2022 08:44 PM

    rayplayer's Avatar

    Hi Maddy, I am using Dropbox Folder for synching and the data file is in the default location at C:\Users\raypl\.moneydance\Documents.

    Regarding the versions I am running Version 2022.2 (4060) on my desktop which is the latest release – I am happy to try the beta version (2022.3 (4063)) if that is your recommendation, but if it hasn’t been fully tested won’t that simply confuse the situation and risk introducing other issues? I am running Version 2.23 on my iPhone.

    Regards

    Ray

    ========================================

    Hi Stuart, thanks for your help - unfortunately I didn't have much luck. I opened the toobox, and selected Hacker Mode / Advanced Mode as you suggested but I couldn’t find an option in any of the menu's to ‘Force a refresh / Push of your local dataset to Sync’?

    Regard’s

    Ray

  8. 8 Posted by Stuart Beesley ... on 07 Jan, 2022 09:54 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Can you send me a screenshot of the hacker menu that appears for you?

  9. 9 Posted by rayplayer on 07 Jan, 2022 11:07 PM

    rayplayer's Avatar

    Hi Stuart, whilst sorting a screenshot I found the option ‘Force a refresh / Push of your local dataset to Sync’ and ran it as per your instructions until it finished.

    Prior to doing that I deleted the mobile app. Once done I restarted MD and reinstalled the mobile app.

    I then added an entry on the mobile app, and added Testing to the memo field – it immediately synched to the desktop. Excellent I thought, so I changed the memo field to Testing Testing – this time the desktop did not synch, but I noticed the mobile app changed to Testing? I added Testing Testing again and this time the desktop memo field changed to Testing Testing.

    Since doing that initial test I have repeated it a few times only now it seems to be working as it should - perhaps that first test was a blip, an error on my part, or perhaps its now working as it should, I'm not sure. I will leave this discussion open while I monitor for a few days - hopefully its fixed. Fingers crossed, and many thanks for your help..

    Regards

    Ray

  10. 10 Posted by Stuart Beesley ... on 08 Jan, 2022 08:09 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    I suspect it’s timing and your tests were quicker than the sync.

    Toolbox 🧰 +1 😃

  11. System closed this discussion on 09 Apr, 2022 08:10 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 May, 2022 07:41 PM
23 May, 2022 07:40 PM
23 May, 2022 07:20 PM
23 May, 2022 07:18 PM
23 May, 2022 07:13 PM