No Devices To Synch

shawn geraghty's Avatar

shawn geraghty

05 May, 2010 10:26 PM

Hello:

I am trying to get MD on my Mac to recognize my iPhone via the Network Sync Extension. I have installed the MD app twice on my iPhone. I have also removed and then readded the Network Sync extension.

I have tried using two different wi-fi networks to be sure this wasn't a network issue.

However, when I try to use Network Sync to connect MD on the Mac to the MD iPhone app, no devices appear. Any suggestions?

Thanks in advance.

sg

  1. 1 Posted by Ben Spencer on 08 May, 2010 07:32 PM

    Ben Spencer's Avatar

    Just to be certain that it is not the wifi network that is the casue of the problem would you be willing to setup a computer-to-computer wifi connection between your iphone and your mac. Here is a link ot an article on how to do this on OSX:

    http://docs.info.apple.com/article.html?path=Mac/10.6/en/8339.html

    Ben Spencer

  2. 2 Posted by shawn geraghty on 10 May, 2010 12:45 PM

    shawn geraghty's Avatar

    Ben:

    Still doesn't show up using the computer-to-computer network.

    So, I still get the key screen on my iPhone, and MD doesn't see any devices
    to add.

    I checked the console, and there isn't any thing in there either.

    I checked and I'm running version 6 of the extension.

    On a wi-fi network, I can ping my iPhone. Do you know of a way to initiate
    a ping from an iPhone?

    I'm starting to think if there is some setting on the iPhone that is
    preventing this connection. Any thing come to mind?

    sg

  3. 3 Posted by don on 10 May, 2010 05:21 PM

    don's Avatar

    Ben,

    Me too:

    My iPhone doesn't show up in Network Sync using a computer-to-computer network on my Macbook Pro.

    I'm running Network Sync version 6 on Moneydance 2010r3 748.

    I can ping my iPhone and the Macbook from each other (btw: I use iStat on the iPhone to ping).

    Waited for 20 minutes: "No devices running Moneydance were found".

    My computer-to-computer network name is one word, no spaces. I even tried setting the iPhone to airplane mode and then connecting to the computer-to-computer network. Still no connection.

    Please let me know when you resolve this issue.

    Thanks,
    Don

  4. 4 Posted by Ben Spencer on 12 May, 2010 03:28 PM

    Ben Spencer's Avatar

    Can you tell me if you switched data files while moneydance was running, or are you only using one data file (the one that was opened automatically at launch)?

    Ben

  5. 5 Posted by shawn geraghty on 12 May, 2010 09:01 PM

    shawn geraghty's Avatar

    Hey Ben:

    I only use the file that is opened when launching MD.

    Thanks for looking into this.

    sg

  6. 6 Posted by Ben Spencer on 13 May, 2010 03:41 PM

    Ben Spencer's Avatar

    Can you tell me if your iphones name has a space in it. If it does you can change the name of the device in itunes from the side bar such that the device name does not contain spaces..

    Ben

  7. 7 Posted by don on 18 May, 2010 03:04 AM

    don's Avatar

    Don here:

    I changed the name so that it doesn't have spaces. The name is 'Don_iPhone". It is specified on the Moneydance iPhone's "To sync..." screen as "don-iphone".

    I still get the same error message from Moneydance: "No devices running Moneydance were found". Even after waiting for a while.

  8. 8 Posted by shawn geraghty on 18 May, 2010 02:39 PM

    shawn geraghty's Avatar

    So Don, your iPhone actually shows up in the list of devices, but you get
    the "No devices .." error message when you click on synch?

    Ben, Tom: MD doesn't even show my iPhone in the list of devices.

    Thought that my help further isolate the issue.

    Thanks for all the help.

    sg

  9. 9 Posted by don on 20 May, 2010 11:39 PM

    don's Avatar

    Shawn:

    No, my iPhone doesn't show up in the list of devices; I get the "No devices..." error message when I click on the Network Sych Settings dialog's "Add Devices" button.

    BTW: I just updated to the latest version of MD: same.

    Don

  10. 10 Posted by Joe LG on 26 May, 2010 03:12 AM

    Joe LG's Avatar

    Ben, I have the same issue. I have tried all of the various combinations of networks suggested and naming conventions for the iphone and have reloaded the app and the extension (currently build 7). I have also tried with Moneydance 2008r4(640) on a MAC OS 10.5.8 and Moneydance 2010r3(750) on a WIN XP SP3 notebook.

    There is no crash and no device has ever shown as being available.

    Joe

  11. 11 Posted by Ben Spencer on 26 May, 2010 07:26 PM

    Ben Spencer's Avatar

    Are you using an existing Moneydance data file? I have noticed that if you create a new data file and try to sync to an iPhone before the data file has been saved on the desktop at least once, the extension will tell you that it cannot find any devices to sync to.

    Ben

  12. 12 Posted by Joe LG on 27 May, 2010 03:47 AM

    Joe LG's Avatar

    Ben, I am using am using an existing file. I just updated Net Synch to build 9 and am now running MD 2008 with OS 10.6.3 and still no devices show.

    Joe

  13. 13 Posted by don on 27 May, 2010 04:20 AM

    don's Avatar

    I'm using an existing file as well. No devices show.

    Don

  14. 14 Posted by shawn geraghty on 27 May, 2010 02:23 PM

    shawn geraghty's Avatar

    Ben:

    First I downloaded the Network Sync, version 9. Also found the MD updater
    extension and installed that. Running MD 2010r3 build 750.

    I created a new MD file, called TestIphoneConnectivity.md, and did not save
    it. Tried to configure net sync and no devices showed. Then I saved the
    file to my Documents directory, but still, no devices show in the configure
    net sync screen.

    I am able to ping my iPhone from my MacBook Pro, running 10.6.3(10D7573).
    I downloaded iStat for my iPhone. SO ... here may be the issue. I can't
    ping my MacBook Pro from my iPhone using iStat. Need to think about this
    for a bit ....

    sg

  15. 15 Posted by Joe LG on 27 May, 2010 08:25 PM

    Joe LG's Avatar

    Ben, I believe I have solved my problem, but I am not sure of the implications.

    My solution was to change the firewall settings as follows:
    System Preferences>Security>Firewall>Advanced
    Uncheck "Block all incoming connections"
    Add Moneydance Desktop application and "allow incoming connections"
    This allowed the iPhone to be recognized when running the Network Synch extension and installation proceeded with no problem. Sometimes it takes a few minutes for synch to be available when executing the iPhone App, but I have had success making changes and synching.

    The item unchecked in the firewall setting's description was "Blocks all incoming connections except those required for basic Internet services, such as DHCP, Bonjour, & IPSec.

    I am relatively new to the Mac environment and am not sure if there are security implications to what I have done. I am also surprised that my solution was not addressed in the programming or user instructions of the Moneydance applications.
    Any insight you have would be appreciated. Thanks for all of your help.

  16. 16 Posted by don on 28 May, 2010 07:14 PM

    don's Avatar

    My firewall has been turned off. I also just updated MD. I still get "no devices shown" error.

  17. 17 Posted by shawn geraghty on 01 Jun, 2010 12:00 PM

    shawn geraghty's Avatar

    Same here. I did not reboot, but I will give that a try as well.

    sg

  18. 18 Posted by Ben Spencer on 02 Jun, 2010 06:22 PM

    Ben Spencer's Avatar

    Just to make sure we haven't missed something simple can those of you why are not able to add the device confirm that you done everything listed in the following article.

    http://help.infinitekind.com/faqs/iphone-app/the-network-sync-exten...

    Ben

  19. 19 Posted by shawn geraghty on 04 Jun, 2010 04:45 PM

    shawn geraghty's Avatar

    Make sure that you have saved your data file in the desktop app at least
    once. Yes

    Make sure the iPhone is connected to the local wifi network. Yes

    Make sure it is the same local network as the PC/mac. Yes

    Make sure the Moneydance app is running on the iPhone when you click the
    "Add device" button in the network sync extension on the desktop app. Yes

    Make sure you are running the latest version of the iPhone app. Yes, just
    did an iTunes update, deleted app from iPhone, reinstalled version 1.2, just
    to be sure.

    Make sure you are running the latest version of the network sync extension
    of the desktop. You can determine the build of an extension by selecting
    Extensions->Get info for. Yes, version 9, uninstalled, re-installed.

    If your iPhone has a name that includes spaces change it to a name without
    spaces. This can be done from the sidebar in itunes. Yes, ShawnsiPhone, as
    shown in iTunes and on my iPhone via General -> About.

    If you have a personal firewall set up on your desktop computer you may need
    to allow incoming connections to the Moneydance application. The instruction
    for doing this will vary depending on the Operating system and firewall
    being used. On mac:

    System Preferences>Security>Firewall>Advanced
    Uncheck "Block all incoming connections"
    Add Moneydance Desktop application and "allow incoming connections" Yes,
    actually turned off firewall altogether.

    Failing that check the ipaddress and netmask of both you ipod touch and you
    pc. To get this info from you iPhone install a free app called "ipconfig".
    To get this info from your PC run a command prompt and enter "ipconfig /all"
    without the quotes on a mac the command is "ifconfig". In most networks the
    netmask will be 255.255.255.0. This need to be the same on you PC and your
    iphone. In most networks the ipaddress needs to have the first 3 segments be
    the same with only the last segment being different.

    Things got interesting here. Using ifconfig, here is the info

    Macbook Pro, runnning 10.6
    IP Address = 10.14.54.141
    Netmask = 255.255.255.0

    I downloaded the ipconfig app for iPhone and installed it. At first, it was
    reporting my IP as

    iPhone:
    IP Address = 10.69.xx.xx (don't remember exactly, but not 10.14.54.xxx
    network)

    I also have iStats installed on my iPhone to debug this, and it showed my
    iPhone having two IPs: "Cell" being the 10.69.xxx.xxx IP address, and
    "WiFi" showing "10.14.54.109".

    I putz around in the the Settings, and found that if I disable 3G, then both
    apps, ipconfig and iStats showed my IP address as 10.14.54.109, with a
    netmask (from ipconfig) as 255.255.255.0

    But unfortunately, my iPhone still doesn't show up in the devices to add.
    UNBELIEVABLE!

    I know the devices see each other, because I can use iStats to ping my
    Macbook Pro, and I can ping my iPhone from my Macbook Pro, which didn't work
    before when 3G was enabled. Interesting to note, that even after I
    re-enabled 3G, I only exhibited the WiFi address of 10.14.54.109. The Cell
    address reported by iStats stayed blank.

    One last point. When pinging my iPhone, my Macbook reported some packet
    loss ... i.e. that some of the ICMP packet request failed. Less than 10%,
    but some did fail. Here's the error message:

    Request timeout for icmp_seq x

    where x is the next sequential ICMP request.

    I also checked my console window, but nothing pops up. Question: Any way I
    can configure MD to show more on this screen in an effort to debug?

    Hope this helps. And I appreciate all of your help.

    Got to run ... I have to get back to making a living.

    sg

    If you have the iPhone app is running and both devices are connected to the
    same network and you are not able to see the iPhone in the device list of
    the network synchronizer extension it might be that your wifi router is
    blocking the bonjour protocol. You can create a computer-to-computer wifi
    connection directly between your iPhone and your desktop. Doing this will
    take you wifi router out of the loop. Below are instructions on how to do
    this on a variety of operating systems

    I need to try this again. But at first glance, my iPhone wasn't
    connecting. Let me try again and get back to you.

    sg

    OS X 10.6
     http://docs.info.apple.com/article.html?path=Mac/10.6/en/8339.html

  20. 20 Posted by Ben Spencer on 05 Jun, 2010 05:49 PM

    Ben Spencer's Avatar

    I suspect what is happening is that your wifi router is blocking the bonjour messages for some security reason. If you tell me the make an model of your router I'll do some research on the subject.

    One other thing you could try, from a command prompt enter the following:

    java -cp ~/.moneydance/fmodules/netsync.mxt com.strangeberry.jmdns.tools.Main

    This should bring up a the moneydance bonjour debugging info interface.
    If you start the iphone app you'll see a service of type mdncsync.tcp.local. appear.

    If you don't see this appear then the discovery messages from the iphone are being blocked or routed somewhere else.

    Ben

  21. 21 Posted by phil.roulo on 07 Jun, 2010 12:37 AM

    phil.roulo's Avatar

    Same here. I used MD for end of month reconciling at end of May. Since then there was an update to 751 and I haven't been able to sync since then. I have download the app for iphone and Mac and used the latest network sync file, no spaces in name, no firewall, even setup a comp to comp network still no devices seen

  22. 22 Posted by don on 07 Jun, 2010 10:07 PM

    don's Avatar

    Ben,

    Re: the KB article with the "Make sure..." list

    I had the same experience as Shawn, except that I am using a Computer-to-Computer network. My iPhone's wifi ip address and my computer's ip address differed in both their 3rd and 4th sets of numbers (both started with 169.254. but had different numbers after that); I set my computer to have a manual ip address that matched the iPhone's for the first three sets of numbers but with a unique last number. The effect was the same ("No devices running Moneydance were found").

    I set my phone to Airplane mode with the wifi connected to the Computer-to-Computer network (this helps another app, Bento for iPhone, to connect): same result. I tried Bento: it connected fine.

    com.strangeberry.jmdns.tools.Main showed other Bonjour discovery message action (including Bento), but never showed mdncsync.tcp.local.

    Don

  23. 23 Posted by shawn geraghty on 23 Jun, 2010 08:13 PM

    shawn geraghty's Avatar

    Ben:

    Sorry to take so long, but I've been busy working a contract that prohibits
    me from using my Mac.

    So, I ran the java program below on my job-site network, and the MD iPhone
    bonjour message indicator did not show up. So, I tried my home network, and
    I do see jmdns indicating that MD bonjour messages are being seen by my Mac,
    but still not devices show in the MD desktop app.

    I've included a screenshot for you to see.

    So far, it appears that some network routers will block the bonjour message,
    but my home network isn't one of them. I have confirmed that both my iPhone
    and Mac are on the same network. One thing I did differently was I
    unplugged my iPhone from my Mac. I don't think that will make a difference,
    and it didn't.

    Any other ideas? Any other debugging I can do?

    Thanks for all the help.

    sg

  24. 24 Posted by Ben Spencer on 28 Jun, 2010 03:34 PM

    Ben Spencer's Avatar

    Shawn

    I expect that you are doing this and I cannot tell form the screenshot, can you please confirm that you are clicking the "add device" button/

    Ben

  25. 25 Posted by Ben Spencer on 28 Jun, 2010 03:36 PM

    Ben Spencer's Avatar

    Don

    What is the subnet mask when you have both computers connected to the computer to computer network. If the last two sections of the Ipaddress are different the mask should be 255.255.0.0

    Ben

  26. 26 Posted by phil.roulo on 28 Jun, 2010 05:06 PM

    phil.roulo's Avatar

    After many tries, I finally got the iPad added (kept deleting and adding the MD app and the netsync file). I had to set the IP Address to Static and set the IP address and Subnet address to what the router was. I can't get it to sync automatically. I have turn the iPad off and on about 5 times and sometimes it will sync. Not a good way. There should be a button to push that will sync when you want it to.
    Phil

  27. 27 Posted by don on 29 Jun, 2010 08:22 PM

    don's Avatar

    Ben,

    The subnet mask when I have both computers connected to the computer to computer network is as you suggested: only the last two sections of the IP address are different and the mask is 255.255.0.0 on both the iPhone (according to the phone's preferences) and the Macbook (according to it's preferences).

    My iStat app on the iPhone shows both the wifi IP address and also a different cellular IP address, but doesn't show a subnet mask. My IP Config app on the iPhone shows the IP address to be the cellular address that iStat lists and the subnet mask to be 255.255.255.255 I assume that this subnet mask is only for the cellular connection.

    Don

  28. 28 Posted by shawn geraghty on 01 Jul, 2010 04:47 PM

    shawn geraghty's Avatar

    Ben:

    Yep, and it now shows up. I was able to synch my iPhone. I will need to do
    some further testing, and I want to go back and retrace my steps. But to
    date, I believe I have narrowed it down to:

    1.) check router to ensure bonjour messages are being routed;
    2.) turn-off firewall;
    3.) and leave iPhone unplugged from MBP.

    I suspect that using my home network, my firewall can be turned back on.
    Interestingly, I used 4 different networks before my home network was
    successful.

    Thanks to all at MD for all their help in getting this to work.

    sg

  29. Angie Rauscher closed this discussion on 24 Jul, 2011 07:56 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

14 Jul, 2024 11:01 PM
14 Jul, 2024 10:58 PM
14 Jul, 2024 10:32 PM
14 Jul, 2024 10:28 PM
14 Jul, 2024 09:49 PM