iPhone app transaction field entry buggy

pete's Avatar

pete

15 Jun, 2010 07:37 PM

I'm new to Moneydance and am moving away from MS Money. (Tried iBank but it just didn't cut it with slow performance issues and no way it seems to transfer reconciled transaction status. Looking for an offering which had an iPhone transaction entry option and Moneydance seemed like the best choice, albeit with an iPhone app which looks like it might be still work in progress.

Been testing the Moneydance iPhone for a couple of days now and have been running into the same reoccurring problems:

  1. Entry in fields (mainly description and memo fields) and then hitting 'Save' without first clicking the 'Done' button on the last field results in the entry made in the last field not being entered.

  2. In relation to the above issue, the 'On screen keyboard' stays on the screen after clicking 'Save'. Normally arises when on a text field and clicking 'Save' without clicking 'Done' first. Seems like clicking 'Save' doesn't force the record entry to be completed properly. End result is that I end up back on the Account List view with the keyboard still on the screen, which causes the last few accounts in the list to be hidden. Only fix is to go into another account, edit a transaction, click on a text field, click 'Done' in order to get the keyboard to disappear off the screen, then cancel the edit to then allow me to resume whatever I wanted to do.

  3. The '>' button next to the description often doesn't work unless the description field is selected. For example after selecting the category or entering the amount it seems to do nothing and I have to 'Save' and then go and find the transaction in order to edit it. Maybe it's picky about the area which is pressed, or the input area for that button is not aligned with the '(>)' image?

Any idea whether these bugs have already been recognised and fixed?

Many thanks,
Pete

  1. 1 Posted by Ben Spencer on 16 Jun, 2010 02:41 PM

    Ben Spencer's Avatar

    Hi Pete

    Can you make sure you are updated to the latest version of the iPhone app. We are up to version.1.2 and in that version I have not been able to reproduce any of the problems you described.

    Ben Spencer
    Moneydance Support

  2. 2 Posted by pete on 16 Jun, 2010 04:13 PM

    pete's Avatar

    Hi Ben,

    Yes definitely running version 1.2 of the iPhone app.

    Also, this is on an iPhone 3G, not that it should make any difference.

    I've just rebooted the iPhone and retested.

    Load MoneyDance.
    Enter Passcode.
    Hit '+'.
    Type digits to enter amount.
    Click on 'Description' field. Typed 'Test' (didn't exist in list) and clicked 'Save'.
    Clicking on '(>)' button doesn't work. Attempted 3 times on dead-centre. Clicked slightly above, below, to the right, gives same no response. Clicked slightly to the left and it responded and moved to the 'Edit Transaction' screen.
    (Attempted a second transaction later on using exactly the above approach and found the '(>)' to work first time. I haven't yet determined a repeatable test for this)

    Clicked on 'Account' and selected the very last account (which is a credit card) in my list. (Retested following the above steps again and it seems selecting any other account does work correctly, but selecting the last one, which happened to also be my main one, seems to reproduce this issue.)
    Clicked on 'Memo' field which brings up the Keyboard. Typed 'Testing'. Clicked 'Save'. The on-screen keyboard remains when returning to the Bank Account list, or an individual account transaction list when editing an existing transaction and changing the Account to which the transaction is allocated. (I've played around a bit further. Selecting a transaction in my last account and allocating it to the first account has also shown the problem, so it's not specific to allocating to the last account. And further allocating of a transaction between accounts seems to have worked in the main, so it's not easily reproduceable. I think it might be related to changing the account a transaction is assigned to at the same time as having the on-screen keyboard shown when clicking 'Save'. I created 3 transactions, and then quit the app and loaded it again. Viewing the last transaction showed that the 'Memo' field hadn't been saved, even though it was shown correctly when I created the transaction and repeatedly reallocated it between accounts. I must admit at this point, I can not reliably reproduce the problem. Could it be memory allocation related?)

    During my testing just now I accidentally allocated one of the transactions to an Account which isn't shown on the home screen, it's set in the main app to not display when it has an amount of zero. The account didn't appear during that execution of the app, it only appeared after quiting the app and reloading when it then spotted the balance was no longer zero.

    I'm fairly new to Moneydance and your prompt response has encouraged me to continue and embrace this a little more. I will continue to see how this goes over the coming days and see if I can figure out whether there's a pattern to the oddities. I'll report back in a few days with my experiences.

  3. 3 Posted by The Cappuccino ... on 17 Jun, 2010 01:02 PM

    The Cappuccino Kid's Avatar

    This has happened to me to, albeit on a fairly random basis.

    I agree that it could be a memory allocation issue. If I have not synced for a while (perhaps just a couple of days), when I enter a new transaction, hit the Description area, it moved to the correct screen but there are no payee suggestions.

    I was going to log this but was waiting until I had some sort of pattern. However, having seen the other issue I thought it worth reporting.

    Thanks

  4. 4 Posted by Angie Rauscher on 03 Jul, 2010 02:12 AM

    Angie Rauscher's Avatar

    Thank you for these detailed descriptions of the issue. I hope that the app update (currently being reviewed by Apple) will help with some of these problem. If not, please do let me know and we'll keep working on it.

    Please let me know if I can be of further assistance,

    Angie Rauscher
    Moneydance Support

  5. Angie Rauscher closed this discussion on 03 Jul, 2010 02:12 AM.

  6. pete re-opened this discussion on 11 Jul, 2010 12:06 PM

  7. 5 Posted by pete on 11 Jul, 2010 12:06 PM

    pete's Avatar

    Angie,

    Thanks for the information. Apple have finally released the app this morning. After trying it for entering a few entries this morning it seems all 3 of the issues I reported are no longer present. (I probably should also note that I have upgraded to iOS4 since originally reporting the issues.)

    Just one bug noted during testing this morning, the date entry wheels seem to be 1 day out. All of the entries I have been testing with this morning I have had to select one day earlier on the date wheels in order to have the date field show the correct date. ie select '9 | July | 2010' on the date wheels to get the date field to read '10/07/10'.
    However closing and re-opening the application seems to now operate correctly showing the correct date to date wheel synchronisation. Perhaps whatever condition caused the date bug was a rare one and unlikely to be reproduced regularly, but worth noting in case others report it too.

    Many thanks for all your assistance in resolving these issues. And it's also nice to see an iPad version of the app, almost tempting to buy an iPad! :)

  8. 6 Posted by Angie Rauscher on 13 Jul, 2010 03:09 PM

    Angie Rauscher's Avatar

    Pete,

    What an odd bug! I'm glad to hear it went away, and would definitely appreciate it if you would let me know if it recurs. I will add it to our bug tracking system.

    Please let me know if I can be of further assistance,

    Angie Rauscher
    Moneydance Support

  9. Angie Rauscher closed this discussion on 13 Jul, 2010 03:09 PM.

  10. Angie Rauscher re-opened this discussion on 13 Jul, 2010 03:09 PM

  11. 7 Posted by martin.j.lowe on 26 Jul, 2010 08:46 AM

    martin.j.lowe's Avatar

    I've had the date thing as well - needing to select 19 July on the date wheels to get the 20 July to be entered (using latest version on OS4)

  12. 8 Posted by pete on 03 Aug, 2010 08:09 AM

    pete's Avatar

    After some weeks of using the Moneydance iPhone application I've discovered that many of the entries i've entered have not saved the 'Memo' field of the entry. I've noticed this after syncing to the app on my Mac and seeing a whole block of entries with no memo stored, and ever single one I entered a 'Memo' entry as the very last thing before hitting 'Save'.

    So I can confirm that issue #1 in my original report above is still a problem.

  13. 9 Posted by The Cappuccino ... on 03 Aug, 2010 08:30 AM

    The Cappuccino Kid's Avatar

    I can reproduce Pete's issue.

  14. 10 Posted by Angie Rauscher on 12 Aug, 2010 07:17 PM

    Angie Rauscher's Avatar

    Hi all,

    Our developer is actively working on fixes to these issue on the iphone app. We hope to release a fix "soon" (I don't have a firmer timeline). We do know this is a serious problem for our users.

    Thank you for bearing with us,

    Angie
    Moneydance Support

  15. 11 Posted by icycle on 15 Jan, 2011 03:47 PM

    icycle's Avatar

    Adding a "me too" for I'm also seeing inconsistent memo field sync. The fix you mention above in August, what's the latest info on that now that it's January? :-)

  16. 12 Posted by Chuck on 19 Jan, 2011 01:28 PM

    Chuck's Avatar

    Agreed - still seems to be a bug.

  17. 13 Posted by Chuck on 28 Feb, 2011 12:48 PM

    Chuck's Avatar

    Any progress on this bug? This bug is making Moneydance mobile useless to me.

  18. 14 Posted by Angie Rauscher on 30 Mar, 2011 06:37 PM

    Angie Rauscher's Avatar

    I don't have any progress to report at the moment- we're working hard to get Moneydance 2011 put to bed and then we'll shift our focus to working more intensely on the iphone app. We'll post both on this thread and on our blog when the new version of the app is available. I do apologize for the delay, I know this is a serious issue for our users.

    Angie Rauscher
    Moneydance Support

  19. 15 Posted by Jessica Little on 06 Jul, 2012 01:24 PM

    Jessica Little's Avatar

    Hi All,

    A fix for the date bug is in the newly released 1.5 version of the iOS app. You can download the update from the App Store. Sorry for the delay!

    Jessica Little
    Moneydance Support

  20. Jessica Little closed this discussion on 06 Jul, 2012 01:24 PM.

  21. pete re-opened this discussion on 07 Jul, 2012 11:48 AM

  22. 16 Posted by pete on 07 Jul, 2012 11:48 AM

    pete's Avatar

    Hi Jessica,

    Thank you very much for following up with this after all this time. I do indeed believe that the date field is resolve as I have not noticed the issue reoccurring.

    I have observed one further oddity since the 1.5 update. I seem to be experiencing the situation where if I enter a transaction late on one day (eg around 11pm) using the 'today' date of that day, and then enter a new transaction the following day (eg midday the following day) the date defaults to yesterday's date, rather than using today's date.

    I can see that having a default of the same date as previously entered is useful for entering several transactions for previous days in one go (I think this is what's happening) but after a few hours of inactivity it's probably useful to default back to 'today'. (again I think this is what I'm observing but its only been a few days. I can monitor further and let you know if you think it's useful)

    Many thanks for your continued support,

    Pete

  23. 17 Posted by Jessica Little on 07 Jul, 2012 12:16 PM

    Jessica Little's Avatar

    Hi Pete,

    Thanks for the report. I'll test it out to see if I can duplicate it as well. Definitely let us know if it seems to keep happening or, conversely, if it stops happening.

    Jessica Little
    Moneydance Support

  24. System closed this discussion on 31 Mar, 2015 03:31 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

14 Jun, 2024 04:59 AM
14 Jun, 2024 02:45 AM
14 Jun, 2024 02:01 AM
13 Jun, 2024 10:05 PM
13 Jun, 2024 09:58 PM