Setting investment transaction type to InvestTxnType.SHORT results in InvestTxnType.COVER

Scott R.'s Avatar

Scott R.

23 Nov, 2016 11:19 PM

No matter what I try I am unable to set the "action" type of an investment transaction to InvestTxnType.SHORT. I've tried:

TxnUtil.setInvstTxnType(newTxn, (InvestTxnType.SHORT))
invstFields.setFieldStatus(InvestTxnType.SHORT, newTxn)

Both of these methods change the type to InvestTxnType.COVER instead of SHORT. I've tried both existing transactions read from my file as well as newly (programmatically) created transactions.

Is there some magic to this that I'm missing, or is it just not possible via the public API? The strange thing is that I am able to manually change the action/investment type to "Short" through the Moneydance register, and when I print these transactions out via a script they have the correct (SHORT) type.

I am trying my best to take matters into my own hands to resolve my Quicken import issue that is preventing me from becoming a paying Moneydance customer:

If I only had a few of these types of transactions I would just fix them manually, but I have hundreds of them (I regularly write call and put options for income).

Any insights or suggestions would be appreciated.

  1. System closed this discussion on 22 Feb, 2017 11:20 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac