Error when installing MoneyPie

janecraft's Avatar


03 May, 2020 05:56 PM

Hi, I'm new to Moneydance, so far so good. I found through all the discussions that I could try envelope budgeting with the MoneyPie extension. However, when I attempt to install it, I get this error:

Error loading extension: java.lang.StringIndexOutOfBoundsException: begin 0,

MoneyPie is not listed in the dropdown under Extensions in the main toolbar, but when I go to "Manage Extensions", it shows MoneyPie as installed.

I tried removing and installing the MoneyPie extension a few times and got the same result.

I was able to install Find and Replace -- it worked as expected.

Please advise!

  1. 1 Posted by derekkent23 on 03 May, 2020 06:38 PM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi janecraft

    Just for information
    Running Moneydance 2019.4(1904) on windows 10.
    I don’t use MoneyPie but as a test it installed correctly.

    Perhaps close the reopen Moneydance and try to install MoneyPie,

    If it does not install close Moneydance and post your errlog.txt file.

    If you're using Mac OS X, it should be located at one of these locations within your Home folder:
    Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance/errlog.txt
    Library/Application Support/Moneydance/errlog.txt
    If you have any trouble finding your Home Library folder, open Finder and select Go -> Go to Folder and type in:
    ~/Library This should pull up your local Library folder.

    If you're using Windows, it should be located at:

    If you're using Linux, it should be located at:

    Hope this helps.

  2. 2 Posted by janecraft on 03 May, 2020 09:02 PM

    janecraft's Avatar

    Thank you derekkent23. Closing and reopening didn't help, nor did restarting the computer and reopening Moneydance. I'm using Windows 7. The log is attached. Thank you!

  3. 3 Posted by derekkent23 on 03 May, 2020 10:00 PM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi janecraft

    If you open the errlog.txt file in say notepad you will see that Moneydance is having a problem loading MoneyPie starting line that reads:

    Error loading extension module moneyPie:
    java.lang.StringIndexOutOfBoundsException: begin 0, end 4, length 1

    I am running 2019.4(1904) which runs java 13.0.1 so as a test I installed the build you are running 2019.3(1880) which run on an older java version 11.0.2 but MoneyPia still installed.
    So, we are left with the difference that I am running window 10 you windows 7.

    I don’t know if this is significant or if there is something else in your setup that’s creating the issue.

    I think this is one for support with a java background to comment on

    Sorry I can’t help.

  4. 4 Posted by janecraft on 04 May, 2020 04:06 AM

    janecraft's Avatar

    Thank you derekkent23 for your work to replicate this problem. I appreciate your time.

  5. 5 Posted by janecraft on 22 May, 2020 08:46 PM

    janecraft's Avatar

    Are there any other ideas out there? I'd love to be able to use MoneyPie. Thank you!

  6. Support Staff 6 Posted by Sean Reilly on 22 May, 2020 09:58 PM

    Sean Reilly's Avatar

    Hi Jane,

    Thanks for sending the logs. I've found and fixed the problem in the moneypie extension. Can you update the extension using the Extensions->Manage Extensions menu? The new version of the MoneyPie extension is version 1016. Please post in this thread if it doesn't solve the problem!

    As far as I can tell it seems like the extension had a problem with one of the dates in your data file. If I'm not mistaken there is some transaction in your file that has a year that is less than 1000! The new version of the extension should be able to deal with that situation.


    Sean Reilly
    Developer, The Infinite Kind

  7. 7 Posted by janecraft on 22 May, 2020 10:29 PM

    janecraft's Avatar

    It worked! Thank you! And for the strange year -- I'll look into that. I'm a new user importing from Quicken. I had not run into such an error but I'll look for it now. Thanks again for solving this for me!

  8. System closed this discussion on 21 Aug, 2020 10:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac