No trusted certificate found for First Tech Federal Credit Union

MUser's Avatar

MUser

24 Nov, 2018 06:15 PM

I know that First Tech Federal Credit Union recently changed some stuff on the online banking. I think they also changed their certificate and Moneydance needs to update the certificate. I am on Moneydance v. 2017.10 (1706), and this version has the error:

There was an error communicating with your financial institution. The details of this error are below.

Bank Name: First Tech Federal Credit Union

A communication or parsing error occurred. This could be the result of a network problem, a proxy error, or misconfigured server.
Error Description: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: No trusted certificate found

--

Besides fixing this immediate issue, I recommend a feature that automatically updates the certificate with online banking institutions without having to upgrade. These change often enough to warrant this feature.

  1. 1 Posted by dwg on 24 Nov, 2018 07:39 PM

    dwg's Avatar
  2. 2 Posted by jon.d.slater on 28 Nov, 2018 10:28 PM

    jon.d.slater's Avatar

    Me too (First Tech, same error.)
    But I've also been told it's being worked. :-)

  3. System closed this discussion on 27 Feb, 2019 10:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac