Paypal QIF import fails

mike's Avatar

mike

11 Feb, 2019 01:01 AM

I just switched to Moneydance Mac 2019.1 and I'm trying to import a QIF file created by Palpal for my non-business account. This has worked a few months ago, but I don't know if it is 2019.1 or PayPal that has changed something. I request custom activity download from the PayPal web site and it creates what it calls a Quicken QIF format file. I try to import that an instead of importing about dozen transactions, I get one. If I try it a second time, I get a duplicate of the same transaction. After I click on import and select the file, I get the import dialog box that asks for the account name, date format, and decimal character.

Below is one of the transactions from the top of the QIF file that fails:

!Type:Cash
D09/22/2018
T-69.48
LeBay Auction Payment
SeBay Auction Payment
$-69.48
SFee
$0.00
CX
MMILWORK FLOO...
PWilson Floor
^

  1. 1 Posted by dwg on 11 Feb, 2019 04:04 AM

    dwg's Avatar

    I'm a fellow user.

    I have just tried importing that one transaction in MD2019.1 (1855) and it worked as expected.

    Does each transaction have a caret (^) after the transaction, missing this is one way of preventing QIF files loading correctly

  2. 2 Posted by jcmoor1-nospam on 12 Feb, 2019 12:45 AM

    jcmoor1-nospam's Avatar

    I am having exactly the same problem with Paypal and Moneydance 2019.1(1855) on Windows 7. Only one transaction out of a group is imported. I can see all of he transactions when I open the qif file in notepad. See attached file. There is a caret after each transaction

  3. 3 Posted by dwg on 12 Feb, 2019 01:49 AM

    dwg's Avatar

    I'm a fellow user.

    I have been able to use the file download.qif to reproduce a totally different problem reported in another thread, that is importing this file creates an account with the name "Imported Bank Account".

    There is something not right happening with QIF imports.

  4. 4 Posted by dwg on 12 Feb, 2019 01:54 AM

    dwg's Avatar

    I have placed a pointer for the developer to this thread.

  5. 5 Posted by dwg on 27 Feb, 2019 11:01 PM

    dwg's Avatar

    I do not know if it addresses this problem but the latest preview has some QIF fixes:

    http://infinitekind.com/preview

  6. 6 Posted by mike on 11 Mar, 2019 07:26 PM

    mike's Avatar

    I tried the preview Moneydance (2019.2 (1860) and got the same effect. Only the first transaction is loaded.

  7. 7 Posted by mike on 11 Mar, 2019 09:08 PM

    mike's Avatar

    I messed around with the QIF file a bit to see if I could get the Paypal version to import. I removed the split transaction that PayPal includes by default, but still no luck. However, I eventually figured out the problem. When as QIF file is imported, you have to select the account to import it to. The default is "Imported Bank Account". I always changed this to "PayPal" and the first transaction would get imported to my PayPal account. HOWEVER - After doing this a few times, I realized that Moneydance had created a new account called "imported Bank Account" and had put all the other (after the first) in that. I import QIF from other banks and this doesn't happen, however it looks like a moneydance bug to me in that it ignores the account name I select.

  8. 8 Posted by jcmoor1-nospam on 11 Mar, 2019 10:08 PM

    jcmoor1-nospam's Avatar

    I get the same result as Mike.

  9. Support Staff 9 Posted by Sean Reilly on 08 Apr, 2019 07:56 PM

    Sean Reilly's Avatar

    Hey all,

    Could you give this a try with the current preview build? I believe I've fixed this issue, along with a bunch of other QIF import problems. https://infinitekind.com/preview

    Thanks!
    Sean

    --Sean Reilly Developer, The Infinite Kind
    https://infinitekind.com

  10. 10 Posted by Joe Moore on 08 Apr, 2019 09:54 PM

    Joe Moore's Avatar

    Sean,
    The transactions are all importing, but:

      * Shows every transaction as a split with an Ebay fee, even if the fee is zero
      * All of the transactions are marked as cleared prior to me marking them as such.
      * The default category that I have specified for this account in Moneydance is not honored (this is not new I believe, as I have had this as an issue with other accounts as well). Categories that I have never used, such as “preapproved payment bill user payment”, “postage payment”, and “Ebay auction payment” are prepopulated.

    Looks like progress, keep at it.
    Thanks.
    Joe Moore

    ________________________________

  11. 11 Posted by dwg on 09 Apr, 2019 11:09 PM

    dwg's Avatar

    Have you selected the checkbox "file was downloaded"?

  12. 12 Posted by mike on 10 Apr, 2019 01:51 AM

    mike's Avatar

    I tried the preview version and 2019.2 (1865) and PayPal transactions could be imported to the correct account, but I also experience that all came with category splits and were pre-reconciled. In looking at the raw QIF file, it looks like this is PayPal's fault in the way they format QIF transactions.

    I'm thinking I need to create some kind of script to preprocess the QIF before trying to import it. Is there a regex function in the import module that I can use to reformat this?

  13. 13 Posted by Joe Moore on 10 Apr, 2019 09:34 AM

    Joe Moore's Avatar

    Initially I did not check the "file was downloaded" box, but on retry the new transactions seem properly imported, with no splits, no marked as cleared, and with prior category designations intact. Maybe more emphasis on why this box needs to be checked is in order if this is the issue.

    ________________________________

  14. Support Staff 14 Posted by Sean Reilly on 10 Apr, 2019 10:01 AM

    Sean Reilly's Avatar

    The "file was downloaded" box only appears if the QIF file contains a single account. Ticking that box will tell Moneydance to mark those transactions as needed confirmation and to not auto-create categories or record the cleared status of transactions in the file. As Mike mentioned, the QIF files that come from paypal put their own categories into the file and also mark transactions as cleared, which is probably ok for some people, but not what most want. It's also unlike any other QIF file provide I've encountered.

    So in most cases, I think including yours, it's better to not check that box. However it seems like the option needs to be there for somewhat rare cases.

    Thanks,
    Sean

  15. 15 Posted by Patrick Callaha... on 24 Apr, 2019 08:10 PM

    Patrick Callahan's Avatar

    I'm getting the single transaction imported symptom with a qif file from Chase Bank (new york) I tried downloading the preview and installed it. Now when I try to import one of two things happen:

    1 I get one transaction and the rest are who knows where. or
    2 the application freezes. then
    using task manager to kill moneydance and restarting it. the first transaction is duplicated.

    No file was downloaded box appears.

    Moneydance Version is 2019.3(1870)

    file contents:
    !Type:CCard
    C*
    D04/23/2019
    NN/A
    PSUNOCO 0005236510
    T-31.66

    C*
    D04/23/2019
    NN/A
    PSANDRA WEAKLAND D.P.M.
    T-50.0

  16. 16 Posted by dwg on 24 Apr, 2019 09:10 PM

    dwg's Avatar

    I'm a fellow user.

    This problem came up some time ago.

    Chase have basically stuffed up the QIF file. Every record in a QIF file must be ended with a caret (^) on a line on its own. Chase are not doing this they have a blank line but this is not valid, therefore Moneydance is not able to interpret the file correctly, I understand customers have complained but nothing has been done about it.

    If you want to work with downloaded files from Chase I suggest you try to download OFX/QFX files.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac