Unable to sync with Patelco anymore

serg.leo's Avatar

serg.leo

12 Feb, 2019 01:35 PM

I'm getting SSL handshake error in the past couple of days when trying to sync with Patelco CU
See output below:

A communication or parsing error occurred. This could be the result of a network problem, a proxy error, or misconfigured server.
Error Description: javax.net.ssl.SSLHandshakeException: No trusted certificate found

  1. 1 Posted by wguy4biz on 13 Feb, 2019 01:16 AM

    wguy4biz's Avatar

    I am having the same problem. I have not attempted a download for a couple of months, and Patelco may have changed something, but i had this problem a few years ago and it was resolved by correcting my credentials to be my account number and PIN, as opposed to the website login. This time, however, nothing seems to work to address the problem.

    I opened a New file in Moneydance and attempted to set up a new account with online banking, but it never asked me for a password. I did this with the console window open to obtain diagnostics. I included the account online setup as well as the attempt at downloading; the download did not produce any results.

    I have a workaround in the form of manually downloading transactions from each account in OFX format and importing, but would like to see this problem addressed quickly.

    Thanks, John

  2. 2 Posted by serg.leo on 14 Feb, 2019 02:05 PM

    serg.leo's Avatar

    I wish MD developers could add settings to allow untrusted SSL certificates for banking connections.

  3. 3 Posted by dwg on 14 Feb, 2019 08:09 PM

    dwg's Avatar

    The certificate error is the bank's server saying that Moneydance has not got the certificate the bank wants.

  4. 4 Posted by serg.leo on 14 Feb, 2019 08:23 PM

    serg.leo's Avatar

    The https://www.ofxhome.com/index.php/institution/view/460 says SSL certificate from Patelco is valid, can this issue get escalated?

  5. 5 Posted by serg.leo on 20 Feb, 2019 12:08 PM

    serg.leo's Avatar

    Hey, MD dev team, any resolution?

  6. 6 Posted by serg.leo on 22 Feb, 2019 04:14 PM

    serg.leo's Avatar

    I was reviewing console log and found this warning, could it be related to root cause?

    FI refresh is forced
    warning: unable to refresh FI info from moneydance.com. error: java.lang.NullPointerException

  7. 7 Posted by hleofxquotes on 26 Feb, 2019 09:43 PM

    hleofxquotes's Avatar

    I know this won't help you directly but for what it worths

    Using a non-MD tool with a fake userName/password, I am getting back a response

    <?xml version="1.0" encoding="UTF-8" standalone="no"?>
    <?OFX OFXHEADER="200" VERSION="200" SECURITY="NONE" OLDFILEUID="NONE" NEWFILEUID="NONE"?>
    <OFX><SIGNONMSGSRSV1><SONRS><STATUS><CODE>15500</CODE><SEVERITY>ERROR</SEVERITY><MESSAGE>User or Member password invalid</MESSAGE></STATUS><DTSERVER>20190226133933.479[-8:PST]</DTSERVER><LANGUAGE>ENG</LANGUAGE><FI><ORG>Patelco Credit Union</ORG><FID>2000</FID></FI></SONRS></SIGNONMSGSRSV1><SIGNUPMSGSRSV1><ACCTINFOTRNRS><TRNUID>61eabcde-6686-434f-b50b-512ee3590986</TRNUID><STATUS><CODE>15500</CODE><SEVERITY>ERROR</SEVERITY></STATUS></ACCTINFOTRNRS></SIGNUPMSGSRSV1></OFX>
    
  8. 8 Posted by serg.leo on 27 Feb, 2019 02:13 PM

    serg.leo's Avatar

    I spoke with Patelco, they are not aware about any issues with ofx.patelco.org, they said it's working fine and the only banking software that authorized to communicate with Patelco is Quicken, they don't even know what Moneydance is. So, I really believe that this issue should be resolved by MD team. And unfortunately I don't see any responses from support team in this thread, looks like they just disappeared. Unacceptable.

  9. Support Staff 9 Posted by Henry on 27 Feb, 2019 04:09 PM

    Henry's Avatar

    Please accept my sincere apologies for the delay getting back to you. We've been receiving a very high volume of support requests since the release of Moneydance 2019 and unfortunately some discussions have been missed. Sorry again for the wait you have endured.

    We've made a change to the Patelco CUconnection information within Moneydance, so you should be able to connect again now.

    You will need to disable your current connection to your bank and then recreate it using the New Connection button on the Online Banking Setup screen. To do so, you can follow these steps:

    Select your bank account in Moneydance

    Select Online --> Setup Online Banking
    Click the "Disable" button. If you don't see this button, just close the setup window.

    Repeat the previous steps for any additional accounts at the same institution.
    Select Online --> Setup Online Banking (again)

    Click the "New Connection" button and select your bank and hit OK
    Continue with the setup process, entering your username/password

    Make sure you pick "New Connection", even though your bank is still one of the connection choices after you disable it. Choosing your bank from the long list of available banks will force Moneydance to download the updated information, which should then allow you to connect.

    Please let me know if you're still seeing the error after following these steps and I will provide further instructions.
    If the problems persist, can you confirm which version and build of Moneydance you are running?
    To check, open Moneydance and select Help --> About Moneydance (or Moneydance --> About Moneydance on a Mac) where the version and build number will be displayed.

    Henry
    Infinite Kind Support

  10. 10 Posted by serg.leo on 27 Feb, 2019 04:17 PM

    serg.leo's Avatar

    Hi Henry, thank you for your response. I've followed steps provided and I've received the same error during New Connection setup process, I saw refresh window appear before error occurred. I'm using 2019.1 (1855) version of MD.

  11. 11 Posted by serg.leo on 27 Feb, 2019 04:33 PM

    serg.leo's Avatar

    Henry, please see the console log attached (masked account numbers) , I'm seeing following errors:

    FI refresh is forced
    warning: unable to refresh FI info from moneydance.com. error: java.lang.NullPointerException
    FI refresh is forced
    FI refresh is forced
    warning: unable to refresh FI info from moneydance.com. error: java.lang.NullPointerException
    FI refresh is forced

  12. 12 Posted by serg.leo on 27 Feb, 2019 05:33 PM

    serg.leo's Avatar

    Quick update, I've downloaded 2019.2 (1858) and it appears to be working now with Patelco CU, however! The sync with Chase is broken, getting the same SSL handshake error for Chase. Switching back to 2019.1, I'm getting opposite results, Chase is working and Patelco not, obviously something with the Moneydance code.

  13. 13 Posted by waltzerer.kwpk on 27 Feb, 2019 06:19 PM

    waltzerer.kwpk's Avatar

    This MAY be new in 1858; I encountered the same certificate error for Chase and Fidelity Netbenefits in 1858; reverting to 1857 resolved this problem for these two financial institutions for me.

  14. Support Staff 14 Posted by Henry on 27 Feb, 2019 06:26 PM

    Henry's Avatar

    @serg.leo Thank you for confirming, ok Patelco CU works with 2019.2 (1858) but Chase doesn't work with the same version.

    Would it be possible for you to share a log of 2019.2 Chase connection issue?

    @bix.kwpk You found an error with 1858 with both Chase and Fidelity Netbenefits, the same issue is not present with 1857.

    Would it be possible to see a log of Fidelity Netbenefits, when you attempt the connection in 1858?

    Thank you both for your help with this, I have marked this discussion for our connections specialist, your logs will be very appreciated.

    Henry
    Infinite Kind Support

  15. 15 Posted by serg.leo on 27 Feb, 2019 06:41 PM

    serg.leo's Avatar

    Henry, please see console log for Chase sync attached

  16. 16 Posted by waltzerer.kwpk on 27 Feb, 2019 06:55 PM

    waltzerer.kwpk's Avatar

    Henry, please see the attached file - I hope this is what you're looking for - if not, I may need a pointer on how to generate something more helpful, please!

    THANK YOU for referring this to your specialist!

  17. 17 Posted by derekkent23 on 28 Feb, 2019 07:50 AM

    derekkent23's Avatar

    I am not support staff, just a user.

    Preview build 1959 has been released https://infinitekind.com/preview
    It has been reported by another user that Build 1859 has resolved the direct-connect errors for Chase Visa and Fidelity Investments.
    Worth a try.

    Hope this helps.

  18. 18 Posted by serg.leo on 28 Feb, 2019 01:27 PM

    serg.leo's Avatar

    I can confirm that, just installed 2019.2 (1859) and all syncs are working. Thank you MD team!

    Quick observation about beta, the color scheme is off on budget bar chart, the amount is blended with color and nearly unreadable, see attached.

  19. 19 Posted by waltzerer.kwpk on 28 Feb, 2019 07:49 PM

    waltzerer.kwpk's Avatar

    I have installed build 1859. and confirming the prior appends, the download issues with Chase and Fidelity Netbenefits are resolved.

    THANK YOU to the Moneydance team for great support! :-)

  20. 20 Posted by Bob Miller on 02 Mar, 2019 02:04 AM

    Bob Miller's Avatar

    I also can no longer download from Patelco CU. I've tried the suggestions to create a new connection without success. I'm testing MD on 2019.1 build 1855 and only have 7 transactions left on my trial before I need to pay the registration/buy fee. I don't know if I can update to build 1859, from the trial version, to see if that resolves the problem. The Patelco CU download capability is critical to me. It does seem like a MD problem because the Quicken download is still working. I hope that this can be resolved so that I can buy the MD license and dump Quicken.

  21. 21 Posted by dwg on 02 Mar, 2019 02:28 AM

    dwg's Avatar

    I'm a fellow user.

    You can upgrade to build 1859, being in trial mode makes no difference to this.

  22. 22 Posted by Bob Miller on 02 Mar, 2019 03:40 PM

    Bob Miller's Avatar

    I can't seem to find build 1859 to test if the Patelco CU download problem is fixed. I only see a download for build 1855. I downloaded it anyway and ran through the installation. It is definitely build 1855. Does anyone know where I can find the latest build? Note that I'm still on the trial version.
    Thanks,

  23. 23 Posted by serg.leo on 02 Mar, 2019 03:49 PM

    serg.leo's Avatar

    @Bob follow this link to get 1859 build. It definitely has resolved syncing issues with Patelco

  24. 24 Posted by serg.leo on 02 Mar, 2019 03:50 PM

    serg.leo's Avatar
  25. 25 Posted by Bob Miller on 02 Mar, 2019 04:28 PM

    Bob Miller's Avatar

    Thanks serg.leo,
    I followed your link to build 1859. I installed, and successfully made the connection and downloads from Patelco CU. I'm going to retest my other bank connections to make sure that they still work.

  26. System closed this discussion on 01 Jun, 2019 04:30 PM.

  27. serg.leo re-opened this discussion on 17 Jun, 2019 05:56 PM

  28. 26 Posted by serg.leo on 17 Jun, 2019 05:56 PM

    serg.leo's Avatar

    After I've upgraded to 1868, the error message came back. Seems like old code sneaked in somehow? Anyone else having this issue?

    "A communication or parsing error occurred. This could be the result of a network problem, a proxy error, or misconfigured server.
    Error Description: javax.net.ssl.SSLHandshakeException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed"

  29. 27 Posted by serg.leo on 18 Jun, 2019 05:17 PM

    serg.leo's Avatar

    Detailed error log:

    A communication or parsing error occurred. This could be the result of a network problem, a proxy error, or misconfigured server.
    Error Description: javax.net.ssl.SSLHandshakeException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed
    javax.net.ssl.SSLHandshakeException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed
    at java.base/sun.security.ssl.Alert.createSSLException(Unknown Source)
    at java.base/sun.security.ssl.TransportContext.fatal(Unknown Source)
    at java.base/sun.security.ssl.TransportContext.fatal(Unknown Source)
    at java.base/sun.security.ssl.TransportContext.fatal(Unknown Source)
    at java.base/sun.security.ssl.CertificateMessage$T12CertificateConsumer.checkServerCerts(Unknown Source)
    at java.base/sun.security.ssl.CertificateMessage$T12CertificateConsumer.onCertificate(Unknown Source)
    at java.base/sun.security.ssl.CertificateMessage$T12CertificateConsumer.consume(Unknown Source)
    at java.base/sun.security.ssl.SSLHandshake.consume(Unknown Source)
    at java.base/sun.security.ssl.HandshakeContext.dispatch(Unknown Source)
    at java.base/sun.security.ssl.HandshakeContext.dispatch(Unknown Source)
    at java.base/sun.security.ssl.TransportContext.dispatch(Unknown Source)
    at java.base/sun.security.ssl.SSLTransport.decode(Unknown Source)
    at java.base/sun.security.ssl.SSLSocketImpl.decode(Unknown Source)
    at java.base/sun.security.ssl.SSLSocketImpl.readHandshakeRecord(Unknown Source)
    at java.base/sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
    at java.base/sun.security.ssl.SSLSocketImpl.ensureNegotiated(Unknown Source)
    at java.base/sun.security.ssl.SSLSocketImpl$AppOutputStream.write(Unknown Source)
    at java.base/java.io.OutputStream.write(Unknown Source)
    at com.moneydance.apps.md.controller.olb.CustomURLStreamHandlerFactory$HttpsURLConnectionImpl.connect(CustomURLStreamHandlerFactory.java:679)
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2661)
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.sendMessage(OFXConnection.java:2568)
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.refreshServiceInfo(OFXConnection.java:624)
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.initSecureServices(OFXConnection.java:914)
    at com.moneydance.apps.md.controller.olb.ofx.OFXConnection.getTransactions(OFXConnection.java:924)
    at com.moneydance.apps.md.view.gui.OnlineManager.downloadAllTxns(OnlineManager.java:524)
    at com.moneydance.apps.md.view.gui.MoneydanceGUI.doNetSync(MoneydanceGUI.java:2929)
    at com.moneydance.apps.md.controller.uri.Dispatcher$UIDispatcher.run(Dispatcher.java:130)
    at com.moneydance.apps.md.controller.uri.Dispatcher$UIDispatcher.invoke(Dispatcher.java:79)
    at com.moneydance.apps.md.controller.uri.Dispatcher.invoke(Dispatcher.java:53)
    at com.moneydance.apps.md.controller.Main.showURL(Main.java:1007)
    at com.moneydance.apps.md.controller.BackgroundOpsThread$DownloadAllTask.run(BackgroundOpsThread.java:204)
    at com.moneydance.apps.md.controller.BackgroundOpsThread.run(BackgroundOpsThread.java:151)
    Caused by: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed
    at java.base/sun.security.validator.PKIXValidator.doValidate(Unknown Source)
    at java.base/sun.security.validator.PKIXValidator.engineValidate(Unknown Source)
    at java.base/sun.security.validator.Validator.validate(Unknown Source)
    at java.base/sun.security.ssl.X509TrustManagerImpl.validate(Unknown Source)
    at java.base/sun.security.ssl.X509TrustManagerImpl.checkTrusted(Unknown Source)
    at java.base/sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(Unknown Source)
    ... 28 more
    Caused by: java.security.cert.CertPathValidatorException: validity check failed
    at java.base/sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(Unknown Source)
    at java.base/sun.security.provider.certpath.PKIXCertPathValidator.validate(Unknown Source)
    at java.base/sun.security.provider.certpath.PKIXCertPathValidator.validate(Unknown Source)
    at java.base/sun.security.provider.certpath.PKIXCertPathValidator.engineValidate(Unknown Source)
    at java.base/java.security.cert.CertPathValidator.validate(Unknown Source)
    ... 34 more
    Caused by: java.security.cert.CertificateExpiredException: NotAfter: Sun Jun 16 18:59:59 CDT 2019
    at java.base/sun.security.x509.CertificateValidity.valid(Unknown Source)
    at java.base/sun.security.x509.X509CertImpl.checkValidity(Unknown Source)
    at java.base/sun.security.provider.certpath.BasicChecker.verifyValidity(Unknown Source)
    at java.base/sun.security.provider.certpath.BasicChecker.check(Unknown Source)
    ... 39 more

  30. 28 Posted by serg.leo on 19 Jun, 2019 03:09 PM

    serg.leo's Avatar

    Hmm, it's working now. Probably issue was at Patelco.

  31. serg.leo closed this discussion on 19 Jun, 2019 03:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac