Citi Bank connections

pretzel.logic1's Avatar

pretzel.logic1

12 Apr, 2020 03:47 PM

I keep getting this error for any citi cards accounts I have. This has been going on for weeks now. On occasion I can run the download again and it will complete downloading transactions. I am using the last beta version 2019.4 (1904) but this was present in the last release also. This is starting to get annoying so is this something on MD side or Citi side.

There was an error communicating with your financial institution. The details of this error are below.
Bank Name: Citi Cards
The error code reported by the server was: 2000
We've had a problem processing your request. It may take 24 to 36 hours for the problem to be resolved. Please try again at that time.

Showing page 3 out of 6. View the first page

  1. 61 Posted by garywiley on 20 May, 2020 05:11 PM

    garywiley's Avatar

    This problem re-surface last week. I had this problem about a month ago, but it was corrected. MD please correct the issue.

  2. 62 Posted by gary.hammer on 20 May, 2020 06:28 PM

    gary.hammer's Avatar

    Likewise on my Citi account, I can and have done a manual download, but nicer if this is corrected.

  3. 63 Posted by layer on 21 May, 2020 12:55 AM

    layer's Avatar

    When the problem a month ago was corrected, how was it corrected by MD, if there hasn't been a release of the software for a good while? 2019.3 (1880) is the latest and it came out last July! I don't see how MD can fix it without software. Someone know something I don't?

    If they can't, then Citi fixed it, I'm assuming. If it is the same problem as before, then waiting for Citi... damn, that's going to suck. Banks have the worst backend support to frontend customers. Ugh.

  4. 64 Posted by dwg on 21 May, 2020 01:36 AM

    dwg's Avatar

    I'm a fellow user.

    Without a new software build there is only a limited amount that TiK can do. The information they do maintain centrally is the connection information, i.e. the basic connection settings that is behind the Bank you pick from the list. You can see the type of information this is by looking at the Advanced Setup option. This sort of information I would expect to either be right or wrong, not something that works today, doesn't work tomorrow, works the next day etc, if there is something wrong or needs updating, updates have been needed in the past, I tend to expect a more consistent type of failure.

  5. 65 Posted by jc4mee on 21 May, 2020 11:00 AM

    jc4mee's Avatar

    Has there been a resolution to this yet? I have not been able to download my transactions in several days.

  6. 66 Posted by Gian Luca Fiori on 21 May, 2020 11:45 AM

    Gian Luca Fiori's Avatar

    Same here. Not able to download or change password.

  7. 67 Posted by whitedavidp on 21 May, 2020 03:44 PM

    whitedavidp's Avatar

    Just FYI, this persists into 5/21/2020 here. It may be that MD cannot fix this without a new release. But in the recent past with exactly the same symptoms (cannot say anything about the actual problem), this got fixed without a new release or patch or anything like that. From that I have to presume the issue is either with Citi OR with some configuration parameters for getting at/interacting with the server at Citi. No idea which.

    Once again, at least we can go to the Citi website and export transactions and shoot them into MD. It appears that the first time you do this you should expect duplicate transactions that must be merged. But for me, after that this has not been an issue. Only a few days trial though. Is this as convenient or as expected - NO. Is it a viable work-around until this gets fixed - possibly.

  8. 68 Posted by jerryskipschnei... on 21 May, 2020 04:38 PM

    jerryskipschneider's Avatar

    Same problem here.
    I get:
     "The error code reported by the server was: 2000
    We've had a problem processing your request. It may take 24 to 36 hours for the problem to be resolved. Please try again at that time."

    I contacted Citibank. They tried re-opening the port. No good. Told me to contact IK.

  9. 69 Posted by donna on 21 May, 2020 04:38 PM

    donna's Avatar

    Question - does anyone know if this is also a problem in Quicken? I am not planning to switch, this is a theoretical debugging question.

  10. 70 Posted by sobo1 on 21 May, 2020 04:47 PM

    sobo1's Avatar

    Has everyone that attempted to fix this by going to the Citi web site and then gone through the process of removing access and then enabling access to MD been successful? It seems that some were- just not sure of others tried it and were not successful? I would prefer to wait this out until this is resolved rather than go through that process- that process reminds me of going to the dentist. :-(

  11. 71 Posted by TonyRI on 21 May, 2020 04:54 PM

    TonyRI's Avatar

    I tried. I disabled Moneydance Third Party Access from the Citi site, then tried to re-add it. Started the 10 minute timer, but when I tried to establish a new connection with Citi, I got the exact same 2000 error. I had been thinking of just leaving things as they were, but I tired the possible remedy to no avail.

  12. 72 Posted by kn855 on 21 May, 2020 05:00 PM

    kn855's Avatar

    Works fine in Quicken for Mac.

    Removing access on Citi website (Manage Desktop Apps) and re-adding didn’t help:
    1. With the current ‘Citi Cards’ profile, connecting doesn’t register MD as an app.
    2. With a new connection based on Quicken’s connection profile, it gets registered as ‘Quicken Windows’ but the downloads still fail with the same error.

  13. 73 Posted by Margie on 21 May, 2020 05:27 PM

    Margie's Avatar

    Same issue for me on May 21, unable to connect for the past 4 days or so. I tried deleting connections in MD and also on the Citi website, closing MD, then started the 10-minute connection time on Citi and tried adding a new connection in MD. Same Error 2000 message after I enter my login info. The request never seems to make it to Citi, as they are not registering any incoming request that I can see. Hoping someone can figure out a solution.

  14. 74 Posted by kwbear on 21 May, 2020 05:35 PM

    kwbear's Avatar

    I’m using Quicken for Mac 5.15.3. Citibank works fine. Mac O/S 10.15.4. HTH.

  15. 75 Posted by TonyRI on 21 May, 2020 05:36 PM

    TonyRI's Avatar

    Just realized you said Quicken for Mac, which may use web connect vs direct connect? Not sure.

  16. 76 Posted by andyschmid on 21 May, 2020 05:46 PM

    andyschmid's Avatar

    Folks, Quicken uses a different protocol for downloading transactions. OFX (direct connect) is quickly being deprecated by financial institutions in favor of web connect (which moneydance cannot support).

    This is likely not a problem with moneydance, but an issue with CitiBank and their direct connect support. I'm guessing they either:

    A) Don't know about the failure
    B) Don't care it doesn't work
    C) Are phasing out support for it.

  17. 77 Posted by kn855 on 21 May, 2020 06:47 PM

    kn855's Avatar

    Quicken Mac (Version 5.15.3) uses Direct Connect for Citi Cards.

    So, it looks like it is easy fix from IK's side (with the updated connection info etc.)

  18. 78 Posted by layer on 22 May, 2020 03:51 AM

    layer's Avatar

    This is troubling. Like they don't know about this thread:

  19. 79 Posted by cscj01 on 22 May, 2020 05:50 AM

    cscj01's Avatar

    Same issue as everyone else. MD version is 219.3 (1880)

    Cannot get a connection for last 4 days.

  20. Support Staff 80 Posted by Maddy on 22 May, 2020 09:37 AM

    Maddy's Avatar

    @Layer

    The reply you are reporting is related to these steps:

    1. Go to Citibank CC account and chose "Set up Online Banking"
    2. Choose "New Connection" and then select "Citi Cards"
    3. Going through the setup you'll be prompted to visit https://citi.com/datamanagement
    4. Make sure you are logged out of Citibank before going to that URL.

    5. Click on ADD ACCESS and followed steps 1 & 2 above.

    They seem to have worked for some customers and not for others, unfortunately. As we cannot exclude it will work, I believe this is the reason why it was suggested there. That being said, please stay assured that our development team is working really hard to get to the root of this problem and to find a "final" solution.

    We perfectly understand your frustration and we are doing everything possible on our end.

    We will keep you updated on any improvements.

    Thank you for your understanding and cooperation.

    --
    Maddy, Infinite Kind Support

  21. 81 Posted by singerdf on 22 May, 2020 10:17 AM

    singerdf's Avatar

    I was never prompted for the citi website. The process could certainly use help

    Please consider the environment before printing this e-mail

  22. 82 Posted by jc4mee on 22 May, 2020 11:05 AM

    jc4mee's Avatar

    I tried the steps several times with no success. I was never prompted to
    go to the Citi Cards web site, but I did go to the site and permitted
    authorization, logged out and tried again, still with no success. I tried
    logged in to the Citi site and logged out of the Citi site all with the
    same results.

  23. 83 Posted by JD on 22 May, 2020 01:04 PM

    JD's Avatar

    I'm in the same boat as the last few posts - I'm never prompted to go to the Citi Cards site to do any setup and following that link from Post 80 just took me to the main Citi page. Is there an alternate solution that has been/is being developed?

    For reference, I'm on a Windows 10 machine using MD 2019.3 (1880) with Chrome as my browser.

  24. 84 Posted by dorph on 22 May, 2020 04:10 PM

    dorph's Avatar

    Same problem here. Running latest moneydance version. Last time this worked was May 14th and I've had Citi account set up to download to MD for 5+ years. This is definitely a connection problem and not my setup.

    Infinitekind PLEASE ADDRESS THIS.

  25. 85 Posted by djraysr on 22 May, 2020 04:26 PM

    djraysr's Avatar

    I am having the same issue with downloading Citi transactions. Was working fine until a few days ago. There is a second issue that has occurred periodically over the years. When one of the institutions starts having a problem downloading transactions, I would select the account and go to "online/setup online banking". That would cause the popup as shown in picture 1. From there I would click on "disable" and continue on with reestablishing online banking. The problem I am seeing now is with trying to reestablish the Citi account for downloads, I never get picture 1. Instead, "online/setup online banking" goes straight to the popup shown in picture 2. So I never get the chance to disable the current online banking so trying to reestablish it is a dead end. As I said, I have seen this in the past but somehow managed to work around it over time. Any help would be appreciated. Thanks.

  26. 86 Posted by jcole01108 on 22 May, 2020 06:17 PM

    jcole01108's Avatar

    Same issue. As a new user, in order to set up this account, I used the process Maddy describes. It worked for a month, but today I got the error everyone is describing.

    The Citibank account lists MoneyDance 2019 under the Manage Your Apps tab. MONEYDANCE is listed as having access with the last access on 5/16/20.

    There is also a Sharing Your Account Information account access tab which according to the Citibank website is only for Quicken and Quickbooks and states that I have not authorized any apps or website access and does not give me any way to add or edit what is listed.

  27. 87 Posted by James Tatsuda on 24 May, 2020 02:53 PM

    James Tatsuda's Avatar

    Add me to the list of users who are having the MoneyDance transaction download problem with Citi. Mine also stopped working around the middle of May.

  28. 88 Posted by Sean N on 24 May, 2020 03:50 PM

    Sean N's Avatar

    I just want to note that I've having the same issue on both of my Citi credit card accounts now as well. I see there are other open threads and took note that two are shown as "assigned," to include this one I believe, but these two were started last month. I also see newer threads that were started more recently. Citi shows my "last access time" for MD was on 13 May, though I've tried to connect over the past several days with negative results, so the problem showed up for me sometime since 13 May 2020. I'm on MD version 2019.4 (1903).

  29. 89 Posted by dm_corsa on 24 May, 2020 04:20 PM

    dm_corsa's Avatar

    Same issue as everyone else, error 2000 trying to download Citi Cards data. Was working fine until about two weeks ago. Running on MoneyDance Version 2019.3 (1880) on Linux

  30. 90 Posted by anthonywarnold on 24 May, 2020 04:44 PM

    anthonywarnold's Avatar

    I too am having same issue. MD integration with my Citi Card has worked for years. Started getting the Server error 2000 a couple of weeks ago. I tried all the suggested fixes didn't help. Contacted Citi tech support and they tried a few things saying it looked like the 3rd party has a software issue. Citibank did kindly put in a tech research ticket to help see if more could be done, but all evidence points to MD. Something changed somewhere. I don't think MD has had any recent updates, so likely something in their code/interface is not compatible with security/network enhancement on Citi Card side. Speculation, but something changed somewhere. I do wish MD would be more transparent on this one and tell us it will be resolved in the next update. We can limp along with manual download, but don't leave us in the dark chasing our tails please. FYI running MD 2019.3 (1880) on MAC. This is the latest release.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac