USAA Script to fix the broken download issue

Need to reconnect to USAA? I have written a (run one-time only) script to make USAA download to Moneydance work again. All it does it fix your connection profile. You simply run once, and then use standard Moneydance. It's not needed again.

This is now the IK recommended fix as they are working on 'medium and long-term' improvements to ofx connections

You must be on MD version 2019.4 (build 1904) or newer (if older, you must upgrade, else usaa will never work again).

[@@ UPDATE Oct 2021: This script is now built into the Toolbox extension (MD2021 onwards) under the Online Banking menu and it also works with MD2022 too. Further, we have worked with Moneydance so that once you have ‘primed’ MD with your USAA specific ClientUID number(s), the standard Moneydance Online Setup will work. Further again, there is now an even simpler way to get the connection working (which we haven’t documented: In Toolbox run the USAA ‘Prime’ option and then just use standard MD Online Setup. Lastly, if you need to get multiple UserIDs working, then Toolbox / Online Banking / OFX Authentication / Edit Multiple UserIds. NOTE: if you still just want the script, it’s still available, read on…. @@]

Following these simple, but complete, PDF instructions will make USAA download to your Moneydance file.

My python script creates a new USAA profile in Moneydance to replace the broken USAA profile. It has been used since Feb 23 by more than 100+ users successfully 😃

This script will allow you to download USAA transactions again. It isn't rocket science, really. You don't have to wait for IK/MD to fix the problem, nor will it stop you from embracing the Moneydance fix if/when it happens. I just fix the connection profile.

NOTE: usaa have changed their download data (content, format). If you get some data duplication afterwards, this is NOTHING to do with the script, it's what usaa are now sending. You simply need to do a one-time cleanup, keep the new data, and that's it.

DISCLAIMER: I have no affiliation with Moneydance. It's entirely possible that this won't work for you. Pretty much the worst that can happen is that your bank logon / service profile won't work - but then it's not working anyway.. You can always just delete the profile and start again, if you wish.

PLEASE ALWAYS BACKUP YOUR DATA FIRST!

The first thing to do is read the walk through PDF guide: ofx_create_new_usaa_bank_custom_profile.pdf

The latest PDF guide (now version 8a) is always here:
[https://github.com/yogi1967/MoneydancePythonScripts/raw/master/sour...]

The latest zip file containing the script to fix USAA/Moneydance is at: [https://github.com/yogi1967/MoneydancePythonScripts/raw/master/usef...]

FYI - When you click these links, you may see a blank screen (depending on your browser) and the file(s) will auto download to your downloads folder

You need to unzip this file. The script is called: ofx_create_new_usaa_bank_custom_profile.py

Quick Details:

  • Make a backup first.
  • Read the instructions.
  • Once you run the script, Moneydance takes over with the new profile.

PS - If you get issues ensure a) you are connecting from a USA IP; and that any PiHole, Blockers etc are not getting in the way..

If you have problems, post - We love to solve problems.

CREDITS and thanks: @dtd and @hleofxquotes

I am not support, just a fellow user and creator of the very free and most-excellent Toolbox 🧰 extension for Moneydance.
The latest useful_scripts.zip package and Toolbox are on my site: [https://yogi1967.github.io/MoneydancePythonScripts/]

Showing page 15 out of 22. View the first page

  1. 421 Posted by stevescom on 15 Apr, 2021 02:22 PM

    stevescom's Avatar

    Great news! I have all the accounts under my USAA AccessID downloaded. Problem is, my wife has a separate USAA# and AccessID for her credit card. Her clientUid is the same as mine, but she has a different AccessID and PIN. I ran the script and selected YES – PRIME SECOND ACCOUNT. I primed her second account like the first with same clientUID, different AccessID.

    All that seemed to go fine.
    The problem is that when I follow the dialog under "Setup Online Banking" for her credit card, the AccessID is primed with my ID. I change it to her AccessID, and then I get the 2000 error. If I continue, her account is not in the dropdown list (which are the accounts under my ID). Any suggestions?

    Looks like the same issue as @gnuite on Mar 5...it's not clear how he/she got theirs working..

    I'm very happy I can download again!! I'm very close to getting it all working again.

    You guys rock!

  2. 422 Posted by Stuart Beesley ... on 15 Apr, 2021 02:26 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @Steve McGahee 😃 +1 (=57)

  3. 423 Posted by stevescom on 15 Apr, 2021 07:18 PM

    stevescom's Avatar

    I still need help with getting the second account to work. Any thoughts?

  4. 424 Posted by dtd on 15 Apr, 2021 11:30 PM

    dtd's Avatar

    @stevescom - Congrats on at least getting this far. Stuart is based in the UK, so should be asleep now. I doubt I can help, but I've tested enough to at least ask pertinent questions.

    Based on your messages:
    1) Your accounts are now downloading fine, and if you do rerun the script, you realize you have to re-enter your credentials again (as a tester, that got old for me quickly)
    2) I note you use the word PIN for the new password - are you entering your spouse's new userid and password vs. the PIN?
    3) At this point, given YOUR accounts are working - I think the 2000 error is about credentials vs. a real connection problem (I THINK - that's where Stuart can help more) - and why I pegged on PIN - make sure the userid/password for your spouse is correct before connecting.

    Other than that, I'm sure Stuart will work with you once he is awake... ;)

  5. 425 Posted by stevescom on 16 Apr, 2021 01:17 PM

    stevescom's Avatar

    When I went onto USAA to create the Quicken login, USAA refers to the ID and password as "Access ID" and "Access PIN". Those are distinct for me and my wife based on the fact that she has a different logon (and different USAA member number) to USAA. So, yes, I can download everything under my ID fine, but when I use her ID, it comes back with the 2000 error. And this is after running the script (a few times) and setting up (priming) both Access IDs.

  6. 426 Posted by dtd on 16 Apr, 2021 05:04 PM

    dtd's Avatar

    @stevescom - I think you have Stuart's email, you should probably move to email for further diagnosis. If you don't have his email, send a quick email to dan at tbg3 dot com and I can share his email with you.

    From Stuart:
    Can you do this.... help>open console. Keep console open. Download again. Paste the console into a text file. Review the text file and redact anything sensitive. (Send the file to me via email.)

    EDIT - from dtd - just a shot in the dark as I have had trouble with multiple login ids in the past (not USAA). In a test database, or if you do a backup (just in case), set up a brand new empty account with the same type as one of your spousal accounts.With this empty account, set up online banking, type in your spouse Accessid/AccessPin and see if you get a 2000 error. (You can delete the empty account once finished)

    EDIT 2 - went back to look at the gnuite part, early March. Here's the final post where success was (mostly) achieved: It may help.

    https://infinitekind.tenderapp.com/discussions/online-banking/18363-usaa-scripts-to-fix-the-broken-download-issue/page/5#comment_49074763

  7. 427 Posted by Chuck Whittenbe... on 16 Apr, 2021 05:09 PM

    Chuck Whittenberg's Avatar

    I just followed your latest protocol and got the following SyntaxError in the log on the Money Bot Screen log:

    Beginning file /Users/charleswhittenberg/Downloads/useful_scripts-2/ofx_create_new_usaa_bank_custom_profile.pdf at Fri Apr 16 12:00:44 CDT 2021
    Error running script: SyntaxError: Non-ASCII character in file '/Users/charleswhittenberg/Downloads/useful_scripts-2/ofx_create_new_usaa_bank_custom_profile.pdf', but no encoding declared; see http://www.python.org/peps/pep-0263.html for details
      File "<string>", line None
    SyntaxError: Non-ASCII character in file '/Users/charleswhittenberg/Downloads/useful_scripts-2/ofx_create_new_usaa_bank_custom_profile.pdf', but no encoding declared; see http://www.python.org/peps/pep-0263.html for details
    Beginning snippet at Fri Apr 16 12:00:49 CDT 2021
    Finished running snippet normally at Fri Apr 16 12:00:49 CDT 2021

    Any idea what I have done wrong or how do I fix this?

    Thanks for all of your help

    Chuck

  8. 428 Posted by dtd on 16 Apr, 2021 05:20 PM

    dtd's Avatar

    @chuck - It looks like you are trying to "run" the documentation (I note the .pdf in the file name), you need to run the script - (ends in .py)

    Hope that helps.

  9. 429 Posted by Stuart Beesley ... on 16 Apr, 2021 05:34 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @Chuck Whittenberg - you are certainly not running the right file. Please download the ZIP, unzip, and then run the file with the .py extension

  10. 430 Posted by Chuck Whittenbe... on 16 Apr, 2021 05:52 PM

    Chuck Whittenberg's Avatar

    Too simple! Thanks.

  11. 431 Posted by Stuart Beesley ... on 16 Apr, 2021 06:47 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    .

  12. 432 Posted by Stuart Beesley ... on 17 Apr, 2021 07:18 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @Chuck. Error 2003 is mentioned in the PDF (did you see that?). It's possible that you are connected but the account number is wrong... Are you trying to connect a Credit card. Once the script has run, and you have restarted, after the 2003 error, try this. Then do the standard Online setup and see if you can see the account(s)? Do these accounts have a recent transaction? If not, they won't appear? Failing this..... HELP>Open Console. Keep console open. Then try the download again. Post the console output here (you might want to redact personal info first)...

  13. 433 Posted by Chuck Whittenbe... on 17 Apr, 2021 07:42 PM

    Chuck Whittenberg's Avatar

    Stuart, yes, I did see the PDF note defining what the 2003 code mean, that is why I went through the entire Script process today after I specifically reconfirmed the various account numbers.

    I studying the Bot output, I note that the system is not set to store passwords, I selected a single account, and “
    >
    > Found USAA service - to delete: USAA Custom Profile (ofx_create_new_usaa_bank_profile_custom.py)
    >
    I suspect deleting or replacing the USAA Custom Profile is the issue because it comes up in conjunction with the Error Code 2003 citation:
    "Bank Name: USAA Custom Profile (ofx_create_new_usaa_bank_profile_custom.py)” and should be set to USAA Federal Savings Bank.

    How do we resolve this?

    Chuck

  14. 434 Posted by dtd on 17 Apr, 2021 07:46 PM

    dtd's Avatar

    @Chuck - you have successfully run the script and have successfully connected to USAA. You should have version 7f of the documentation. Here is part of the document:

    2003. Account not found. This is your bank telling you that it could not find the account you specified. You have successfully connected! We discuss Dealing with Credit Card numbers later, by looking at your account numbers and other items.

    Have you read the Dealing with Credit Card numbers section? USAA changed the credit cards and most do not match. You seem to also have trouble with checking, but you would try to deal with that the same way as a credit card. (PAGE 7 of documentation)

    You do NOT need to run the script again. You have a successful connection. You have to match the numbers USAA reports to what you THINK your accounts are. Did you see the part about nicknaming accounts to help out? (Optional, but you appear to be having problems in the Dealing with Credit Cards section.)

    You should NOT need to revisit the script. You have successfully connected. You just have to figure out which accounts go where.

    Hope that helps.

  15. 435 Posted by dtd on 17 Apr, 2021 07:51 PM

    dtd's Avatar

    "after I specifically reconfirmed the various account numbers. "

    Reconfirming the various account numbers is irrelevant. As page 7 - Dealing with Credit Cards states - most of the account numbers within USAA (especially credit cards) have been changed and you will have to rematch them within Moneydance.

  16. 436 Posted by dtd on 17 Apr, 2021 07:59 PM

    dtd's Avatar

    @chuck - you may also want to edit out the long moneybot console log, as I see some information you should have, but did not redact. Probably better just to delete that part of the message, as Stuart and I have now looked it over.

  17. 437 Posted by Stuart Beesley ... on 17 Apr, 2021 08:57 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @chuck. As I mentioned. Please help/open console. Keep console open. Download again. Get the 2003 error. Post the (redacted) console here (not moneybot console. Do not rerun script).

  18. 438 Posted by Chuck Whittenbe... on 17 Apr, 2021 09:44 PM

    Chuck Whittenberg's Avatar

    Stuart, I did read the PDF and the meaning of Code 2003. What is happening is not isolated to just credit cards, but is also applicable to my checking account as well. The Bot indicates that the Bank Name is not being changed from
    >
    > Bank Name: USAA Custom Profile (ofx_create_new_usaa_bank_profile_custom.py)
    >
    To USAA Federal Savings Bank. At this point, changing that Bank Name field is my issue for credit cards and checking.

    Any ideas? I have carefully reconfirmed that I am loading the correct IDs as your PDF instructions indicate that I must do.

    Chuck Whittenberg

  19. 439 Posted by Stuart Beesley ... on 17 Apr, 2021 09:50 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @Chuck. Your interpretation of the moneybot console is wrong and ‘USAA Custom Profile’ is irrelevant to your issue. Respectfully, for the third time of asking.... please close moneybot and do not look at that again. Do menu Help/Open Console. Keep console open. Try the download again. Get the 2003 error. Then post a redacted console output back here. If you are not willing to do this then I cannot help you further. Up to you.

  20. 440 Posted by dtd on 17 Apr, 2021 10:14 PM

    dtd's Avatar

    @Chuck, similarly, and also respectfully, for the third time, I ask that you read "Dealing with Credit Card Numbers" in the documentation. (I'm the person who wrote the documentation)

    Your understanding of that section is the only way I can help you as well.

  21. 441 Posted by brianb on 18 Apr, 2021 04:35 PM

    brianb's Avatar

    @Stuart Beesley @dtd @hleofxquotes: You Guys Rock!

  22. 442 Posted by Stuart Beesley ... on 18 Apr, 2021 04:38 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @brianb 😃 +1 (=58)

  23. 443 Posted by Chuck Whittenbe... on 18 Apr, 2021 05:56 PM

    Chuck Whittenberg's Avatar

    Stuart, I have success to report: my Credit Card is now downloading! Indeed, I have a second card and updated its info according to your PDF and that is working as well.Thank you because that is a huge help. Also, I have no more Code 2003 Messages.

    My remaining issue is that the Checking Account still will not display the various transactions. By reading the Console Messages, I can see that Moneydance has accessed multiple Checking transactions, but none of them are actually being displayed when I select the Checking Account — Personal Finances view. Would you like for me to send the Redacted Console Messages to you for reference?

    Thanks for sticking with me!

    Chuck

  24. 444 Posted by dtd on 18 Apr, 2021 06:01 PM

    dtd's Avatar

    @Chuck - that's fantastic to hear. that things are working.

    My one question before you move to Stuart helping, is did you do the same thing with the checking account that you did with the credit cards (i.e. go to online banking,get the list of accounts, and see if your checking account is a choice)?

    If it is not there at all, that would be good info to have as well.

  25. 445 Posted by Chuck Whittenbe... on 18 Apr, 2021 06:43 PM

    Chuck Whittenberg's Avatar

    Yes, I believe so. When I go to Online, and select “Download all accounts” the script runs and the system attempts Checking and at the bottom of the screen says 9 transactions were downloaded, but they do not show up on my list of transactions. The script then goes in sequence to the two Credit Cards and successfully downloads them.

    I have gone to Account and then Edit Account and the script then displays Checking Account. I click Ok and the screen closes — does not offer either Credit Card.

    I hope that this helps.

    Chuck

  26. 446 Posted by Stuart Beesley ... on 18 Apr, 2021 06:54 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @Chuck 😃 +1 (=59). Yes, please email me your console output. So Help>Console Window, then download your checking account, then send me that output.

  27. 447 Posted by dtd on 18 Apr, 2021 06:55 PM

    dtd's Avatar

    Ok, if it says 9 transactions downloaded, then see if Stuart can help.

    The only thing I can think of (outside of looking at the logs) is maybe you have a filter on, or the personal finances view is not set to sort by date.

    So, other than that, move to Stuart.

    EDIT: I do notice you keep saying "the script" as to actions in Moneydance. The script did one thing, and then is no longer in the picture - create a new profile that works. What you are dealing with now is "basic Moneydance". The script is no longer involved with anything. (and one reason you've been +1 by Stuart. The script worked. Now he's just trying to be helpful. )

  28. 448 Posted by tahartman on 18 Apr, 2021 08:40 PM

    tahartman's Avatar

    Just wanted to say I installed the script in March for two USAA credit cards and it works perfectly for me each week. Thank you Stuart!!

  29. 449 Posted by Stuart Beesley ... on 18 Apr, 2021 08:57 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    @tahartman 😃 +1 (=60)

  30. 450 Posted by tahartman on 18 Apr, 2021 09:14 PM

    tahartman's Avatar

    Actually, you counted me in early April as
    #52! It’s worked perfectly since then.

    Sent from my iPhone

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac