USAA Script to fix the broken download issue

Need to reconnect to USAA? I have written a (run one-time only) script to make USAA download to Moneydance work again. All it does it fix your connection profile. You simply run once, and then use standard Moneydance. It's not needed again.

This is now the IK recommended fix as they are working on 'medium and long-term' improvements to ofx connections

You must be on MD version 2019.4 (build 1904) or newer (if older, you must upgrade, else usaa will never work again).

[@@ UPDATE Oct 2021: This script is now built into the Toolbox extension (MD2021 onwards) under the Online Banking menu and it also works with MD2022 too. Further, we have worked with Moneydance so that once you have ‘primed’ MD with your USAA specific ClientUID number(s), the standard Moneydance Online Setup will work. Further again, there is now an even simpler way to get the connection working (which we haven’t documented: In Toolbox run the USAA ‘Prime’ option and then just use standard MD Online Setup. Lastly, if you need to get multiple UserIDs working, then Toolbox / Online Banking / OFX Authentication / Edit Multiple UserIds. NOTE: if you still just want the script, it’s still available, read on…. @@]

Following these simple, but complete, PDF instructions will make USAA download to your Moneydance file.

My python script creates a new USAA profile in Moneydance to replace the broken USAA profile. It has been used since Feb 23 by more than 100+ users successfully 😃

This script will allow you to download USAA transactions again. It isn't rocket science, really. You don't have to wait for IK/MD to fix the problem, nor will it stop you from embracing the Moneydance fix if/when it happens. I just fix the connection profile.

NOTE: usaa have changed their download data (content, format). If you get some data duplication afterwards, this is NOTHING to do with the script, it's what usaa are now sending. You simply need to do a one-time cleanup, keep the new data, and that's it.

DISCLAIMER: I have no affiliation with Moneydance. It's entirely possible that this won't work for you. Pretty much the worst that can happen is that your bank logon / service profile won't work - but then it's not working anyway.. You can always just delete the profile and start again, if you wish.

PLEASE ALWAYS BACKUP YOUR DATA FIRST!

The first thing to do is read the walk through PDF guide: ofx_create_new_usaa_bank_custom_profile.pdf

The latest PDF guide (now version 8a) is always here:
[https://github.com/yogi1967/MoneydancePythonScripts/raw/master/sour...]

The latest zip file containing the script to fix USAA/Moneydance is at: [https://github.com/yogi1967/MoneydancePythonScripts/raw/master/usef...]

FYI - When you click these links, you may see a blank screen (depending on your browser) and the file(s) will auto download to your downloads folder

You need to unzip this file. The script is called: ofx_create_new_usaa_bank_custom_profile.py

Quick Details:

  • Make a backup first.
  • Read the instructions.
  • Once you run the script, Moneydance takes over with the new profile.

PS - If you get issues ensure a) you are connecting from a USA IP; and that any PiHole, Blockers etc are not getting in the way..

If you have problems, post - We love to solve problems.

CREDITS and thanks: @dtd and @hleofxquotes

I am not support, just a fellow user and creator of the very free and most-excellent Toolbox 🧰 extension for Moneydance.
The latest useful_scripts.zip package and Toolbox are on my site: [https://yogi1967.github.io/MoneydancePythonScripts/]

Showing page 19 out of 22. View the first page

  1. 541 Posted by dtd on 24 May, 2021 06:48 PM

    dtd's Avatar

    A couple more questions, as this may need to go into the documentation.

    Can you verify the accounts you are trying to set up were working with USAA before January 26th, or is this a new online setup (explaining the lack of the "Change" window)

    If you run the script again, can you juggle it up a little and put in a different account or a different credit card? Maybe even set up the script to use your husband's credentials and one his accounts?

    I think the script is creating a working profile; but you are encountering difficulties in trying to link the other accounts, and only the ones the script sets up work for you. Are all the accounts in Moneydance already and you just have to relink them?

    Just trying to get a feel for your overall situation, and where the disconnect in making this work for all your accounts might be (and yes it is complicated by two logins, which is why I suggest going back to one login, and making all accounts connected to that login work for you as a first step, before complexing it up again.

  2. 542 Posted by Stuart Beesley ... on 25 May, 2021 03:15 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    All,

    We had a report that USAA stopped working with MD2021.1 build 3069. So, is anyone else out there running MD2021.1 build 3069 and still successfully connecting to USAA..? Pls respond..? Thx

  3. 543 Posted by billpiper on 25 May, 2021 03:39 PM

    billpiper's Avatar

    Connected this am. No problems

  4. 544 Posted by Stephen Skidd on 25 May, 2021 03:46 PM

    Stephen Skidd's Avatar

    Stuart - I connected yesterday and just now with no problems. All accounts
    downloaded. Thanks for your diligence in helping everyone manage their USAA
    accounts!
    All - MD2021.1 build 3069 is the latest version.
    Steve

  5. 545 Posted by Stuart Beesley ... on 25 May, 2021 03:50 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    We found the problem. Note to all in case this happens to other.

    If you see this error in the console log:

    java.lang.IllegalArgumentException: type DIRECT is not compatible with address 127.0.0.1/:8866 at java.base/java.net.Proxy.(Unknown Source)
    

    Then check your MD Preferences/Network settings. If Use Proxy is NOT set, but you see data in the Host and Port fields (greyed out), then you need to enable the proxy, delete the fields, and then disable the proxy. Then try again....

    Do let us know if you use this trick.

    @dtd, for noting.....

  6. 546 Posted by hbr245b on 25 May, 2021 04:12 PM

    hbr245b's Avatar

    Moneydance 2021.1 (3069) - I successfully downloaded transactions from USAA
    earlier today (Tue 25 May 2021)

  7. 547 Posted by docrobc on 28 May, 2021 02:20 AM

    docrobc's Avatar

    Updated MD and then followed your instructions. Worked great. Thanks for all your hard work!

  8. 548 Posted by dtd on 28 May, 2021 03:54 AM

    dtd's Avatar

    Beating Stuart to the punch

    @docrobc :) - +1 (=64)

    And Stuart, given the ones who have come out successful over the last month without posting here, I'm going to declare:

    @allthosefolks :) - +6 (=70)

    and I think I'm being quite conservative. Don't argue with me. :)
    Remember I'm your document writer. :) :) :)

  9. 549 Posted by jynxnyx on 06 Jun, 2021 02:35 PM

    jynxnyx's Avatar

    When trying to run script a question comes up asking "Do you have multiple different credentials where you wish to "prime" the default `UUID into (Root's) profile? this is not mentioned in the instructions.

  10. 550 Posted by Stuart Beesley ... on 06 Jun, 2021 02:41 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    It is... but if you only have one login to the bank then just say no.

    (Not support, just a fellow user)

  11. 551 Posted by jynxnyx on 06 Jun, 2021 02:45 PM

    jynxnyx's Avatar

    Do I run the script for each account I have with USAA?

  12. 552 Posted by jynxnyx on 06 Jun, 2021 03:29 PM

    jynxnyx's Avatar

    Getting error 2000 and went to the console window, but do not see error messages

    Starting Moneydance 2021.1 (3069) at Sun Jun 06 11:24:20 EDT 2021
    Settings Folder: /xxxxxContainers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance
    OS: Mac OS X 10.15.7 x86_64
    Java: 15.0.1 (AdoptOpenJDK)
    Is in sandbox: true; restricted file access: false
    Library path: /Applications/Moneydance.app/xxxxxxxxPlugIns/vm.jdk/Contents/Home/lib
    Initializing fonts:
      default: [[SF Pro Display, SF Display, Helvetica Neue, Helvetica, Lucida Grande, Dialog]]
      printing: [[Helvetica, SF Pro Display, SF Display, Helvetica Neue, Helvetica, Lucida Grande, Dialog]]
      monospaced: [[Gill Sans, Menlo, Monaco, Monospaced]]
      coding: [[Hack, Monospaced]]
    fonts resolved:
     default: SF Pro Display:13.0:style0
     mono: Gill Sans:13.0:style0
     coding: Hack:13.0:style0
     print: Helvetica:12.0:style0
     header: SF Pro Display:15.0:style0
     register: SF Pro Display:12.0:style0
     reportTitle: SF Pro Display:32.0:style0
     calendarTitle: SF Pro Display:12.0:style0
     reportHeader: SF Pro Display:11.0:style0
     detailTitle: SF Pro Display:15.0:style0
    detected system appearance: org.violetlib.vappearances.VAppearanceImpl@5bda8e08
    detected system appearance: org.violetlib.vappearances.VAppearanceImpl@5bda8e08
    Setting look and feel class to org.violetlib.aqua.AquaLookAndFeel
    Unable to map image: java.lang.IllegalArgumentException: argument type mismatch
    opening last file: Personal Finances v3
    loading dataset: /xxxxxxx/Containers/com.infinitekind.MoneydanceOSX/Data/Documents/xxxxxx.moneydance
    creatingURLStreamHandler for protocol 'http'
    loading with 128 bit encryption key
    reading trunk data tiksync/trunk
    trunk data loaded (0.035 seconds), checking for incremental updates
    loading un-synced txn files...
    loading synced txn files...
    replacing root: null () with new root: Personal Finances v3 (xxxxxxxxxxxx
    VAQUA: system appearance did change
    detected system appearance: org.violetlib.vappearances.VAppearanceImpl@xxxxx
    VAQUA: applying updated theme: default
    detected system appearance: org.violetlib.vappearances.VAppearanceImplxxxxxx
    Setting look and feel class to org.violetlib.aqua.AquaLookAndFeel
    Java version: 1500001
    creatingURLStreamHandler for protocol 'https'
    Unrecognized cookie parameter: SameSite -> None
    loaded cookie from https://df3cx-services.1fsapi.com/casm/usaa/access.ofx : visid_incap_xxxxxxxx=aJH2jVIvSjyEw88gNy3Qi4PovGAAAAAAQUIPAAAAAACKyMA9gYs5XxV23y5RHVmF; expires=Mon, 06 Jun 2022 09:49:49 GMT; HttpOnly; path=/; Domain=.1fsapi.com; Secure; SameSite=None -> visid_incap_xxxxxx=aJH2jVIvSjyEw88gNy3Qi4PovGAAAAAAQUIPAAAAAACKyMA9gYs5XxV23y5RHVmF; Mon, 06-Jun-2022 05:49:49 EDT; path=%2F; domain=.1fsapi.com; secure
    Unrecognized cookie parameter: SameSite -> None
    loaded cookie from https://df3cx-services.1fsapi.com/casm/usaa/access.ofx : nlbi_xxxxxxx=DTIxxxxxxpath=/; Domain=.1fsapi.com; Secure; SameSite=None -> nlbi_xxxxxxx=DTIxxxxxxxxxxH; path=%2F; domain=.1fsapi.com; secure
    Unrecognized cookie parameter: SameSite -> None
    loaded cookie from https://df3cx-services.1fsapi.com/casm/usaa/access.ofx : incap_ses_1246_xxxxxxxxghxnXLwWpneF6Kw==; path=/; Domain=.1fsapi.com; Secure; SameSite=None -> incap_ses_xxxxxxxx=qgBiIFLPO3vUsOq2+bdKEbfovGAAAAAA29ClxPDghxnXLwWpneF6Kw==; path=%2F; domain=.1fsapi.com; secure

  13. 553 Posted by Stuart Beesley ... on 06 Jun, 2021 03:35 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    Nope. You run once only. Just give it one account number. Then download. If that works then use the MD online menu, as per the pdf, to link further accounts.

  14. 554 Posted by Stuart Beesley ... on 06 Jun, 2021 03:39 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    You haven’t posted the whole log?

    Some errors we’ve seen:
    2000. Connection error. Check the console log for details.
    If you get connection problems, please try disabling proxies, VPNs, Pi-Hole, Browser blockers, DNS Sinkholes, Cookie blockers to eliminate these as potential problems.

    Menu help, show console. Keep console open. Run download again. Post whole (redacted) log.

  15. 555 Posted by jynxnyx on 06 Jun, 2021 04:58 PM

    jynxnyx's Avatar

    Have I just exposed sensitive information?

  16. 556 Posted by dtd on 06 Jun, 2021 05:05 PM

    dtd's Avatar

    The console log usually redacts things like passwords and such, but it does show things like where you tried to go, a few directory names, etc., so depending on what you consider sensitive the answer could go either way.

    Some people redact more items by opening up the console log in an editor and then they XXXXX out things they don't want people to see.

    In this particular case, I now know your xxxxxxx and yyyyyyy, but most people wouldn't worry about that. Otherwise, it mostly looks like info on that session.

    If you are concerned, you can edit the message and remove most of the text by being on the forum (if you are not already) vs. using email.

    just a user, hope that helps.

  17. 557 Posted by dtd on 06 Jun, 2021 05:12 PM

    dtd's Avatar

    Also, you mention the instructions, and what is or is not in it. That makes me think you are not using the latest version of the instructions, Version 8a, which can be found in the first message above here:

    The latest PDF guide (now version 8a) is always here:
    [find link above in first message...]

    I'll post the full link here as well, but I've found that doesn't always work...

    https://infinitekind.tenderapp.com/discussions/online-banking/18363/r?go=aHR0cHM6Ly9naXRodWIuY29tL3lvZ2kxOTY3L01vbmV5ZGFuY2VQeXRob25TY3JpcHRzL3Jhdy9tYXN0ZXIvc291cmNlL3VzZWZ1bF9zY3JpcHRzL29meF9jcmVhdGVfbmV3X3VzYWFfYmFua19jdXN0b21fcHJvZmlsZS5wZGY%3D

  18. 558 Posted by dtd on 06 Jun, 2021 06:13 PM

    dtd's Avatar

    @jynxnyx -I see you redacted some of the console log you posted, so I also redacted what I said I saw.

    Reread post 554, as Stuart felt you didn't post the information he needed to see.

    Alternatively, walk through the Version 8a document to see if there was something you didn't get to read when running the script, but I think Stuart already posted what you can do about 2000 errors.

  19. 559 Posted by jynxnyx on 06 Jun, 2021 06:25 PM

    jynxnyx's Avatar

    OFXHEADER:100
    DATA:OFXSGML
    VERSION:103
    SECURITY:NONE
    ENCODING:USASCII
    CHARSET:1252
    COMPRESSION:NONE
    OLDFILEUID:NONE
    NEWFILEUID:NONE




    xxxxxxxxxxx.008
    xxxxxxxx
    *
    N
    ENG

    USAA Federal Savings Bank
    xxxxx

    QMOFX
    2300
    xxxxxxxxxxxxxxxx




    1xxxxxxxxxxx-1


    xxxxxxxxxxx
    xxxxxxxxxxxx
    CHECKING


    Y




    <<<<77<<<<
    connecting to: https://df3cx-services.1fsapi.com/casm/usaa/access.ofx with method: POST
    Connecting with https headers:
    POST /casm/usaa/access.ofx HTTP/1.1
    Host: df3cx-services.1fsapi.com
    Content-Type: application/x-ofx
    Accept-Language: en-us
    Cookie: visid_incap_xxxxxxxx=7Vd/e4jFRF6zywazJcQo5xxxxxxxxxBDu/0bg1SIueM7m4j; nlbi_xxxxxxx=1+ZOcW8Scn2obhg4hXBnAwxxxxxxxxMioQiTBoCqg5EAWl; incap_ses_1246_xxxxxxxxxxxZZMYQJMfZThJBga3+bdKEdMKvWAAAAAA+KV4I6D92IMUoyzHke7Dnw==
    Date: Sun, 06 Jun 2021 13:50:51 EDT
    Accept: /
    User-Agent: InetClntApp/3.0
    Content-Length: 679
    Cache-Control: no-cache
    Connection: close

    ---end headers HTTP/1.1 200
    Date: Sun, 06 Jun 2021 17:50:51 GMT
    Content-Type: application/x-ofx
    Content-Length: 677
    Vary: Origin
    Vary: Access-Control-Request-Method
    Vary: Access-Control-Request-Headers
    X-Content-Type-Options: nosniff
    X-XSS-Protection: 1; mode=block
    Cache-Control: no-cache, no-store, max-age=0, must-revalidate
    Pragma: no-cache
    Expires: 0
    Strict-Transport-Security: max-age=31536000 ; includeSubDomains
    X-Frame-Options: DENY
    X-CDN: Imperva
    Connection: close
    X-Iinfo: 9-xxxxxxxx-xxxxxxxx1 NNNN CT(19 15 0) RT(xxxxxxxxx 41) q(0 0 0 -1) r(1 1) U6

    HTTP response headers:
    date: [Sun, 06 Jun 2021 17:50:51 GMT]
    content-length: [677]
    expires: [0]
    vary: [Access-Control-Request-Headers]
    x-frame-options: [DENY]
    x-cdn: [Imperva]
    x-iinfo: [9-xxxxxxx4-3xxxxxxxNNNN CT(19 15 0) RT(162xxxxxx864 41) q(0 0 0 -1) r(1 1) U6]
    pragma: [no-cache]
    strict-transport-security: [max-age=xxxxxxx ; includeSubDomains]
    x-content-type-options: [nosniff]
    x-xss-protection: [1; mode=block]
    content-type: [application/x-ofx]
    connection: [close]
    cache-control: [no-cache, no-store, max-age=0, must-revalidate]
    Reading message from https://df3cx-services.1fsapi.com/casm/usaa/access.ofx

    OFXHEADER:100
    DATA:OFXSGML
    VERSION:103
    SECURITY:NONE
    ENCODING:USASCII
    CHARSET:1252
    COMPRESSION:NONE
    OLDFILEUID:NONE
    NEWFILEUID:NONE

    2000ERRORWe're unable to complete your request. To download USAA account transactions into Quicken, you'll need to verify your information. Get Access ID and PIN here https://df3cx-services.1fsapi.com/casm/usaa/enrollxxxxxxxxxx.229[-4:EDT]ENGUSAA Federal Savings Bank67811xxxx-115500ERRORBEGINRESPONSE>>>>>




    2000
    ERROR
    We're unable to complete your request. To download USAA account transactions into Quicken, you'll need to verify your information. Get Access ID and PIN here https://df3cx-services.1fsapi.com/casm/usaa/enroll

    20210606125051.229[-4:EDT]
    ENG

    USAA Federal Savings Bank
    XXXXX





    1XXXX8-1

    15500
    ERROR



    <<<<<<<<ENDRESPONSE

  20. 560 Posted by Stuart Beesley ... on 06 Jun, 2021 06:31 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    It’s not clear why the error. Try another account? Have you typed the UID correctly. Have you enabled quicken access in the usaa logon?

  21. 561 Posted by dtd on 06 Jun, 2021 06:49 PM

    dtd's Avatar

    This appears as if you ARE connecting to USAA, but you are being rejected by them.

    When you went through the process of gathering the information for the script, did you get the access id and pin, or did you use your usaa login/password (forgive me for asking if the "computer is plugged in", but that's happened a few times) - also as Stuart says, make sure you did give access to USAA from Quicken. (Did you get an email saying that had happened?)

    I'd recommend starting over with the script (don't worry, doing it again just gets rid of the broken profile (again). Use the checking account number (10 numbers), (let's keep any credit card out of it for now, we can make that work later), and enter the data you gathered and have in a text file for the script with copy/paste vs. if you manually typed anything in.

    I'd recommend reading the documentation 8a as you do this, as it now has things in it about where people have inadvertently entered information incorrectly (things as simple as forgetting to clear out the field of the default info before putting in their personal info)

    Hope that helps.

  22. 562 Posted by andreablander on 07 Jun, 2021 12:46 AM

    andreablander's Avatar

    Hi @dtd. Responding (finally) to your post #540.

    I am answering the questions you asked, and numbering them to try to help make sure we are talking about the same thing.

    (1) When I follow your steps 1-7, here is what happens: everything goes as you state until step 6. When, in step 6, I click Next, I get the screenshot I posted earlier, NOT a window entitled "Online Banking Authentication" (with USAA userid listed). Instead of having moved to 'authentication,' the window asking for Customer ID still is titled "Online Banking Signup."

    (2) I am using MoneyDance Version 2021 (2006), I downloaded the free upgrade back in March when I first started trying to fix this.

    (3) When you start talking about making backup databases and new files, I want to make sure I understand what you mean. I have on two separate occasions "exported to backup" the file I am trying to use. Once before I started tying anything, and then again the last time I was working on this.

    So when you talk about making backups and working on a copy of the backup -- what do you mean? Should I open a new file in MD and then import my copy/renamed backup data into that new file? If not, what do you mean?

    (4) The file now has two logins -- mine and my husband's. The first time I ran the script, I used only my login, and I was able to get my individual accounts working, but nothing that was joint. I re-ran the script and I assumed that USAA has my husband as the main account holder, so I set it up with his credentials, and entered mine as the second set. But now, after using both sets of credentials, I can only get the joint checking account to download, and my personal account gets the error described in this message in (1).

    (5) As far as the accounts, I have a checking account and a credit card that are mine alone. We have one joint checking account, one joint credit card account. My husband has one credit card that is his alone. I changed the nicknames on everything so I could keep them straight.

    (6) For the one working account (now the joint checking account), when I go to "Set up Online Banking," I DO!! get the "change" option. Is that a good sign?

    I really appreciate your assistance!! Thank you!

  23. 563 Posted by dtd on 07 Jun, 2021 02:19 AM

    dtd's Avatar

    1) I suggest upgrading to 2021.1(3069) - it's a free upgrade if you are currently using (2006). What OS are you using (Mac, Windows, Linux)? I'm trying to get us both on the same page as to the software.

    2) Now that you've done the script a couple times, do you get "Setup Online Banking" vs. the Authentication page on the accounts that you had working on earlier script runs? (This is my biggest disconnect as to figuring out how to help you, as that stops everything.) I've even created a new thread asking others more knowledgeable than me when "Setup Online Banking" might happen.

    Did all of your accounts work before January 26th, or are you trying to set up online banking for some accounts versus restoring what worked before?

    (3) Do you have Version 8a of the documentation? It describes "testing" vs. operating on your live database (and then possibly restoring from backup if something goes terribly wrong). Given I want to have you "go wild", I wouldn't want you to do this on your actual data. So, (repeating the documentation) - one way to test is to make an export backup, then make a copy of the export backup and call it TESTUSAA. You then have 3 copies of your live database - Live, Export Backup, and a place to play (TESTUSAA).

    I'd have you open up TESTUSAA to do all the script runs, and maybe do some stuff you'd never do to the live database, because when this is figured out, you just throw TESTUSAA away.

    6) Yes, getting Change is good. Did you set up both the joint checking and credit card in the script? And what do you get as the "picklist" on this account as to which accounts you can choose?

    Remember that making two accounts work is very experimental by Stuart. One thing to try to do is to go back to only one account and redo the script twice, and seeing what we see (i.e. how many accounts can you see on your login, and how many accounts can you see on his..... then how many on both). You become a guinea pig, sorry, but we've only had three people work on this - on page (i don't remember) are a few messages from someone who had similar problems but finally made it work for two accounts. --- BUT, this is why we do all this on TESTUSAA vs, your live data, until we get it sussed out.

    Sorry, but two logins is just much harder. (Oh, I have two logins as well, but am blessed that all our accounts are joint accounts, and only need to use one login)

  24. 564 Posted by andreablander on 07 Jun, 2021 06:06 AM

    andreablander's Avatar

    Hi.

    (1) Did the upgrade.
    (2) After running the script the first time, with only my credentials, I got my personal checking and personal credit card to work. After running the script the second time with my husband's credentials too, I can ONLY get the authentication page on our joint checking account to work. For everything else (including joint credit card) I dead end at the "Set Up Online Banking" page asking for the mysterious Customer ID. Everything worked fine before January 26.
    (3) Yes, I have Documentation Version 8(a). Reading more carefully now I see the information about the test account. i will try this tomorrow.
    (6) I think I set up only the checking account in the script (the second time I ran it with both accounts), because I had done only my personal checking account the first time and had no trouble setting up my personal credit card. So I did the same the second time around. The strangest thing is that the picklist I get has only the old nicknames I had for my accounts, not the new ones I assigned them in USAA before running the script.

  25. 565 Posted by dtd on 07 Jun, 2021 12:20 PM

    dtd's Avatar

    Ok, I dreamed about this last night, but I can't get back to you until later today.

    So, don't do the testusaa thing yet, as I want to move to private message and work with you when you do that.

    So, some thoughts, and as always, create a backup first.

    Two things to try. Let's move away from the two logins totally for the moment, (i.e. in running the script yet again, say NO to two logins. Set up only your login, but put in both a checking and credit card to "kill two birds with one stone". See if you can get all the rest of your accounts to work. Then run the script, setting up only his login. See if you can get all his accounts to work.

    I look at this as you have four accounts, and he has three accounts, assuming the joint ones are showing in both accounts. With your login, try to get the four to work, either by entering them in Stuart's script (two at a time), or see if my suggestion below works.

    As for the mysterious screen I cannot reproduce (I'd hoped it would go away with the update), try using the Access ID (i.e. the new username given by USAA/Quicken) as the customer id. Also click "Online Banking" (one of the two checkboxes) and choose the appropriate account type. I'm assuming the account number you blanked out the number or the program did, but if not, you may need to enter the account number.

    Taking this one step at a time, we want to get each SINGLE set of accounts working before tackling both at once.

    As for "old nicknames" for your accounts, that's odd. I assume you've double checked that the new nicknames show up within USAA itself (i.e. they "took"). Login to both your accounts at USAA, and look at both sets of nicknames. Maybe the joint accounts have mismatched names, i.e. you set the nicknames in both places, right?

  26. 566 Posted by dtd on 07 Jun, 2021 12:28 PM

    dtd's Avatar

    Oh, by "two at at a time" for Stuart's script, that would be needed if we cannot get the mysterious box in moneydance to work. i.e. You'd run Stuart's script once, get two working, then run the script again with the other two accounts. The idea is to prove that we CAN get all the accounts working, even if not all at the same time (yet).

  27. 567 Posted by Stuart Beesley ... on 07 Jun, 2021 05:41 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    As dtd says (as I do the technical bits, he does the user docs and user help bits. ;-> ) .... steps to try...:
    - Create a new dataset for testing (file/New) and use this. I want to eliminate your dataset as causing issues. Set a master password and 'store passwords'. Restart MD. - Run script on test dataset for each scenario below.... - Try to get one logon working and then your accounts on this logon. - Then try the other login and get the accounts working on that.. If you can't get the above working, there is no point proceeding to 'multiple' logins....

    Also, if you help, open console. Keep it open... I would love to see the messages appearing just before you see the 'Online Banking Signup' screen appear...

  28. 568 Posted by dtd on 07 Jun, 2021 09:11 PM

    dtd's Avatar

    @andreablander - Stuart is considering that your datafile might have some profile issues. So starting with a brand new database to test vs. a copy of an export (which would have the same profile issues) is a good idea.

    As the user doc person, one thing you might not get is "how do i get even one login working when I don't have any accounts in a new dataset? - so create a bunch of empty ones - like "mychecking", "mycreditcard", "jointchecking", "jointcredit", "spouse credit" (or whatever they are). Then you can still run Stuart's script, but then do the "matching" (if you can) using the step 1-7 bit in msg 540, or reread "relinking multiple accounts".
    In this case, you enter a checking or credit card in the script simply to get a working profile.
    Then do what Stuart suggests, now that you have "fresh" accounts to work with.
    Do not complicate this with the "multiple login" bit, just get one login working.

  29. 569 Posted by Stuart Beesley ... on 07 Jun, 2021 09:19 PM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    To clarify... just to eliminate any profile issues... I wouldn’t say ‘corruption’. If the tests work then we can work out why once we know.

  30. 570 Posted by jynxnyx on 08 Jun, 2021 09:25 PM

    jynxnyx's Avatar

    I have run the script ad nauseam and was able to get one account to connect. Going to the online did not work to add the other accounts. Got on the phone with USAA and they were not helpful at all. Told me I should be using my login credentials and not the access-id

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac