Importing .CSV file to Moneydance

David Sullivan's Avatar

David Sullivan

05 Apr, 2021 11:02 AM

Hello Moneydance
I have Version 2020.1 (1928) and am using a Mac Bookpro High Sierra 10.13.6.
When i download a .CSV file from my bank, the file will open in Excel or in Numbers.

I have installed the CSV extension in MD. When I try to import the CSV file is says Unsupported CSV file then File Format Wrong.

Is there any work around as I would love to be able to transfer the data from my 19 century era bank (Bank of Ireland)
Thanks
David

  1. 1 Posted by jeff_l on 05 Apr, 2021 11:29 AM

    jeff_l's Avatar

    Hi David,

    You don’t need to use the CSV extension.

    In Moneydance, go to File → Import. Navigate to where you saved your CSV file. Make sure the account you want to import it into is selected. Click next, with your csv file change the second option on the page from Ignore to Description. Click Finish.

    Attached is your CSV file imported (it will show as Euro not £ if that is your base currency)

    Jeff - fellow user

  2. 2 Posted by davidfsullivan on 05 Apr, 2021 11:47 AM

    davidfsullivan's Avatar

    Hi Jeff
    That was terrific thank you so much.
    Best regards
    David

  3. 3 Posted by -Kevin N. on 05 Apr, 2021 02:27 PM

    -Kevin N.'s Avatar

    Hi David,

    Thank you for attaching a sample of your CSV file.

    Where the CSV Importer comes in handy is when you have more than one financial institution that you d/l CSV files from. In that, it allows for multiple custom file readers.

    Attached is a screenshot of your CSV file using the CSV Importer. The 'Date' column illustrates the US format MM/dd/yyyy.

    One small issue that I noticed with your CSV file was an errant, single comma entered on the last row. It is visible when opening the CSV file using a simple word processor.

    -Kevin N. (not a member of MD support)

  4. 4 Posted by davidfsullivan on 05 Apr, 2021 05:24 PM

    davidfsullivan's Avatar


    On Mon, 5 Apr 2021 at 12:29, jeff_l <[email blocked]> wrote:
    Hi Jeff
    That was terrific thank you so much.
    Best regards
    David


    ==================================================

    From: jeff_l

    Hi David,

    You don’t need to use the CSV extension.

    In Moneydance, go to File → Import. Navigate to where you saved your CSV file. Make sure the account you want to import it into is selected. Click next, with your csv file change the second option on the page from Ignore to Description. Click Finish.

    Attached is your CSV file imported (it will show as Euro not £ if that is your base currency)

    Jeff - fellow user

    On Mon, Apr 05 at 04:02 AM PDT, David Sullivan wrote:

    Hello Moneydance
    I have Version 2020.1 (1928) and am using a Mac Bookpro High Sierra 10.13.6.
    When i download a .CSV file from my bank, the file will open in Excel or in Numbers.

    I have installed the CSV extension in MD. When I try to import the CSV file is says Unsupported CSV file then File Format Wrong.

    Is there any work around as I would love to be able to transfer the data from my 19 century era bank (Bank of Ireland)
    Thanks
    David

    Having trouble reading this? View this discussion online: Importing .CSV file to Moneydance .

    Reply with #ignore to stop receiving notifications for this discussion.

  5. Maddy closed this discussion on 06 Apr, 2021 12:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac