MoneyDance+ Problem/Question

keith's Avatar

keith

04 Oct, 2021 12:52 PM

I am having an issue setting up any accounts with MoneyDance+. I can get through the part of the process for connecting my accounts (choose bank, sign in, get confirmation message about account being linked) but when I go back to MoneyDance I am not able to do anything else on the Online Banking Signup page. The "Next >>" button does nothing when clicked. The only options on that screen are "Connect Your Accounts", "Cancel", "Back" and "Next >>". That screen does say "You're fully connected!". Am I missing something? How do I complete linking and using the account in MoneyDance? This happens with any MD+ accounts I have tried to set up. Thank you for any assistance.

  1. Support Staff 1 Posted by Maddy on 04 Oct, 2021 01:35 PM

    Maddy's Avatar

    Hi Keith,
    Thank you for contacting Moneydance support.

    Firstly, please ensure the preview version you are running is this build Moneydance 2022 (4045).
    Once having subscribed (as you did), you should have been brought back to a page displaying a link to connect your accounts.
    Clicking that normally takes you to Plaid where you can choose your bank/s, enter your login, or (usually) bounce over to your bank’s web site so that you can login directly and then it bounces you back to Plaid to make the connection.

    Also, from within Moneydance have you selected an account from the Side bar and have you selected Online->Set Up Online Banking->Connect Using Moneydance +?

    Would it be possible for you to send us your Moneydance error logs? The logs should include information on what might be causing a problem. The logs are saved on your computer as an errlog.txt file.

    If you're using Windows, the logs should be located at:

    C:\Users\(YourUserName)\.moneydance\errlog.txt

    You should simply copy the content to your next reply on this thread.

    Thank you

    Thank you

    --
    Maddy, Infinite Kind Support

  2. 2 Posted by Stuart Beesley ... on 04 Oct, 2021 01:48 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    The Next button does not work for MD+ - Sean confirmed this.. After setup, you need to exit this window, then restart MD.. Check the Online menu, Match Online Accounts, select MD+ and see if they are there. If accounts are listed, then do the mapping..

    Otherwise, as suggested, send in the logs....

    (not support, just a fellow user)

  3. 3 Posted by keith on 04 Oct, 2021 02:41 PM

    keith's Avatar

    Maddy,

    Thanks for your reply. I was using version 4044 and as suggested I have updated to version 4045 with no change in my results.

    I do select the account on the side-bar and then the option to set up online banking via MD+. I get to the Plaid interface and successfully login and link my account. I get a confirmation pop-up that says "Success! Moneydance will now sync with the selected accounts". I then click on the "Continue" button and I am returned to the webpage that says "Let's get your Moneydance file MoneyDanceData (XXXXX) connected! The Plaid Link interface should appear momentarily...". Then I return to MD and have to close the Online Setup window (as mentioned, the Next button does not work). The account still does not sync (even after a MD restart).

    One additional note - I have never (and still do not) see MD+ listed in the pull-down for "Match online accounts".

    Please find the requested error log attached after performing the MD+ setup.

    Thanks!

  4. 4 Posted by Stuart Beesley ... on 04 Oct, 2021 02:56 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    So you never see this MD+ item in the Match window - as per screen shot?

    FYI - Your log has this error which I know Sean is trying to find.. Perhaps this might be the cause:

    Task com.moneydance.apps.md.view.gui.MDPlusController$LinkCallbackChecker@3ecf0433 failed. You had one job. exception: java.lang.NoSuchMethodError: 'com.google.gson.stream.JsonReader com.google.gson.Gson.newJsonReader(java.io.Reader)'
    

    ... and unfortunately the log shows that no accounts are recognised as configured... Perhaps caused by the error above.....

    (I know this doesn't help you, but perhaps useful info....)

  5. 5 Posted by keith on 04 Oct, 2021 02:59 PM

    keith's Avatar

    That is correct. I see the banks I have connecting directly (not with MD+) listed along with "Other" in the pull-down, but not MoneyDance+.

    Thanks

  6. Support Staff 6 Posted by Maddy on 04 Oct, 2021 02:59 PM

    Maddy's Avatar

    Thank you for sending your logs, Keith!
    I’m sorry to keep you waiting, but I’d like to run your query past the development team who will be able to provide further information.

    --
    Maddy, Infinite Kind Support

  7. 7 Posted by keith on 04 Oct, 2021 03:02 PM

    keith's Avatar

    Maddy,

    No worries....thanks for the help. I am happy to help test on my end as needed to try to fix the issue.

    Thanks!

  8. Support Staff 8 Posted by Maddy on 05 Oct, 2021 04:00 PM

    Maddy's Avatar

    Thank you Keith, we appreciate that!

    Firstly, according to Sean (the head developer) the "Next >>" button not working seems to be normal for the current build, but it should be fixed in the next preview.
    In the meantime you could try to close that window (in your screenshot), or if you haven't already clicked the "Connect your Accounts" button to find and sign-in to your banks, then you should do that.

    Please keep us posted on your progress, Thank you!

    --
    Maddy, Infinite Kind Support

  9. 9 Posted by keith on 05 Oct, 2021 04:21 PM

    keith's Avatar

    Maddy,

    I believe that the screenshot you are referring to was posted by Stuart (another user on the forum) to assist with the issue. As previously mentioned, I have tried to "Connect your Accounts" multiple times and get through the Plaid signup process for my bank but nothing changes in MD and I still can't seem to get linked accounts to work with MD+.

    Thanks

  10. 10 Posted by bschottmi on 07 Oct, 2021 12:30 AM

    bschottmi's Avatar

    Hi - I just activated Moneydance+ running I am on Max OSX 11.6 and using MD 2022 (4045) I get a screen that says "The Plaid Link interface should appear momentarily..." When I go back to MD, I see a screen listing my account so I can map them, but there is no Save button! (User interface note - please add a Save or Done button!!!!)
    My only option is to hit the "red" dot to close the window. SO once setup, how do I download transactions? If I try the old "download all accounts" is behaves as it did before MD+ setup - I get ZERO transactions.
    When I use the Match Online Accounts option I see all the data is there.

  11. 11 Posted by bschottmi on 07 Oct, 2021 12:55 AM

    bschottmi's Avatar

    Sorry - Once I got the confirming email from Schwab and tried Download all accounts I got a new dialogue. It had a drop down option and took the default of "All". It did download transactions, but only for my Schwab Checking account, (Bank) but not for my Investment accounts.
    It continues to say "zero new transactions" for my seven mapped Schwab investment accounts. 8-(
    How can I get back to that wide, drop down to see if I can answer it a different way?

  12. 12 Posted by bschottmi on 07 Oct, 2021 01:13 AM

    bschottmi's Avatar

    One more update for tonight.
    I exited MD, then re-launched. . Now when I go to the Match Online Accounts screen I see all my account twice! One mapped, one not mapped. And still no transactions will download.
    I managed to find errlog.txt in /Users/billschott/Library/Containers/com.infinitekind.MoneydanceOSX/Data/Library/Application Support/Moneydance and have attached it.
    I hope that helps!

  13. 13 Posted by Stuart Beesley ... on 07 Oct, 2021 05:21 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    You use Menu Online>Match Online Accounts to do the mapping.

    There is a dropdown button...
    - Other = list for mapping of manual file imports - Moneydance+ = mapping new MD+ connections - anything else = the older OFX connections mapping.

    You need to map MD+ for MD+
    When you select an account and it appears in the right hand box, then you need to click the ENTER button to save.

  14. 14 Posted by Stuart Beesley ... on 07 Oct, 2021 05:28 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Your console shows you have connected your accounts. You are hitting this error:

    Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException: Cannot invoke "java.lang.Comparable.compareTo(Object)" because the return value of "java.util.function.Function.apply(Object)" is null
    

    Reported....

  15. 15 Posted by Stuart Beesley ... on 07 Oct, 2021 05:28 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Has anyone managed to get any Investment account(s) working with MD+?

  16. 16 Posted by Stuart Beesley ... on 07 Oct, 2021 06:29 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    @bschottmi you should perhaps delete your console log from the above post….

  17. 17 Posted by Stuart Beesley ... on 07 Oct, 2021 08:05 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    An update. Sean has reported that the error (post 14) above is fixed in build 4046 (not yet released).

  18. 18 Posted by Stuart Beesley ... on 07 Oct, 2021 08:06 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Second update... Investment accounts are NOT yet enabled with MD+/Plaid - IK are working on it.....

  19. 19 Posted by keith on 07 Oct, 2021 03:01 PM

    keith's Avatar

    An small update on my issue (original issue in post) - I still have all the same issues as reported, but one interesting thing is using the Toolbox I can see the MD+ profile listed as one I can remove, but the MD+ option does not appear in the Match online accounts pull-down. Removing this profile and adding back in MD+ accounts does not help at all.

  20. 20 Posted by Stuart Beesley ... on 07 Oct, 2021 03:23 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Yes. You are using the current toolbox which does not understand md+. The latest preview does understand and will warn you against doing this. But yes, removing won’t make any difference as MD will recreate it anyway.

  21. 21 Posted by Scott Kirkpatri... on 07 Oct, 2021 10:24 PM

    Scott Kirkpatrick's Avatar

    I installed MD+ 4045 and tried to get my NCSECU accounts working. Everything seemed to go okay with Plaid but they are now telling me they are having problems connecting to NCSECU. If I click on Online->Match Online Accounts, nothing happens at all.

  22. 22 Posted by Scott Kirkpatri... on 07 Oct, 2021 11:37 PM

    Scott Kirkpatrick's Avatar

    Screenshot of Plaid.

  23. 23 Posted by avp2 on 09 Oct, 2021 12:58 AM

    avp2's Avatar

    Update on "need Matching Window row delete". I now have two MD accounts which were matched, and work, via MD+, but that I have since closed out and checked as inactive in the account edit window. I discovered the "inactive" setting does not keep MD+ from downloading these accounts.

    I also now know that the only way to make build 4045 on mac usable when there is a MD+ matched account which does not work (I have two of those also which are set to "none" in the right column of the matching window) is to click ok, or close, the MD comm error screen when it pops up and then set the matching window (which pops up after 2 or 3 comm errors have been ok'd) to some lower part of the MD screen where it is not in the way - the MD comm error window are top level and do not allow other MD functions when open. I have even had the comm error windows come up after closing MD and causing a stop of the backup function - I had to click ok a few times for the backup to finish - my backup drive is slow and takes tens of seconds to write the backup.

    In other words, a matching window row delete, or deactivate, function is badly needed, at least by me.

  24. Support Staff 24 Posted by Sean Reilly on 09 Oct, 2021 01:51 AM

    Sean Reilly's Avatar

    A better matching window for Moneydance+ accounts is coming right up. The ability to refresh expired MD+ connections, remove entries, or update links to banks is also included as is a whole bunch of bug fixes regarding this whole process and how it interacts with OFX downloads.

    Re that Plaid screenshot... wow, I didn't realise that was possible. I hope it's resolved quickly, but please let me know if not and I'll see if I can push for a change.

    Thanks,
    Sean

    --
    Sean Reilly
    Developer, The Infinite Kind
    https://infinitekind.com

  25. 25 Posted by Stuart Beesley ... on 09 Oct, 2021 07:23 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    I’m seeing many problems in 4046. Sorry. Refer my Slack posts.

  26. 26 Posted by Scott Kirkpatri... on 09 Oct, 2021 07:05 PM

    Scott Kirkpatrick's Avatar

    Still problems with Plaid today.

  27. 27 Posted by Stuart Beesley ... on 09 Oct, 2021 08:15 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    4046 is a duff build. You need 4047 - much better!!

  28. 28 Posted by Dan P on 09 Oct, 2021 09:25 PM

    Dan P's Avatar

    I'm using 4047. I'm unable to resolve the issues.
    I deleted all the invalid attempts that show Status Unknown and weren't linked to an account. Then tried relinking the 'good' ones. I keep getting a Plaid error about invalid country code.
    So far nothing is working. But it actually did in 4045. I just need to get rid of all the junk.

    I thnen deleted all of the MD+ accounts.
    Tried re-adding through MD+ and I still get the country code error.

    (I'm in the US)

  29. 29 Posted by Stuart Beesley ... on 09 Oct, 2021 09:35 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    There is a CC issue and I saw on Slack that Sean said he will fix this for the next preview. Also note that when disconnecting a (zombie) link, you will get one popup online error window and then the screen will look unchanged. At this point, exit the md+ window and relaunch it. Refresh is an issue.

  30. 30 Posted by Stuart Beesley ... on 10 Oct, 2021 01:23 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    4050 is out.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac