Moneydance+ not working with Schwab

Jason M's Avatar

Jason M

14 Oct, 2021 12:46 AM

Today I set up Moneydance+ and linked my Schwab Bank/Investment accounts. It is my understanding that Investment accounts are not yet supported, but after linking my accounts - Bank transactions are still not downloading.

  1. 1 Posted by derekkent23 on 14 Oct, 2021 06:53 AM

    derekkent23's Avatar

    I am not support staff, just a user.
    Hi Jason

    I am not a Schwab customer but this user has reported success, see https://infinitekind.tenderapp.com/discussions/problems/73146-unabl...

    Hope they can help.

  2. 2 Posted by Jason M on 14 Oct, 2021 08:07 PM

    Jason M's Avatar

    OK, I have it working now. Couple items of note:

    When linking my Schwab account via Plaid, I was required to temporarily disable my two factor authentication (using the Symantec VIP soft token). The normal two factor authentication via text message worked correctly with Schwab. Now that Plaid linking is complete, I've enabled the Symantec VIP 2FA solution and everything still works.

    After completing the Moneydance+ linking process via Plaid, I went through and changed the passwords on all my bank accounts, since Plaid uses a token and does not store username/password to access accounts. After changing passwords, I started getting errors in Moneydance about bad password (which was definitely not expected). Upon further troubleshooting, I found that I had to visit each account in Moneydance, click Online and choose Set Up Online Banking, then click the Disable button. ONLY after performing this step does Moneydance connect using Moneydance+/Plaid vs "normal" means. Ideally the setup of Moneydance+ should take care of this step for the user when you are linking the accounts, but it's working now so I'm OK.

    Looking forward to support for Schwab investment accounts - once that is in place I will know I can stay with Moneydance instead of migrating back to Quicken.

  3. 3 Posted by ARP on 15 Oct, 2021 11:38 PM

    ARP's Avatar

    Any idea how long until investment accounts are supported?

  4. 4 Posted by Jason M on 15 Oct, 2021 11:43 PM

    Jason M's Avatar

    No idea - I saw a thread here from the developer that indicated they were going to be working on investments - but no timeline or release date was given.

    Now I'm dealing with an issue with my Chase accounts (apparently Chase requires you to relink periodically via Plaid; in my experience every day) so I'm trying to work through that privately with support, hopefully to go back to OFX sync for Chase accounts instead of Moneydance+/Plaid.

    Willing to give it a little time to try to avoid going back to Quicken on Windows in a VM.

  5. 5 Posted by ARP on 24 Oct, 2021 02:17 AM

    ARP's Avatar

    So i linked some non-Schwab investment accounts to Moneydance+ and it is unclear to me if the accounts are updating using Moneydance or using the old (OFX?) download.

    What am I supposed to see when I go to "Online"? At the moment it says "Download [account] transactions" same as always.

    Is there a MD+ user guide?

    I have to say, the constant technical issues with MD have become exhausting. The amount of time I have to spend troubleshooting is wearing me thin.

  6. 6 Posted by dwg on 24 Oct, 2021 02:53 AM

    dwg's Avatar

    I'm a fellow user.

    The only documentation on MD+ is the three Knowledge Base Articles:

    https://infinitekind.tenderapp.com/kb/moneydance

    If Direct Connect is configured it will be used in all cases, even if it fails or gives an error MD+ will not be used. In other words MD+ will only be used if it is configured and if Direct Connect is not.

  7. 7 Posted by ARP on 24 Oct, 2021 03:10 AM

    ARP's Avatar

    Yeah, it's just not working for me.

    I'm using 2022.1 (4056)
    I can see the account is linked to Moneydance+ through plaid
    I delinked from Direct Connect
    I am going to "Online > Download AccountName Transactions"
    I know there are transactions that aren't in the account

    And. Nothing. Happens.

  8. 8 Posted by dtd on 24 Oct, 2021 04:22 AM

    dtd's Avatar

    just a user

    if you are talking investment accounts, they dont work yet

  9. 9 Posted by Stuart Beesley ... on 24 Oct, 2021 04:52 AM

    Stuart Beesley - JUST A FELLOW USER and Toolbox ‘guy’'s Avatar

    If you are sure you have disabled the OFX Direct connections, then try this..
    Install the latest Toolbox extension (build 1043), advanced mode, go to Online Banking menu. Click cleanup banking links...

    Then try the download again...

  10. 10 Posted by ARP on 25 Oct, 2021 12:32 AM

    ARP's Avatar

    DTD, yes, these are investment accts. I knew Schwab investment accounts weren't working; didn't realize it was ALL investment accounts. Since IA's are the only thing I track on MD, MD+ is kinda no help to me at the moment. To all the fellow users, thanks for taking the time to respond.

    Moneydance Crew, if you're listening: I'm in the investment industry and have done my research, and in normal times your product is the best out there for Mac users who want to track their investments. But at the moment, for the average joe - someone who does not have a technical background in programming, software, or general interest in spending time constantly troubleshooting - we are approaching a point where I would call the situation untenable. Countless hours of wasted time troubleshooting, downloading, reading message boards, refreshing, deleting, reinstalling, etc...I am going to put my pencil down and walk away for a few weeks and hope when I return that the kinks have been worked out. I'm rooting for you. Maybe someone can respond to this thread to alert me when it is.

  11. 11 Posted by dtd on 25 Oct, 2021 12:41 AM

    dtd's Avatar

    I'd guess before end of year (i.e. two months), I'm hopeful by Thanksgiving.

    Sean (IK) did this last year with Schwab. Was about 6-8 weeks. Of course it's now about approval by Plaid/Schwab versus setting up a proxy server.

    I need two banks: Schwab and USAA, so I'm watching this, and working as a tester to make sure it works.

  12. 12 Posted by jrg on 25 Oct, 2021 03:55 AM

    jrg's Avatar

    I'm having trouble connecting a credit card account that doesn't use 2FA. Plaid keeps telling me that the login / PW I've entered for the card is wrong, but that is clearly wrong, as I am able to use the login / PW to access the card's website. Any ideas, anyone?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac