Repeated 880012 INVALID_INPUT INVALID_ACCESS_TOKEN errors with Bank Name: Moneydance+

cereece's Avatar

cereece

30 Oct, 2021 11:57 PM

As soon as open up Moneydance, I get a pair of identical error messages, back to back:

"There was an error communicating with your financial institution. The details of this error are below.
Bank Name: Moneydance+
The error code reported by the server was: 880012
Error type: INVALID_INPUT
Error code: INVALID_ACCESS_TOKEN
Request ID: <random-string-of-characters-different-each-error>
Message: could not find matching access token"

These errors periodically (frequently) re-occur during my working session, but my accounts appear to be updating, and it's not obvious if there is anything misconfigured. Any suggestions? Could this be actually happening between one of my financial providers and MD+?

  1. 1 Posted by Stuart Beesley ... on 31 Oct, 2021 06:07 AM

    Stuart Beesley (Mr Toolbox)'s Avatar

    It means that md+ is trying to refresh but Plaid is saying there is a problem. You should go to the online>setup md+ menu and look in the connections list. Hit refresh. You will have an account that’s now not mapped or a connection that’s disconnected. You will need to fix this.

  2. 2 Posted by Patrick Malone on 08 Nov, 2021 11:52 AM

    Patrick Malone's Avatar

    I am getting the same error, even with Moneydance running in the background. I tried Stuart's suggestion, but even though the popup occurred twice during the Refresh process, everything shows as connected after the refresh.

    It would help if the error indicated which financial institution is the problem.

  3. 3 Posted by Stuart Beesley ... on 08 Nov, 2021 01:38 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    It should tell you in the MD+ setup window which one has become disconnected.

  4. 4 Posted by Patrick Malone on 08 Nov, 2021 02:04 PM

    Patrick Malone's Avatar

    Perhaps it should, but as I said, it does not. They all show as connected.

  5. 5 Posted by Stuart Beesley ... on 08 Nov, 2021 02:39 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Are you on preview build 4060? If not, then upgrade.

    Any messages in Help/Console (keep console open). ?

  6. 6 Posted by Patrick Malone on 08 Nov, 2021 04:44 PM

    Patrick Malone's Avatar

    I'm on 4060.

    A sample console entry is

    Received error from Plaid request: Response{protocol=h2, code=400,
    message=, url=https://mdplus.infinitekind.com/plaid/accounts/get}

    parsed error: ErrorResponse{displayMessage='null',
    errorCode='INVALID_ACCESS_TOKEN', errorMessage='could not find matching
    access token', errorType='INVALID_INPUT', requestId='UXSQYDLfQxF09Sc'}

    But the Moneydance+ page still shows "Connected" across the board on a
    refresh.

    I may have found part of the problem. One of the entries on
    Moneydance+ showed "no name" for the institution, but showed it as
    connected. I disconnected it and will see if the problem occurs.

    Thanks.

  7. 7 Posted by cereece on 08 Nov, 2021 04:54 PM

    cereece's Avatar

    That is what I found as well. When I *really* looked at the list instead of just scanning for "Connected"s, I found a "no name" company and disconnected that one. Since then, I haven't had any re-occurrence.

    So, thanks for the help, Stuart! It wasn't exactly it (unless that's what you meant by unmapped >.>), but it was close enough for me to see the problem. :)

    -Carol

  8. 8 Posted by Stuart Beesley ... on 08 Nov, 2021 05:00 PM

    Stuart Beesley (Mr Toolbox)'s Avatar

    Yes, I'm afraid I only give rough guidance from memory... I normally lead you in the right direction.....

  9. 9 Posted by Patrick Malone on 08 Nov, 2021 06:47 PM

    Patrick Malone's Avatar

    It's appreciated!

  10. 10 Posted by cereece on 09 Nov, 2021 04:40 PM

    cereece's Avatar

    Hey, just the "look over here" was helpful. I had already looked there,
    but I looked especially closely to prove to myself that I'd already
    checked that and you must be incorrect when I saw what I'd missed when I
    looked before. >.<  So, very good advice and appreciated!

  11. Maddy closed this discussion on 10 Nov, 2021 04:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac